SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-09-12 14:07:20

johnnyb
New Member
Registered: 2014-05-03
Posts: 2

Brightness keys on laptop

First thanks for the RC1 distro,  I have been using crunchbang on another pc for ages and had been waiting for the iso to become available. I have installed this release on my samsung and am very pleased with it.

I have a samsung r519 laptop and the brightness keys do not work. A previous fix for this under mint (which I have now junked) was to add a line into the grub file along the lines of apci backlight = vendor and update the grub file - I have tried this fix on RC1 and it has no effect. Its not critical as I tend to use the pc as a media server however it would be nice to turn the brightness down (it's at max) when using it for other things. The window does pop up for the brightness function but the up/down keys don't change it. I am not very technical so I would be grateful if you could please bear that in mind if your are able to offer a solution.

Offline

Help fund CrunchBang, donate to the project!

#2 2015-09-12 16:23:14

hhh
Cityspeak
Registered: 2010-08-04
Posts: 3,253

Re: Brightness keys on laptop

A couple of things come to mind. First, see if anything in the Arch Wiki page on backlight helps...
https://wiki.archlinux.org/index.php/Backlight

To change your power settings while in battery mode, run xfce4-power-manager-settings .

Finally, the panel applet for xfce4-power-manager (battery icon) was removed from Debian jessie due to a bug. It's returned in stretch but has not been officially backported yet. BunsenLabs has a backport available, use it at your own risk...
http://pkg.bunsenlabs.org/#jessie-backports

Once you've added the repository and signing key...

sudo apt-get update && sudo apt-get install -t jessie-backports xfce4-power-manager --no-install-recommends

Remove fdpowermon from ~./config/openbox/autostart. Logout and when you login you'll see what looks like the same battery icon as before in your panel, but right-clicking it will give you access to xfce4-power-manager-settings and a brightness slider.

If all is well, feel free to remove fdpowermon from your system.


bunsenlabs     8)     forum mod squad

Offline

#3 2015-09-12 19:07:33

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: Brightness keys on laptop

For the 3.16 kernel that BunsenLabs uses, try adding this parameter to /etc/default/grub (instead of "acpi_backlight=vendor"):

GRUB_CMDLINE_LINUX="video.use_native_backlight=1"

Remember to run `update-grub` afterwards.

If that doesn't work, replace the "=1" with "=0"

You could also try:

acpi_osi="!Windows 2012"

In isolation or in combination.

Offline

#4 2015-09-12 19:25:04

hhh
Cityspeak
Registered: 2010-08-04
Posts: 3,253

Re: Brightness keys on laptop

Also, run xfce4-power-manager-settings and under the General tab toggle "Handle display brightness keys" and see if it does anything.


bunsenlabs     8)     forum mod squad

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo