SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#26 2015-07-08 06:49:04

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: I Switched from mplayer2 to mpv

twoion wrote:

In the code, you have to insert a user name and password.

osdb.LOGIN = '(myusername)'
osdb.PASSWORD = '(mypasswd)'

ok, thanks.
so i registered with opensubtitles.org, and also had to unblock them from an overzealous hostsblock.
the result is still exactly the same:
the same error message, and the ability to download exactly one subtitle in english. if that happens to be one for HI, i end up downloading it manually anyway.
maybe i'll open an issue on github then...

Offline

Help fund CrunchBang, donate to the project!

#27 2015-07-11 15:00:30

paxmark1
#! Junkie
From: Winnipeg, MB Canada
Registered: 2009-07-08
Posts: 263

Re: I Switched from mplayer2 to mpv

I went to mpv in sid and never looked back, I tossed everything else out.  There was a burp or two while developers were loading as dependencies  mplayer | mplayer2 | vlc | and not adding mpv | as another of the possibilities needed for a dependency - but that seems to have stopped.

I just have mpv in debian 8.1 lxde-openbox via deb-multimedia and have had no problems.  No vlc, no mplayer2.  ymmv  (Note- no I do not use deb-multimedia in sid machine) 

Note:  mpv is geared towards ffmpeg development, it should work with the libav fork, but maybe some glitches come in from there.  I have ffmpeg in sid(uction) since the change from libav there and will study about making the transition to ffmpeg from libav in 8.1 .


Jean Vanier wrote "Being Human" and "A Short History of Progress" by Ronald Wright.  Gotta love the Massey Lectures.

Offline

#28 2015-07-22 11:24:58

Nili
#! Die Hard
From: 127.0.0.1
Registered: 2013-03-20
Posts: 811
Website

Re: I Switched from mplayer2 to mpv

mplayer2 make possible to stop my monitor turning off during the play of video.

I have no screensaver, xscreensaver or power manager installed on my system, i don't need any of them
my monitor turn itself off after 10mins on idle, this is enough for me i'd like so to be.

mplayer2 stoped monitor turning off while playing a video while mpv did not, if i open a video and let paused without touching mouse/keyboard. Perhaps it's a issue because of stable package i am using or mpv issue, or a missing packages that was before on mplayer2.

I must find a way to prevent my monitor to turn off during video playing...


# Debian GNU/Linux 8:8.2 (netinst/stable)
# Packages Installed: 541
# Linux debian 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt11-1+deb8u4 (2015-09-19) i686 GNU/Linux
# Startup finished in 2.850s (kernel) + 6.473s (userspace) = 9.324s

Offline

#29 2015-07-22 11:30:46

smacz
#! Junkie
Registered: 2014-12-09
Posts: 250

Re: I Switched from mplayer2 to mpv

$ xset -q

Run that first, take a look at the "Screen Saver" setting and the "DPMS" setting. Then:

$ xset s off

$ xset -dpms

If you want to see what that did, take a look at:

$ xset -h

Then run 'xset -q' again to see that it was turned off.

Alternatively if you study xset -h for a hot minute, you may just set the defaults to something that works for you. But what I said should turn it off completely.

Last edited by smacz (2015-07-22 11:36:21)

Offline

#30 2015-07-22 11:54:35

Nili
#! Die Hard
From: 127.0.0.1
Registered: 2013-03-20
Posts: 811
Website

Re: I Switched from mplayer2 to mpv

Thank you smacz

This was default

$ xset -q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  660    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,built-ins
DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Enabled
  Monitor is On
$ xset s off
$ xset -dpms
xset -h
nili@debian:~$ xset -h
xset:  unknown option -h

usage:  xset [-display host:dpy] option ...
    To turn bell off:
	-b                b off               b 0
    To set bell volume, pitch and duration:
	 b [vol [pitch [dur]]]          b on
    To disable bug compatibility mode:
	-bc
    To enable bug compatibility mode:
	bc
    To turn keyclick off:
	-c                c off               c 0
    To set keyclick volume:
	 c [0-100]        c on
    To control Energy Star (DPMS) features:
	-dpms      Energy Star features off
	+dpms      Energy Star features on
	 dpms [standby [suspend [off]]]     
	      force standby 
	      force suspend 
	      force off 
	      force on 
	      (also implicitly enables DPMS features) 
	      a timeout value of zero disables the mode 
    To set the font path:
	 fp= path[,path...]
    To restore the default font path:
	 fp default
    To have the server reread font databases:
	 fp rehash
    To remove elements from font path:
	-fp path[,path...]  fp- path[,path...]
    To prepend or append elements to font path:
	+fp path[,path...]  fp+ path[,path...]
    To set LED states off or on:
	-led [1-32]         led off
	 led [1-32]         led on
	-led named 'name'   led off
	 led named 'name'   led on
    To set mouse acceleration and threshold:
	 m [acc_mult[/acc_div] [thr]]    m default
    To set pixel colors:
	 p pixel_value color_name
    To turn auto-repeat off or on:
	-r [keycode]        r off
	 r [keycode]        r on
	 r rate [delay [rate]]
    For screen-saver control:
	 s [timeout [cycle]]  s default    s on
	 s blank              s noblank    s off
	 s expose             s noexpose
	 s activate           s reset
    For status information:  q
    To print version: -version

again

$ xset -q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  660    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,built-ins
DPMS (Energy Star):
  Standby: 600    Suspend: 600    Off: 600
  DPMS is Disabled

Some settings changed.

timeout:  0    cycle:  600
DPMS is Disabled

i'm going to use this trick "xset s off/on && xset -dpms/xset +dpms" or to make something on bashrc

Last edited by Nili (2015-07-22 13:03:25)


# Debian GNU/Linux 8:8.2 (netinst/stable)
# Packages Installed: 541
# Linux debian 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt11-1+deb8u4 (2015-09-19) i686 GNU/Linux
# Startup finished in 2.850s (kernel) + 6.473s (userspace) = 9.324s

Offline

#31 2015-07-22 13:40:50

smacz
#! Junkie
Registered: 2014-12-09
Posts: 250

Re: I Switched from mplayer2 to mpv

I believe that you should put it in your ~/.xinitrc file IIRC.

Nope! Try ~/.config/openbox/autostart.

Head_on_a_Stick wrote:

Why use two commands?

xset s off -dpms &

wink

Last edited by smacz (2015-07-22 13:43:05)

Offline

#32 2015-07-22 13:55:15

Nili
#! Die Hard
From: 127.0.0.1
Registered: 2013-03-20
Posts: 811
Website

Re: I Switched from mplayer2 to mpv

Thanks!!! smacz smile

Indeed you're correct "with IIRC", first i will place the command on .xinitrc because i use xinitrc on startup instant of openbox i use spenctrw that start on xinitrc so i'll put the command there that seems optimal solution big_smile

Many thanks for clever idea.
Kindly regards


# Debian GNU/Linux 8:8.2 (netinst/stable)
# Packages Installed: 541
# Linux debian 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt11-1+deb8u4 (2015-09-19) i686 GNU/Linux
# Startup finished in 2.850s (kernel) + 6.473s (userspace) = 9.324s

Offline

#33 2015-07-22 17:40:23

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: I Switched from mplayer2 to mpv

my build mpv notes:

sudo apt-get install libncurses5-dev liblua5.1-0.dev devscripts equivs

get the mpv-build git and cd to source dir

(remove any mpv-build-deps**.deb)
mk-build-deps
sudo dpkg -i mpv-build-deps(TAB).deb
sudo apt-get install -f

./rebuild -j2

after everything happens you can just copy/link mpv-build/mpv/build/mpv to ~/bin.

So no need to suffer from the old-repo-disease on this one.

Last edited by brontosaurusrex (2015-07-22 17:50:56)

Offline

#34 2015-07-26 16:19:26

Nili
#! Die Hard
From: 127.0.0.1
Registered: 2013-03-20
Posts: 811
Website

Re: I Switched from mplayer2 to mpv

Is there a way to keep a little longer the info when we press "i" because the nerd info leaving too soon without being able to read. If i can delay atleast to 5sec would be enough.

In default "the pressed i" stays only 1.5sec.
Thanks in advance.


# Debian GNU/Linux 8:8.2 (netinst/stable)
# Packages Installed: 541
# Linux debian 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt11-1+deb8u4 (2015-09-19) i686 GNU/Linux
# Startup finished in 2.850s (kernel) + 6.473s (userspace) = 9.324s

Offline

#35 2015-07-26 22:18:37

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: I Switched from mplayer2 to mpv

Nili wrote:

mplayer2 make possible to stop my monitor turning off during the play of video.
I have no screensaver, xscreensaver or power manager installed on my system, i don't need any of them
my monitor turn itself off after 10mins on idle, this is enough for me i'd like so to be.
mplayer2 stoped monitor turning off while playing a video while mpv did not, if i open a video and let paused without touching mouse/keyboard. Perhaps it's a issue because of stable package i am using or mpv issue, or a missing packages that was before on mplayer2.
I must find a way to prevent my monitor to turn off during video playing...

fwiw...
i have used these settings for ages:

xset r rate 350 50 ; xset +dpms ; xset dpms 200 300 0 ; \
xset s off ; xset s noblank ; xset s noexpose;

with either mplayer2 or mpv
...
and it has worked, not switching monitor off while watching video.

Offline

#36 2015-07-27 09:31:47

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: I Switched from mplayer2 to mpv

@Nili: you mean osd? (default key is "o" here)

mpv --osd-duration 5000 *

Dunno why they didn't keep this as toggle.

Last edited by brontosaurusrex (2015-07-27 09:33:03)

Offline

#37 2015-07-27 10:30:42

Nili
#! Die Hard
From: 127.0.0.1
Registered: 2013-03-20
Posts: 811
Website

Re: I Switched from mplayer2 to mpv

brontosaurusrex wrote:

@Nili: you mean osd? (default key is "o" here)

mpv --osd-duration 5000 *

Dunno why they didn't keep this as toggle.

Yes OSD i meant,
see the pic...

u3W92nS.png

those info on screen appear every time i press shortcut "i" but disappear pretty fast in 1.2sec. As I can not read it all.

How can i set osd-duration to mpv.conf?

--osd-duration 5000 *

does not provide any change

Thank you


# Debian GNU/Linux 8:8.2 (netinst/stable)
# Packages Installed: 541
# Linux debian 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt11-1+deb8u4 (2015-09-19) i686 GNU/Linux
# Startup finished in 2.850s (kernel) + 6.473s (userspace) = 9.324s

Offline

#38 2015-07-27 10:33:18

Nili
#! Die Hard
From: 127.0.0.1
Registered: 2013-03-20
Posts: 811
Website

Re: I Switched from mplayer2 to mpv

ohnonot wrote:

fwiw...
i have used these settings for ages:

xset r rate 350 50 ; xset +dpms ; xset dpms 200 300 0 ; \
xset s off ; xset s noblank ; xset s noexpose;

with either mplayer2 or mpv
...
and it has worked, not switching monitor off while watching video.

Thank you ohnonot, I'll check and test these settings. Many thanks for sharing.


# Debian GNU/Linux 8:8.2 (netinst/stable)
# Packages Installed: 541
# Linux debian 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt11-1+deb8u4 (2015-09-19) i686 GNU/Linux
# Startup finished in 2.850s (kernel) + 6.473s (userspace) = 9.324s

Offline

#39 2015-07-27 10:36:12

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: I Switched from mplayer2 to mpv

Nili wrote:

How can i set osd-duration to mpv.conf?

--osd-duration 5000 *

does not provide any change

Have you tried:

osd-duration=5000

Offline

#40 2015-07-27 15:12:38

Nili
#! Die Hard
From: 127.0.0.1
Registered: 2013-03-20
Posts: 811
Website

Re: I Switched from mplayer2 to mpv

Head_on_a_Stick wrote:

Have you tried:

osd-duration=5000

Bingo Head_on_a_Stick!!! tongue

That's leave the OSD to stay appears 5sec.

Awesome!!!

Thank you guys


# Debian GNU/Linux 8:8.2 (netinst/stable)
# Packages Installed: 541
# Linux debian 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt11-1+deb8u4 (2015-09-19) i686 GNU/Linux
# Startup finished in 2.850s (kernel) + 6.473s (userspace) = 9.324s

Offline

#41 2015-07-27 17:30:02

Nili
#! Die Hard
From: 127.0.0.1
Registered: 2013-03-20
Posts: 811
Website

Re: I Switched from mplayer2 to mpv

ohnonot, just tried your settings , i put them on my .xinitrc > restarted scpectrwm
- opened a video but my monitor still turned off during video (paused).

thanks anyway...

so far , manually changing plus / minus these ones works fine.

xset b on &
xset s on +dpms &

# Debian GNU/Linux 8:8.2 (netinst/stable)
# Packages Installed: 541
# Linux debian 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt11-1+deb8u4 (2015-09-19) i686 GNU/Linux
# Startup finished in 2.850s (kernel) + 6.473s (userspace) = 9.324s

Offline

#42 2015-07-27 17:34:07

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: I Switched from mplayer2 to mpv

Try:

xset s off -dpms

Offline

#43 2015-07-27 17:43:54

Nili
#! Die Hard
From: 127.0.0.1
Registered: 2013-03-20
Posts: 811
Website

Re: I Switched from mplayer2 to mpv

Head_on_a_Stick wrote:

Try:

xset s off -dpms

Yeah it works Head_on_a_Stick, with plus / minus I meant

xset s off -dpms
xset s off +dpms

But...ohnonot provide a productive solution in automatic form, too bad not worked for me
while what you writed i have added on .xinitrc / restarting wm, works just fine.

Thanks!


# Debian GNU/Linux 8:8.2 (netinst/stable)
# Packages Installed: 541
# Linux debian 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt11-1+deb8u4 (2015-09-19) i686 GNU/Linux
# Startup finished in 2.850s (kernel) + 6.473s (userspace) = 9.324s

Offline

#44 2015-07-27 18:06:38

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: I Switched from mplayer2 to mpv

damo wrote:
Sector11 wrote:

Not in the repos.  sad
...

deb-multimedia wink

But it is in Bunsen ...

mpv (0.6.2-2)
    video player based on MPlayer/mplayer2

just got it to see what all the hoopla is about.

OMG!  Awesome and the man page is only 138 pages long.  Talk about options.


·  ↓   ↓   ↓   ↓   ↓   ↓  ·
BunsenLabs Forums now Open for Registration
·  ↑   ↑   ↑   ↑   ↑   ↑  · BL ModSquad

Offline

#45 2015-07-27 18:07:24

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: I Switched from mplayer2 to mpv

@Nili: oneliners are possible

xset s off s noblank s noexpose -dpms

But unsure if xinitrc is the correct place for that, I would just use your wm's startup script.

Last edited by brontosaurusrex (2015-07-27 18:09:34)

Offline

#46 2015-07-27 19:48:09

Nili
#! Die Hard
From: 127.0.0.1
Registered: 2013-03-20
Posts: 811
Website

Re: I Switched from mplayer2 to mpv

brontosaurusrex wrote:

@Nili: oneliners are possible

xset s off s noblank s noexpose -dpms

But unsure if xinitrc is the correct place for that, I would just use your wm's startup script.

Editing manually xset on xinitrc works and so i'll keep at the moment.

Changes i will make with hand, it's just a plus / minus to add "-dpms" & "+dpms". Im just fine even with that...

Many thanks for all your suggestion.


# Debian GNU/Linux 8:8.2 (netinst/stable)
# Packages Installed: 541
# Linux debian 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt11-1+deb8u4 (2015-09-19) i686 GNU/Linux
# Startup finished in 2.850s (kernel) + 6.473s (userspace) = 9.324s

Offline

#47 2015-07-29 10:32:49

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: I Switched from mplayer2 to mpv

@nili:
maybe i should add that apart from what i posted earlier, i use no power manager or screensaver whatsoever.

and:

Sector11 wrote:
mpv (0.6.2-2)
    video player based on MPlayer/mplayer2

just got it to see what all the hoopla is about.
OMG!  Awesome and the man page is only 138 pages long.  Talk about options.

S11, great you are beginning to see the light.
BUT:

$ pacman -Q mpv
mpv 0.9.2-2

...imagine the difference from 0.6 to 0.9!!!

@nili, this might also explain your difficulties.



======================================

brontosaurusrex wrote:

@Nili: oneliners are possible

xset s off s noblank s noexpose -dpms

But unsure if xinitrc is the correct place for that, I would just use your wm's startup script.

omg, i didn't know one could write it like that...
in any case, it shouldn't matter whether you put it in .xinitrc or your wm's startup script, if your .xinitrc gets executed, that is (i'm not using a display manager, but iirc most display managers do it differently).

Offline

#48 2015-07-29 10:42:33

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: I Switched from mplayer2 to mpv

ohnonot wrote:

in any case, it shouldn't matter whether you put it in .xinitrc or your wm's startup script, if your .xinitrc gets executed, that is (i'm not using a display manager, but iirc most display managers do it differently).

Ok, noted.

Offline

#49 2015-07-29 16:53:20

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: I Switched from mplayer2 to mpv

ohnonot wrote:

S11, great you are beginning to see the light.
BUT:

$ pacman -Q mpv
mpv 0.9.2-2

Ahhh yes but for us Debian people pacman is = a game!
wink  Bought a movie today will see how mpv works with that.


·  ↓   ↓   ↓   ↓   ↓   ↓  ·
BunsenLabs Forums now Open for Registration
·  ↑   ↑   ↑   ↑   ↑   ↑  · BL ModSquad

Offline

Help fund CrunchBang, donate to the project!

#50 2015-07-30 13:10:29

Nili
#! Die Hard
From: 127.0.0.1
Registered: 2013-03-20
Posts: 811
Website

Re: I Switched from mplayer2 to mpv

ohnonot wrote:

...imagine the difference from 0.6 to 0.9!!!
@nili, this might also explain your difficulties.

accurate ohnonot wink


# Debian GNU/Linux 8:8.2 (netinst/stable)
# Packages Installed: 541
# Linux debian 3.16.0-4-686-pae #1 SMP Debian 3.16.7-ckt11-1+deb8u4 (2015-09-19) i686 GNU/Linux
# Startup finished in 2.850s (kernel) + 6.473s (userspace) = 9.324s

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo