SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-07-05 20:45:48

drink_n_drive
Member
From: Argentina
Registered: 2014-08-07
Posts: 36

xfce4-screenshooter captures are "shaded"

Hi again, this time I got an issue with xfce4-screenshooter as I said. It works OK with the whole screen and the active window, but there's a problem when I select an area. This is a picture of a page in LO, which is supposed to be white as snow.

9x9lvzmm.png

Hope you guys (and gals) can give me a hint. TIA!


F5-ing

Offline

Be excellent to each other!

#2 2015-07-05 20:50:30

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: xfce4-screenshooter captures are "shaded"

scrot -s

tongue

Offline

#3 2015-07-05 21:43:37

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: xfce4-screenshooter captures are "shaded"

That bug was supposed to have been fixed in v1.8.1-3. Checking with  v.1.8.2 I get the same issue (nvidia graphics)

Use scrot as HoaS suggested, or shoot the whole screen and crop it with GIMP.

Last edited by damo (2015-07-05 21:44:05)


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#4 2015-07-05 21:56:51

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: xfce4-screenshooter captures are "shaded"

OB Menu:

Label: [ PNG ] 
Execute: scrot -s '%F_%T_$wx$h_Sector11.png' -e 'mv $f ~/images/ & mirage ~/images/$f'

Then crop directly in mirage.  big_smile


·  ↓   ↓   ↓   ↓   ↓   ↓  ·
BunsenLabs Forums now Open for Registration
·  ↑   ↑   ↑   ↑   ↑   ↑  · BL ModSquad

Offline

#5 2015-07-05 22:31:16

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: xfce4-screenshooter captures are "shaded"

SOLUTION: Disable compositing before using xfce4-screenshooter


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#6 2015-07-06 17:56:10

drink_n_drive
Member
From: Argentina
Registered: 2014-08-07
Posts: 36

Re: xfce4-screenshooter captures are "shaded"

damo wrote:

SOLUTION: Disable compositing before using xfce4-screenshooter

How so?


F5-ing

Offline

#7 2015-07-06 17:59:06

drink_n_drive
Member
From: Argentina
Registered: 2014-08-07
Posts: 36

Re: xfce4-screenshooter captures are "shaded"

Sector11 wrote:

OB Menu:

Label: [ PNG ] 
Execute: scrot -s '%F_%T_$wx$h_Sector11.png' -e 'mv $f ~/images/ & mirage ~/images/$f'

Then crop directly in mirage.  big_smile

It would be a good workaround if I didn't handle tons of graphics every day. xfce's scrot has been, by far, the best tool I've encountered, it saves a lot of my time. I just want to understand what's wrong with it and see if it could be fixed.


F5-ing

Offline

#8 2015-07-06 18:01:22

drink_n_drive
Member
From: Argentina
Registered: 2014-08-07
Posts: 36

Re: xfce4-screenshooter captures are "shaded"

Head_on_a_Stick wrote:
scrot -s

tongue

Nice, but no. I handle an insane number of graphics and charts every day, I just cannot afford cropping every single one manually.


F5-ing

Offline

#9 2015-07-06 18:06:03

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: xfce4-screenshooter captures are "shaded"

drink_n_drive wrote:
Head_on_a_Stick wrote:
scrot -s

tongue

Nice, but no. I handle an insane number of graphics and charts every day, I just cannot afford cropping every single one manually.

Did you even try the command?

When the command is passed, you click and drag the area you wish to capture with the mouse pointer -- exactly as you do with xfce4-sceenshooter.

No cropping is required.

The command can be run from dmenu (<Alt>+F2 in a stock #! system) and is thus quicker and easier to use than the (pointless) GUI alternatives.

Offline

#10 2015-07-06 18:06:04

porkpiehat
#! Die Hard
Registered: 2012-10-02
Posts: 1,007

Re: xfce4-screenshooter captures are "shaded"

^^ Read the man page for scrot (or simply try "scrot -s") -- the "s" option allows you to select a portion of the screen, just like xfce4-screenshooter does.

(edit) what HoaS said.

(edit2) Did you try disabling compositing, as damo recommended? We are giving you options, but I don't think you are listening.

Last edited by porkpiehat (2015-07-06 18:08:38)

Offline

#11 2015-07-06 18:07:10

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: xfce4-screenshooter captures are "shaded"

drink_n_drive wrote:
damo wrote:

SOLUTION: Disable compositing before using xfce4-screenshooter

How so?

pkill compton

Offline

#12 2015-07-06 18:09:15

porkpiehat
#! Die Hard
Registered: 2012-10-02
Posts: 1,007

Re: xfce4-screenshooter captures are "shaded"

^ I believe there is also an Openbox menu option in #!, for lazy GUI users.

Offline

#13 2015-07-06 18:12:25

drink_n_drive
Member
From: Argentina
Registered: 2014-08-07
Posts: 36

Re: xfce4-screenshooter captures are "shaded"

Thank you for being the best forum ever!
And excuse me for being unbelievably stupid  8o

[edit]: I drowned in a glass of water, and also had a different concept of scrot command, I didn't expect it to be so simple... my apologies.

Last edited by drink_n_drive (2015-07-06 18:17:18)


F5-ing

Offline

#14 2015-08-25 00:19:04

nicholasalipaz
#! Member
Registered: 2015-02-05
Posts: 72

Re: xfce4-screenshooter captures are "shaded"

I just ran into same issue.  Here is what I did to replace xfce4-screenshooter with shutter:

$ sudo apt-get remove xfce4-screenshooter -y
$ sudo apt-get install shutter

Find lines in ~/.config/openbox/rc.xml that xfce4-screenshooter and remove the xml keybindings, replace with:

    <keybind key="Print">
      <action name="Execute">
        <command>shutter -f</command>
      </action>
    </keybind>
    <keybind key="A-Print">
      <action name="Execute">
        <command>shutter -w</command>
      </action>
    </keybind>
    <keybind key="S-Print">
      <action name="Execute">
        <command>shutter -s</command>
      </action>
    </keybind>

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo