SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-06-09 18:33:46

Colossal_Crunch
#! CrunchBanger
Registered: 2015-05-06
Posts: 154

Problem with keyboard's auto-repeat

I own a logitech K400r and it I can't seem to get any key to repeat when I hold it down. I'm not sure what happened, but I was working on trying fix a different problem involving multiple windows.
Here is the output of: xset -q

jack@SyCog:~$ xset -q
Keyboard Control:
  auto repeat:  off    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  660    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  0    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  0
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,built-ins
DPMS (Energy Star):
  Standby: 600    Suspend: 0    Off: 900
  DPMS is Enabled
  Monitor is On

Offline

Be excellent to each other!

#2 2015-06-09 18:56:31

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: Problem with keyboard's auto-repeat

You have "auto repeat: off"

Find out the usage of xset eg:

man xset | grep repeat

(We keep saying to you to read the instructions! wink )


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#3 2015-06-09 19:05:06

Colossal_Crunch
#! CrunchBanger
Registered: 2015-05-06
Posts: 154

Re: Problem with keyboard's auto-repeat

damo wrote:

You have "auto repeat: off"

Find out the usage of xset eg:

man xset | grep repeat

(We keep saying to you to read the instructions! wink )

(damo, don't give up! I cane be taught!!!!_)

damo, I did like you said and I didn't see the answer, but I kept reading the man page. Suddenly it clicked I could take what the man page was talking about and r with xset.

I might of had a thought today! Thank you!

Offline

#4 2015-06-10 06:32:11

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: Problem with keyboard's auto-repeat

so is this solved now?

for what it's worth, you have to reapply those settings everytime you login, or maybe there's a way to do it through ~/.Xresources...

i have this in my ~/.xinitrc (i like it speedy):

xset r rate 350 50

Offline

#5 2015-06-10 06:35:00

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: Problem with keyboard's auto-repeat

^ In CrunchBang (and BunsenLabs) the keyboard repeat is set in ~/.config/openbox/autostart wink

Offline

#6 2015-06-10 14:42:39

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: Problem with keyboard's auto-repeat

^ thanks for pointing that out.

i still think it should be possible to configure it via .Xresources, or maybe even some file in /etc/X11/xorg.conf.d...
i just never got around to figuring it out,  so every xset call slows my login down by 10µs...  wink

Offline

#7 2015-06-10 15:26:01

Colossal_Crunch
#! CrunchBanger
Registered: 2015-05-06
Posts: 154

Re: Problem with keyboard's auto-repeat

Oh I see what happen now.  :8

I was trying to keep multiple windows from popping up when I used hotkeys. I had adjusted the ~/.config/openbox/autostart to "r off" but it didn't seem to change anything. When I restarted it must of turned it off and I didn't realize it. Really dumb mistake on my part sorry, but thanks for all the help.

Last edited by Colossal_Crunch (2015-06-10 15:26:53)

Offline

#8 2015-06-10 17:41:18

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: Problem with keyboard's auto-repeat

ohnonot wrote:

i still think it should be possible to configure it via .Xresources

Yes, adding it to .Xresources would also work as that is parsed during startup automatically by BunsenLabs.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo