SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#26 2015-04-16 11:54:14

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: After installing, does not detect wifi

So what is the output of this command now:

ip r

(no need to use `sudo` for this one)

EDIT: make sure the cable is disconnected before running the command.

Last edited by Head_on_a_Stick (2015-04-16 11:54:46)

Offline

Help fund CrunchBang, donate to the project!

#27 2015-04-16 11:55:27

rodolfo1477
Member
Registered: 2015-04-15
Posts: 37

Re: After installing, does not detect wifi

If necessary I can tell you all hardware from my computer.

Offline

#28 2015-04-16 11:58:05

rodolfo1477
Member
Registered: 2015-04-15
Posts: 37

Re: After installing, does not detect wifi

Disconnected:

rodolfo@crunchbang:~$ ip r
rodolfo@crunchbang:~$ ip r
rodolfo@crunchbang:~$ sudo ip r
rodolfo@crunchbang:~$


Nothing happens

Connected:

default via 192.168.1.1 dev eth0  proto static
192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.105

Offline

#29 2015-04-16 12:03:39

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: After installing, does not detect wifi

OK, try this:

sudo modprobe -r acer-wireless

Then see if you can connect.

If that works, run this command:

sudo tee /etc/modprobe.d/acer_wireless.conf <<< "blacklist acer-wireless"

The module name may not be correct, you can check the full name using:

lsmod|grep acer

Offline

#30 2015-04-16 12:07:03

rodolfo1477
Member
Registered: 2015-04-15
Posts: 37

Re: After installing, does not detect wifi

I'm no expert, but I do not like ... WTF?

rodolfo@crunchbang:~$ sudo modprobe -r acer-wireless
[sudo] password for rodolfo: 
FATAL: Module acer-wireless not found.
rodolfo@crunchbang:~$ 
rodolfo@crunchbang:~$ sudo tee /etc/modprobe.d/acer_wireless.conf <<< "blacklist acer-wireless"
blacklist acer-wireless
rodolfo@crunchbang:~$ lsmod|grep acer
acer_wmi               21651  0 
sparse_keymap          12680  1 acer_wmi
rfkill                 18516  5 cfg80211,acer_wmi,bluetooth
wmi                    13051  3 acer_wmi,mxm_wmi,nouveau

Offline

#31 2015-04-16 12:13:43

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: After installing, does not detect wifi

Yeah, I got the name wrong...

sudo rm /etc/modprobe.d/acer_wireless.conf
sudo modprobe -r acer_wmi

Only run the next command if the `modprobe -r` command worked (ie, it did not give an error message and your wi-fi starts working):

sudo tee /etc/modprobe.d/acer_wmi.conf <<< "blacklist acer_wmi"

EDIT: typo in my first command -- check it again.

Last edited by Head_on_a_Stick (2015-04-16 12:17:07)

Offline

#32 2015-04-16 12:16:52

rodolfo1477
Member
Registered: 2015-04-15
Posts: 37

Re: After installing, does not detect wifi

rodolfo@crunchbang:~$ sudo rm /etc/modprobe.d/acer_wrieless.conf
[sudo] password for rodolfo: 
rm: no se puede borrar «/etc/modprobe.d/acer_wrieless.conf»: No existe el fichero o el directorio
rodolfo@crunchbang:~$ sudo modprobe -r acer_wmi
rodolfo@crunchbang:~$ 

rm: no se puede borrar «/etc/modprobe.d/acer_wrieless.conf»: No existe el fichero o el directorio -> You can not erase "/etc/modprobe.d/acer_wrieless.conf ': No such file or directory

I think not work

Offline

#33 2015-04-16 12:23:19

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: After installing, does not detect wifi

rodolfo1477 wrote:

I think not work

I had a typo in the command (see my EDIT), try it again with the correct spelling.

It looks like the module removal worked so run the last command in my post #31 and reboot your machine.

Offline

#34 2015-04-16 12:27:13

rodolfo1477
Member
Registered: 2015-04-15
Posts: 37

Re: After installing, does not detect wifi

rodolfo@crunchbang:~$ sudo modprobe -r acer_wmi
rodolfo@crunchbang:~$ sudo rm /etc/modprobe.d/acer_wireless.conf
rodolfo@crunchbang:~$ sudo modprobe -r acer_wmi
rodolfo@crunchbang:~$ sudo tee /etc/modprobe.d/acer_wmi.conf <<< "blacklist acer_wmi"
blacklist acer_wmi

now restart.

Offline

#35 2015-04-16 12:33:00

rodolfo1477
Member
Registered: 2015-04-15
Posts: 37

Re: After installing, does not detect wifi

Nothing ... nothing happens. sad

Offline

#36 2015-04-16 12:36:08

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: After installing, does not detect wifi

Well I'm all out of ideas, sorry.
sad

It may be best to remove the configuration file if it doesn't work:

sudo rm /etc/modprobe.d/acer_wmi.conf

Offline

#37 2015-04-16 12:37:57

rodolfo1477
Member
Registered: 2015-04-15
Posts: 37

Re: After installing, does not detect wifi

Head_on_a_Stick wrote:

Well I'm all out of ideas, sorry.
sad

It may be best to remove the configuration file if it doesn't work:

sudo rm /etc/modprobe.d/acer_wmi.conf

Thank you very much sad

Offline

#38 2015-04-16 12:51:05

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: After installing, does not detect wifi

rodolfo1477 wrote:

Already installed and worked perfect until after installing everything the terminal box (all I said "and") the internet goes down and does not connect to Wi-fi, in fact, any connection does not appear Wi-fi, when I could previously navigate.

Are you saying it was working when you first installed it and then stopped working some time afterwards?

If that is the case then we need to see:

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d
apt-cache policy

Offline

#39 2015-04-16 13:36:20

rodolfo1477
Member
Registered: 2015-04-15
Posts: 37

Re: After installing, does not detect wifi

Head_on_a_Stick wrote:
rodolfo1477 wrote:

Already installed and worked perfect until after installing everything the terminal box (all I said "and") the internet goes down and does not connect to Wi-fi, in fact, any connection does not appear Wi-fi, when I could previously navigate.

Are you saying it was working when you first installed it and then stopped working some time afterwards?

If that is the case then we need to see:

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d
apt-cache policy

Of the many times to install and reinstall, that happened to me only twice...

Offline

#40 2015-04-16 16:55:04

userx-bw
#! Die Hard
From: stuck in an unknown reality
Registered: 2013-11-19
Posts: 735

Re: After installing, does not detect wifi

NetworkManager has 1.0 out -- you have to build it and install it yourself my experience is that it makes you update to jessie to get the dependences all of the dev packages -- had in mine once worked great. I had to install it because the jessie "upgrade" NetworkManager stopped fully functioning with the version it installed so I put 1.0 in and it went back to great working condition. 

two be sure your on wlan0 not lan0 for most wifi not cable

https://www.linux.com/learn/tutorials/3 … hese-tools


"How can you learn how to fix it, if you don't break it first? :8
"the only way to get away with murder is - by killing time" swp 1997  8o
"A computer is only as smart as the person using it"
"Just plug it in and see if it blows up, if not then take it apart and figure out how it works."

Offline

#41 2015-04-16 16:56:11

userx-bw
#! Die Hard
From: stuck in an unknown reality
Registered: 2013-11-19
Posts: 735

Re: After installing, does not detect wifi

rodolfo1477 wrote:
Head_on_a_Stick wrote:
rodolfo1477 wrote:

Already installed and worked perfect until after installing everything the terminal box (all I said "and") the internet goes down and does not connect to Wi-fi, in fact, any connection does not appear Wi-fi, when I could previously navigate.

Are you saying it was working when you first installed it and then stopped working some time afterwards?

If that is the case then we need to see:

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d
apt-cache policy

Of the many times to install and reinstall, that happened to me only twice...




NetworkManager has 1.0 out -- https://wiki.gnome.org/Projects/NetworkManager -- you have to build it and install it yourself my experience is that it makes you update to jessie to get the dependences all of the dev packages -- had in mine once worked great. I had to install it because the jessie "upgrade" NetworkManager stopped fully functioning with the version it installed so I put 1.0 in and it went back to great working condition.

two be sure your on wlan0 not lan0 for most wifi not cable

https://www.linux.com/learn/tutorials/3 … hese-tools

Last edited by userx-bw (2015-04-16 17:01:41)


"How can you learn how to fix it, if you don't break it first? :8
"the only way to get away with murder is - by killing time" swp 1997  8o
"A computer is only as smart as the person using it"
"Just plug it in and see if it blows up, if not then take it apart and figure out how it works."

Offline

#42 2015-04-17 16:57:20

rodolfo1477
Member
Registered: 2015-04-15
Posts: 37

Re: After installing, does not detect wifi

userx-bw wrote:
rodolfo1477 wrote:
Head_on_a_Stick wrote:

Are you saying it was working when you first installed it and then stopped working some time afterwards?

If that is the case then we need to see:

cat /etc/apt/sources.list
ls /etc/apt/sources.list.d
apt-cache policy

Of the many times to install and reinstall, that happened to me only twice...




NetworkManager has 1.0 out -- https://wiki.gnome.org/Projects/NetworkManager -- you have to build it and install it yourself my experience is that it makes you update to jessie to get the dependences all of the dev packages -- had in mine once worked great. I had to install it because the jessie "upgrade" NetworkManager stopped fully functioning with the version it installed so I put 1.0 in and it went back to great working condition.

two be sure your on wlan0 not lan0 for most wifi not cable

https://www.linux.com/learn/tutorials/3 … hese-tools

when  entered "https://www.linux.com/learn/tutorials/3" i get this "404 - Article # 3 not found"

Offline

#43 2015-04-17 17:51:10

rodolfo1477
Member
Registered: 2015-04-15
Posts: 37

Re: After installing, does not detect wifi

With wifi radar i can see my wifi.

HOW I CONNECT TO WIFI?  big_smile

Offline

#44 2015-04-17 17:55:12

rodolfo1477
Member
Registered: 2015-04-15
Posts: 37

Re: After installing, does not detect wifi

rodolfo@crunchbang:~$ sudo iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: 74:EA:3A:A4:EF:56
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=70/70  Signal level=-33 dBm  
                    Encryption key:on
                    ESSID:"Vanessa fabulosa Manzo"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=00000000e588f580
                    Extra: Last beacon: 212ms ago
                    IE: Unknown: 001656616E6573736120666162756C6F7361204D616E7A6F
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 03010B
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    IE: Unknown: DD180050F2020101060003A4000027A4000042435E0062322F00
                    IE: Unknown: DD1E00904C334E101BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 2D1A4E101BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C340B071B00000000000000000000000000000000000000
                    IE: Unknown: 3D160B071B00000000000000000000000000000000000000
                    IE: Unknown: DD0900037F01010000FF7F
                    IE: Unknown: DD0A00037F04010004000000
                    IE: Unknown: DD890050F204104A000110104400010210570001001041000100103B00010310470010565AA94967C14C0EAA8FF349E6F593111021000754502D4C494E4B10230009544C2D57523934314E10240003322E3010420001311054000800060050F204000110110019576972656C65737320526F7574657220544C2D57523934314E100800020084103C000101
          Cell 02 - Address: 54:E6:FC:F4:E6:52
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=32/70  Signal level=-78 dBm  
                    Encryption key:on
                    ESSID:"Red_Manzo"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000001f4c83d8a3
                    Extra: Last beacon: 1436ms ago
                    IE: Unknown: 00095265645F4D616E7A6F
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030101
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: WPA Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    IE: Unknown: DD180050F2020101860003A4000027A4000042435E0062322F00
                    IE: Unknown: DD1E00904C334E111BFF00000000000000000000000000000000000000000000
                    IE: Unknown: 2D1A4E111BFF00000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C3401051900000000000000000000000000000000000000
                    IE: Unknown: 3D1601051900000000000000000000000000000000000000
                    IE: Unknown: DD0900037F01010000FF7F
                    IE: Unknown: DD0A00037F04010000004000
                    IE: Unknown: DD850050F204104A0001101044000102103B000103104700100000000000001000000054E6FCF4E6521021000754502D4C494E4B10230009544C2D57523734314E10240007312E302F322E3010420003312E301054000800060050F204000110110019576972656C65737320526F7574657220544C2D57523734314E100800020086103C000101
          Cell 03 - Address: 00:22:75:C3:C0:DE
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=10/70  Signal level=-100 dBm  
                    Encryption key:on
                    ESSID:"ALESSIO WIFI"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000002664fd718b
                    Extra: Last beacon: 1216ms ago
                    IE: Unknown: 000C414C455353494F2057494649
                    IE: Unknown: 010882848B961224486C
                    IE: Unknown: 030106
                    IE: Unknown: 2A0104
                    IE: Unknown: 32040C183060
                    IE: Unknown: 2D1AEE1113FFFF0000010000000000000000000000000C0000000000
                    IE: Unknown: 3D1606070500000000000000000000000000000000000000
                    IE: Unknown: 3E0100
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: 7F0101
                    IE: Unknown: DD07000C4307000000
                    IE: Unknown: DD1E00904C33EE1113FFFF0000010000000000000000000000000C0000000000
                    IE: Unknown: DD1A00904C3406070500000000000000000000000000000000000000

my wifi is "Vanessa fabulosa Manzo"
How do I connect now?

Offline

#45 2015-04-17 18:01:35

rodolfo1477
Member
Registered: 2015-04-15
Posts: 37

Re: After installing, does not detect wifi

2dj49yd_jpg.jpg

How do I connect now?  neutral

=== Mod Edit ===

Please use thumbnails

- To help those of us with slow connections and the CrunchBang server bandwidth.  Most image hosting sites will automatically generate thumbnail codes for you.

Of course use whatever service you wish, but please, get a thumbnail and use that or it will be changed by a moderator.

Avoid the large thumbnail www.imgur.com code, use the "medium" link thumbnail.  An example of the code:

[url=http://imgur.com/your_image_code][img]http://i.imgur.com/your_image_codem.jpg[/img][/url]

Notice the m in your_image_codem.jpg in the IMG code block

Users have been using www.postimage.org lately which does a nice job and is Multi-lingual as well.  Upload your image to the site and grab the Thumbnail for Forums (1) code.

Here is a generic piece of code if you need to create your own thumbnail:

[url=http://link.to.your.fullsized.image][img]http://link.to.your.thumbnail.image[/img][/url]

Offline

#46 2015-04-17 18:29:06

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: After installing, does not detect wifi

rodolfo1477 wrote:

How do I connect now?  neutral

I've never used Wi-Fi Radar, but it looks like you _are_ connected.

Offline

#47 2015-04-17 18:52:12

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: After installing, does not detect wifi

That screenshot says you are connected to wifi. The network manager icon looks like it says you are connected to ethernet.

What does Network Manager say? (Disconnect ethernet, reconnect wireless)

You keep asking "How to connect" but Head_on_a_Stick has already explained to you the ways to do it.


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#48 2015-04-18 07:36:37

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: After installing, does not detect wifi

dear op, rodolfo,
it seems your problem is a little more complex than the usual firmware missing.
what you have to do:

  • first of all, rename your ssid to something more straightfoward (how about "rodolfo"?)

  • try rebooting your router. mine sometimes locks up, displaying similar symptoms: connected, but no internet

  • i seem to remember similar problems that had sth to do with encryption. disable encryption, just to see if that helps.

  • use the name of your wifi device (Atheros AR242x AR542x, you have to try out various phrases) to search the internet if other people have had similar problems. preferably add "debian" to your search phrase, and if that doesn't give results, just "linux"

there's more things we can try, but start with that.

Last edited by ohnonot (2015-04-18 07:39:02)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo