SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-01-17 14:47:15

thrax01
New Member
Registered: 2015-01-17
Posts: 5

SOLVED - Upgraded sources to Jessie repos, upgraded system, disaster.

Hello, I would like to clarify what I mean by disaster, but first a little backstory.

I was wanting to test out what #! 12 Janice might look and feel like, so I followed this guide:

https://jschueths.wordpress.com/2014/04 … t-release/

and upon reboot, my icons were brown, the network manager applet was gone and I wasn't able to use the ALT+F3 command.

I was able to fix the icons via various threads on this fourm, manually installing and removing certain packages etc.  but in the end, I did a full reinstall with my #! 11 disc.  I am most likely going to wait for #! 12 ISO to be offically released, then reinstall that way.

Now, with that out of the way, can anyone tell me, WHAT I did wrong, besides following some random guide on the Internet.  Have any of you had a problem in doing this?  Was I too impatient? big_smile

Last edited by thrax01 (2015-01-17 15:07:54)

Offline

Help fund CrunchBang, donate to the project!

#2 2015-01-17 14:58:58

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: SOLVED - Upgraded sources to Jessie repos, upgraded system, disaster.

thrax01 wrote:

Now, with that out of the way, can anyone tell me, WHAT I did wrong, besides following some random guide on the Internet.  Have any of you had a problem in doing this?  Was I too impatient? big_smile

Things to watch out for...

GTK3 themes may well be broken, so find one that works.
NetworkManager may get removed if you aren't careful.
I don't know if the Janice repos are just a placeholder atm.
Lots of other stuff....

The best place for advice is on these forums IMO - a guide here that could cause you problems will get jumped on pretty quick. I have upgraded installations to jessie/sid many times, and I now know the gotchas, but I'm waiting for Janice before jumping the gun.


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#3 2015-01-17 15:06:54

thrax01
New Member
Registered: 2015-01-17
Posts: 5

Re: SOLVED - Upgraded sources to Jessie repos, upgraded system, disaster.

Alright, thank you damo.  I'll try not to be so impulsive next time.  wink   That never works out, broke a motherboard late at night 'cause I forgot to remove a screw from the laptop.  Thank godness it was mine.  lol

Offline

#4 2015-01-17 15:47:26

olegabrielz
#! Junkie
From: Norway
Registered: 2014-06-14
Posts: 442

Re: SOLVED - Upgraded sources to Jessie repos, upgraded system, disaster.

I've done some upgrades to both testing and unstable (using unstable for a while now). And I always uninstall tint2, tint2conf and slimconf before I drop into tty1, stops slim and do the upgrade. After the upgrade I just install tint2 and then restart. Works every time. The only thing I loose is the battery applet and the slimconf gui. But that doesn't bother me to the point of trying to find a solution wink

Edit: typo  :8

Last edited by olegabrielz (2015-01-17 15:50:53)

Offline

#5 2015-01-17 15:48:11

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: SOLVED - Upgraded sources to Jessie repos, upgraded system, disaster.

thrax01 wrote:

Thank godness it was mine.  lol

?? big_smile


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#6 2015-01-17 16:03:01

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: SOLVED - Upgraded sources to Jessie repos, upgraded system, disaster.

Just a note on my part ...
I find it best to: dist-upgrade ... on a fresh install using only one repo if going to sid:

## DEBIAN
deb http://ftp.us.debian.org/debian/ sid main contrib non-free

and two if going to testing

## DEBIAN
deb http://ftp.us.debian.org/debian/ testing main contrib non-free
## DEBIAN SECURITY
deb http://security.debian.org/ testing/updates main contrib non-free

Of course your choice of mirrors may vary.

And then like damo says - be prepared to fix things like themes, etc

@ damo - a thought - can you put NM on hold before doing the dist-upgrade?  Will the hold be honoured?

@ olegabrielz - oops, have to agree with tint2conf - I dropped that a long time ago.  It does mess up a dist-upgrade - never bothered to reinstall it.  But why slimconf?


·  ↓   ↓   ↓   ↓   ↓   ↓  ·
BunsenLabs Forums now Open for Registration
·  ↑   ↑   ↑   ↑   ↑   ↑  · BL ModSquad

Offline

#7 2015-01-17 16:21:00

olegabrielz
#! Junkie
From: Norway
Registered: 2014-06-14
Posts: 442

Re: SOLVED - Upgraded sources to Jessie repos, upgraded system, disaster.

^ Thanks for noticing. I forgot to mention it. The slimconf gui dosen't work after upgrade, so why keep it? wink  I just edit the /etc/slim.conf manually instead smile

Edit: I just grabbed and installed the slimconf from the waldorf repository just to se what was the problem, and this is what I got:

ole@dell:~$ sudo slimconf

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:57:17: Theming engine 'unico' not found

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:289:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:323:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1828:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1845:21: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1861:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:2146:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets-backdrop.css:16:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets-backdrop.css:93:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets-backdrop.css:183:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets-backdrop.css:503:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets-backdrop.css:850:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets-backdrop.css:925:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets-backdrop.css:941:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets-backdrop.css:957:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets-backdrop.css:1012:21: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets-backdrop.css:1020:21: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets-backdrop.css:1034:21: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets-backdrop.css:1103:21: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gtk-widgets-backdrop.css:1237:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: gnome-panel.css:94:21: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: nautilus.css:18:18: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: nautilus.css:18:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: nautilus.css:81:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: nautilus.css:86:20: Not using units is deprecated. Assuming 'px'.

(slimconf:4197): Gtk-WARNING **: Theme parsing error: nautilus.css:145:20: Not using units is deprecated. Assuming 'px'.
Traceback (most recent call last):
  File "/usr/bin/slimconf", line 121, in <module>
    builder.get_object("sessions").set_text(sessions)
NameError: name 'sessions' is not defined

Edit2: Changing the widgets theme from waldorf to greybird solved the gtk issue. But still:

ole@dell:~$ sudo slimconf
[sudo] password for ole: 
Traceback (most recent call last):
  File "/usr/bin/slimconf", line 121, in <module>
    builder.get_object("sessions").set_text(sessions)
NameError: name 'sessions' is not defined

This issue is already discussed but not solved in this thread.

Last edited by olegabrielz (2015-01-17 17:31:42)

Offline

#8 2015-01-17 17:49:47

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: SOLVED - Upgraded sources to Jessie repos, upgraded system, disaster.

@Sector11
I can't remember what the exact problem was last time re NM, but when I saw it was due to be removed along with a bunch of other stuff I installed wicd first, then let it all go through.

@olegabrielz
slim.conf is so easy to edit that a problem gui is a waste of time IMO wink

@OP
Install "apt-listbugs" before trying to upgrade to testing/sid, and learn about using "apt-mark hold/unhold". It will save you tons of grief!


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#9 2015-01-17 18:07:49

olegabrielz
#! Junkie
From: Norway
Registered: 2014-06-14
Posts: 442

Re: SOLVED - Upgraded sources to Jessie repos, upgraded system, disaster.

I found out what the issue was. When upgrading it replaces or modifies the /etc/slim.conf in the sessions section. I just changed that section and now it works smile But I have to agree with you damo: Why bother to use time on the gui when the slim.conf is that easy to configure wink

Last edited by olegabrielz (2015-01-17 18:09:28)

Offline

#10 2015-01-17 18:28:34

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: SOLVED - Upgraded sources to Jessie repos, upgraded system, disaster.

Well, that answers two of my questions.

Interesting about NM - is not something that's in the waldorf repo ... straight Debian.

I don't even edit slim.conf - I like it as it is. Didn't know it didn't work after upgrading.
Live & Learn


·  ↓   ↓   ↓   ↓   ↓   ↓  ·
BunsenLabs Forums now Open for Registration
·  ↑   ↑   ↑   ↑   ↑   ↑  · BL ModSquad

Offline

#11 2015-01-17 18:59:53

hhh
Cityspeak
Registered: 2010-08-04
Posts: 3,253

Re: SOLVED - Upgraded sources to Jessie repos, upgraded system, disaster.

@thrax, brown icons? I haven't heard of that one before! To add to the great advice offered already...

~Yes, the Janice repo is empty, so this didn't do anything or hurt anything.

~Read the upgrade release notes for upgrading from wheezy. Debian recommends disabling apt pinning, dist-upgrading out of the x session (meaning switch to run-level 3), doing apt-get upgrade before doing apt-get dist-upgrade and purging packages before reboot. Read this entire chapter...
https://www.debian.org/releases/testing … ng.en.html

@damo, oleG, Sector, I wonder if SLiM is the reason nm-applet isn't starting...
https://wiki.archlinux.org/index.php/di … th_systemd


bunsenlabs     8)     forum mod squad

Offline

#12 2015-01-17 19:07:36

olegabrielz
#! Junkie
From: Norway
Registered: 2014-06-14
Posts: 442

Re: SOLVED - Upgraded sources to Jessie repos, upgraded system, disaster.

@hhh: I have not experienced the brown icons either. And I have never had the problem with nm-applet. Like Sector11 already suggested, I only use the official debian repositories, and therefore I delete the /etc/preferences.

Offline

#13 2015-01-17 19:17:12

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: SOLVED - Upgraded sources to Jessie repos, upgraded system, disaster.

nm-applet hasn't been a problem for me with slim as login manager.


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#14 2015-01-17 19:49:13

hhh
Cityspeak
Registered: 2010-08-04
Posts: 3,253

Re: SOLVED - Upgraded sources to Jessie repos, upgraded system, disaster.

Yeah, a shot in the dark. The wiki I linked specifies Entrance and MDM, but I thought it funny that thrax had the same issue.


bunsenlabs     8)     forum mod squad

Offline

#15 2015-01-17 21:45:07

thrax01
New Member
Registered: 2015-01-17
Posts: 5

Re: SOLVED - Upgraded sources to Jessie repos, upgraded system, disaster.

Thank you all for the replies, I greatly appreciate it, and I am using my fathers "enlarged letter" keyboard, they keys are laid out different and as such I cannot touch type accurately.  About the brown icons, I may have been misinterpreted.  What I mean, is instead of the gray / light gray look, they turn to a light brown, bronze almost.  They keep their designs, but they change color.  The nm-applet I managed to get back before the reinstall, and it was showing blue bars.  The clipit icon was brown.  It's as if the upgrade I preformed undid the gray theming to the icons, reverted them back to their original color schemes.   

  Now, I am a little OCD, so it just seemed so out of place.   lol  When I decided to reinstall, I backed up all my data to both external HDDs, disconnected them and tested out that "rm -rf /*" command.   Thank goodness with Linux distros, you can reinstall as many times as you want, for free, unlike that other OS that I shall not name and which I'm in the process of purging from the household.    ]:D  ]:D

Offline

#16 2015-01-19 21:01:46

spacex
ew
From: Norway
Registered: 2015-01-17
Posts: 385
Website

Re: SOLVED - Upgraded sources to Jessie repos, upgraded system, disaster.

You get the brown icons because the gnome icon theme gets upgraded if you have commented out the waldorf repo. If you want the grey ones back, just download the original theme from here: http://packages.crunchbang.org/waldorf/ … g2_all.deb

and replace the one that currently is in /usr/share/themes.


Regards,
spacex/ew
http://tweaklinux.org

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo