SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2012-08-11 04:38:17

paxmark1
#! Junkie
From: Winnipeg, MB Canada
Registered: 2009-07-08
Posts: 263

Solved: /etc/modprobe.d/fbdev-blacklist.conf

Waldorf 32 bit Radeon driver (EEEbox with AMD innards)

Saw a warning last two times when safe-upgrading.  I checked around and saw it was mentioned in a Jul 17 post as a side issue which was never addressed. 

 libkmod: ERROR ../libkmod/libkmod-config.c:684 kmod_config_parse: /etc/modprobe.d/fbdev-blacklist.conf line 6: ignoring bad line starting with 'fb'

I found this

http://forums.debian.net/viewtopic.php?f=5&t=76873

I deleted fb  from the fdbev-balcklist.conf on line 6

safe-upgrade with no new software saw no error messages.  If that continues I will append Solved to the title.


EDIT:  I was wondering about putting things I solved by searching, but since I check #! 1rst, it does no harm to take and distill noise - er, cluttered posts -  from  other forums into bite size nuggets here.  S/N is quite important.

Last edited by paxmark1 (2012-09-03 18:06:30)


Jean Vanier wrote "Being Human" and "A Short History of Progress" by Ronald Wright.  Gotta love the Massey Lectures.

Offline

Help fund CrunchBang, donate to the project!

#2 2012-09-02 21:39:31

foxytheoldone
Member
From: WestMidlands
Registered: 2012-07-04
Posts: 44

Re: Solved: /etc/modprobe.d/fbdev-blacklist.conf

sweet solved a little prob i was having on my microserver.


Only the good die young !!! why was i never GOOD!

Offline

#3 2013-11-25 15:16:51

salmonella
New Member
Registered: 2011-11-22
Posts: 2

Re: Solved: /etc/modprobe.d/fbdev-blacklist.conf

Hi,
I have the same problem. After running an update i had the same report and at boot I have following:

modprobe: bad line 6: 1 tokens found, 2 needed

here how fbdev-blacklist.conf looks like:

blacklist arkfb
blacklist aty128fb
blacklist atyfb
blacklist cirrusfb
blacklist cyber2000fb
fb
blacklist gx1fb

I tried to delete the fb row, but the message persists

Offline

#4 2015-01-01 23:20:54

1093_3511
Member
Registered: 2015-01-01
Posts: 21

Re: Solved: /etc/modprobe.d/fbdev-blacklist.conf

Had the very same problem that the corrected line in the fbdev-blacklist.conf didn't resolved the issue.
An newly introduced blacklist.conf had direct effect on the boot up routine.

Anyway, just found these infos on module blacklisting : https://wiki.debian.org/KernelModuleBlacklisting

Create a file '/etc/modprobe.d/<modulename>.conf' containing 'blacklist <modulename>'.
Run 'depmod -ae' as root
Recreate your initrd with 'update-initramfs -u'

After I did this the modprobe error didn't occurred anymore during the boot.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo