SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2014-11-04 01:48:15

Joe90
#! Junkie
Registered: 2013-10-10
Posts: 337

[SOLVED - workaround] minidlna settings?

Running minidlna on my server due to the arrival of a Samsung Smart TV in the house (which is nice!). minidlna seems to work OK, takes a while to build the database, but is reluctant to add new files automatically. ( I am asking it to serve up @ 50,000 music files and @ 3000 videos)

Here is my minidlna.conf

media_dir=/var/lib/minidlna
media_dir=A,/media/music
media_dir=V,/media/tv
media_dir=V,/media/film
db_dir=/var/cache/minidlna
log_dir=/var/log
port=8200
friendly_name=SERVER
serial=681019810597110
inotify=yes               #       <- this should be handling auto-updates to database?
album_art_names=Cover.jpg/cover.jpg/AlbumArtSmall.jpg/albumartsmall.jpg
album_art_names=AlbumArt.jpg/albumart.jpg/Album.jpg/album.jpg
album_art_names=Folder.jpg/folder.jpg/Thumb.jpg/thumb.jpg
notify-interval=300

Anyone who uses this have any suggestions for improvement?

Last edited by Joe90 (2014-11-06 10:54:36)

Offline

Be excellent to each other!

#2 2014-11-04 08:04:41

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: [SOLVED - workaround] minidlna settings?

see my sig for a link (also have a samsung thingy), probably you need the part about "inotify device".

Last edited by brontosaurusrex (2014-11-04 08:06:45)

Offline

#3 2014-11-04 11:43:46

Joe90
#! Junkie
Registered: 2013-10-10
Posts: 337

Re: [SOLVED - workaround] minidlna settings?

I do have "inotify=yes" and "notify-interval=300" in place (why not use plain english -> autoupdate=yes and autoupdate-interval=300 ??). The 300 seconds might be a bit short given the size of my library, but am guessing it checks if running then doesn't run on top?

Following a post over on ubuntu forums, I also increased the value for user_watches

echo 65538 > /proc/sys/fs/inotify/max_user_watches

I did a permissions check on a few files I knew weren't showing up and changed from -rw-r----- to -rw-r-r-- to match the others, a rebuild of the db then added them, so one to watch out for. Not sure why these had different permissions, all part of the same boxed set? Just got one more to fix, an old avi file that won't scan. - getting a better more up to date version. wink

This now seems to have removed all error warnings in the log

Last edited by Joe90 (2014-11-04 12:06:31)

Offline

#4 2014-11-04 13:46:10

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: [SOLVED - workaround] minidlna settings?

I guess I wasn't really clear, what does:

ls -l /dev/inotify

return?

Offline

#5 2014-11-04 14:27:14

Joe90
#! Junkie
Registered: 2013-10-10
Posts: 337

Re: [SOLVED - workaround] minidlna settings?

Ahhh:

auser@SERVER:~$ ls -l /dev/inotify
ls: cannot access /dev/inotify: No such file or directory
auser@SERVER:~$ sudo ls -l /dev/inotify
[sudo] password for auser: 
ls: cannot access /dev/inotify: No such file or directory

So something not right then ?

Last edited by Joe90 (2014-11-04 14:28:51)

Offline

#6 2014-11-04 16:13:02

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: [SOLVED - workaround] minidlna settings?

possibly, check http://crunchbang.org/forums/viewtopic. … 09#p294109 (4.)
What minidlna version did you install? (the link is probably mostly usefull for the one in wheezy stable)

Offline

#7 2014-11-04 18:23:45

Joe90
#! Junkie
Registered: 2013-10-10
Posts: 337

Re: [SOLVED - workaround] minidlna settings?

OK, have created /dev/inotify so will see what gives.

Running:

Version: 1.1.2+dfsg-1~ubuntu14.04.1 (yes, just given away I have an ubuntu server, but is much the same as #!) - this is latest on there.

Do need to reconsider the folder structure, some big lists to search through!

Offline

#8 2014-11-05 00:14:21

Joe90
#! Junkie
Registered: 2013-10-10
Posts: 337

Re: [SOLVED - workaround] minidlna settings?

Well, it still doesn't want to auto update, no signs of this happening in the log, even after adding/changing some files.

Perhaps a cron job ?

Offline

#9 2014-11-05 01:00:44

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: [SOLVED - workaround] minidlna settings?

I don't think that would be in minidlna logs, the files will simply show on your client (tv).

Offline

#10 2014-11-05 16:16:07

Joe90
#! Junkie
Registered: 2013-10-10
Posts: 337

Re: [SOLVED - workaround] minidlna settings?

But there in lies the problem, newly added files don't show up ? Will keep testing.

However, just checked the log again. I changed logging for inotify to debug, and am seeing this on every folder (for example)

[2014/11/05 02:07:38] inotify.c:163: debug: Add watch to /media/film/U/Disney

Shows some promise.....

FWIW just found "MediaHouse" for android, which will connect to the minidlna service and then play to the Samsung TV (the TV will ask to allow the device). Clever stuff.

Last edited by Joe90 (2014-11-05 16:19:04)

Offline

#11 2014-11-06 10:53:33

Joe90
#! Junkie
Registered: 2013-10-10
Posts: 337

Re: [SOLVED - workaround] minidlna settings?

Think I have reached the end of the road with this one. Seems the minidlna will not automatically update for me on my server. YMMV.

Have instead setup a cronjob in root to run every morning at 3am, given it takes quite a while (creates a database of @ 170mb!)

sudo -i

crontab -e

#cronjob for minidlna

0 3 * * * /user/bin/minidlna  && service minidlna restart

I have also set my "watches" to 100000

Some useful resources:

https://wiki.archlinux.org/index.php/MiniDLNA

http://stackoverflow.com/questions/5180 … g-database

https://help.ubuntu.com/community/MiniDLNA

Offline

#12 2014-11-06 11:29:20

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: [SOLVED - workaround] minidlna settings?

What kernel do you use? (You will not be happy with that workaround).

Offline

#13 2014-11-06 22:34:24

Joe90
#! Junkie
Registered: 2013-10-10
Posts: 337

Re: [SOLVED - workaround] minidlna settings?

On "3.13.0-39-generic" (remember is ubuntu 14.04) at the moment, latest available through the normal repos.

Offline

#14 2014-11-07 10:42:26

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: [SOLVED - workaround] minidlna settings?

dunno then, have minidlna on exactly the same os (and I didn't even create a new inotify device) and inotify seems to be working somehow (just installed it a week ago, so still in testing faze);

apt-cache policy minidlna 
minidlna:
  Installed: 1.1.2+dfsg-1~ubuntu14.04.1
  Candidate: 1.1.2+dfsg-1~ubuntu14.04.1
  Version table:
 *** 1.1.2+dfsg-1~ubuntu14.04.1 0
        100 http://archive.ubuntu.com/ubuntu/ trusty-backports/universe amd64 Packages
        100 /var/lib/dpkg/status

Offline

#15 2014-12-15 09:56:59

Joe90
#! Junkie
Registered: 2013-10-10
Posts: 337

Re: [SOLVED - workaround] minidlna settings?

Is working OK now (without further intervention) updates new files almost immediately! smile

Offline

#16 2014-12-20 15:44:34

Joe90
#! Junkie
Registered: 2013-10-10
Posts: 337

Re: [SOLVED - workaround] minidlna settings?

Found a new problem in a work setting, using several TVs of the same type/make. If one stops a video mid stream on one device, another device will resume from that point if same video selected. Resume is built-in to minidlna with no option to turn it off. Might have a look at compile flags?

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo