SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2014-10-06 16:37:24

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

[SOLVED]Icons for symlinks display differently on different installs

I set up my installations so that /home's share data on another partition. Then I make symlinks like documents -> /mnt/data/documents etc

On the laptop, the special folder icons display as desired, but on the desktop the symlinks just display the generic folder.png. It is the same for all themes, whether they are in ~/.icons or /usr/share/icons. Both installations are using Thunar 1.6.3-1

Desktop: 3.16-2-amd64 (sid)
YHoN0rcq.jpg

Laptop: 3.14-2-amd64 (jessie)
TNbCXpc2.jpg

The only difference I can see is the permissions (why is that?). I've spent hours making icons, and getting it looking good on the laptop, then I copied the theme across to the desktop machine and found the special folders weren't displaying sad  I never noticed before that other themes behave the same.

So my question is: where should I start looking for the reason? Is it a system thing to do with symlinks, or a thunar bug, or gtk issue, or etc??

Last edited by damo (2014-10-07 11:10:53)


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

Help fund CrunchBang, donate to the project!

#2 2014-10-06 20:34:38

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: [SOLVED]Icons for symlinks display differently on different installs

i think i noticed this myself sometimes, but never gave it much attention.
have you tried changing the permissions?

Offline

#3 2014-10-06 21:19:23

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: [SOLVED]Icons for symlinks display differently on different installs

ohnonot wrote:

i think i noticed this myself sometimes, but never gave it much attention.
have you tried changing the permissions?

I've tried it for one folder - no difference - and the drives for each machine are mounted in fstab exactly the same way btw.


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#4 2014-10-07 07:17:14

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: [SOLVED]Icons for symlinks display differently on different installs

have a look at $HOME/.config/user-dirs.dirs (it's there on a standard crunchbang install).

Offline

#5 2014-10-07 11:09:08

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: [SOLVED]Icons for symlinks display differently on different installs

ohnonot wrote:

have a look at $HOME/.config/user-dirs.dirs (it's there on a standard crunchbang install).

Take a bow that man! I hadn't changed the defaults from eg "Documents" to "documents" on that installation :8


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#6 2014-10-07 16:28:32

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: [SOLVED]Icons for symlinks display differently on different installs

aah, glad to be of help.  O:)

just for the record, the file is created by xdg-user-dirs-update.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo