SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#26 2009-07-16 04:35:39

jackbang
#! CrunchBanger
Registered: 2009-05-28
Posts: 244

Re: [Retired] HOWTO: Bluetooth

OK, forget gnome-vfs-obexftp, as it's superceded by gvfs, which is installed on #! jaunty by default, including an obexftp back-end.
But how to use it?
Perhaps there are some filemanagers other than nautilus that support gvfs, but I'm not sure which.
In the meantime, I've mounted my phone under fuse, in ~/.gvfs
Here's what I did:

sudo apt-get  install gvfs-bin
sudo apt-get install gvfs-fuse
/usr/lib/gvfs/gvfsd-obexftp #not sure if this was required, or should get started automatically by gvfs-mount
/usr/lib/gvfs-fuse-daemon ~/.gvfs
gvfs-mount obex://[xx:xx:xx:xx:xx:xx]

Voila, I have my phone mounted under ~/.gvfs and can view it in pcmanfm

Unfortunately, it's flakier than cadbury's finest, but maybe it works for you.
EDIT: Works OK on a nokia 2630, but on a nokia 6233 there seems to be a 48k file size transfer limit of some kind, so anything biigger gets an i/o error.  will try some others.

Last edited by jackbang (2009-07-16 05:35:42)

Offline

Help fund CrunchBang, donate to the project!

#27 2009-07-16 06:38:27

corenominal
WRONG
From: Lincoln, UK
Registered: 2008-11-20
Posts: 5,131
Website

Re: [Retired] HOWTO: Bluetooth

^^ is good stuff, please keep it coming. smile


Ex-developer of #! CrunchBang. Follow me on Twitter smile

Offline

#28 2009-07-18 00:30:14

jackbang
#! CrunchBanger
Registered: 2009-05-28
Posts: 244

Re: [Retired] HOWTO: Bluetooth

Just on the subject of file-browsers/managers that support gvfs, I found this about thunar:
http://www.nabble.com/Porting-Thunar-to … 60199.html

And also this filemanager, which is kind of a gtk version of mc, and has a gvfs plugin:
http://tuxcmd.sourceforge.net/description.php

Haven't looked at how far the thunar port has gone, or downloaded tuxcommander yet.

Offline

#29 2009-07-18 01:02:18

anonymous
The Mystery Member
Registered: 2008-11-29
Posts: 9,419

Re: [Retired] HOWTO: Bluetooth

Small FYI, you can get tuxcmd from the Ubuntu repo.

Offline

#30 2009-09-03 19:20:10

rpgormley
New Member
Registered: 2009-09-03
Posts: 1

Re: [Retired] HOWTO: Bluetooth

In response to Nik_Doof's instructions on how to install Bluetooth on CrunchBang Linux:
I installed Bluetooth fine and got the bluetooth icon at the bottom. Connected my Logitech BT mouse and my Stowaway GT keyboard just fine. Everything worked. However, after subsequent startups of my eee901, I get a "...failed to connect" for any bluetooth device, including my mouse and keyboard. I even removed the application and reinstalled "bluez-gnome bluetooth gnome-bluetooth" again. Still doesn't work. It only ever worked that one time when I initially installed bluez-gnome.
???? mad
Thanks,  Robert G

Offline

#31 2009-09-09 10:26:00

tonyoptical
#! CrunchBanger
Registered: 2009-09-08
Posts: 226

Re: [Retired] HOWTO: Bluetooth

Hi

I followed the initial instructions to add bluetooth to my system in order to connect my MS Bluetooth Mouse.

I got the bluetooth icon and was able to connect successfully. But the mouse was still not functional.

After some googeling i came up to this solution:

http://stesind.blogspot.com/search/label/Bluetooth

This finally did the trick for me.

Offline

#32 2009-09-24 17:16:21

eazybang
New Member
Registered: 2009-09-23
Posts: 1

Re: [Retired] HOWTO: Bluetooth

I love blueman and pcmanfm,and i dont want to install nautilus,so is there any way to get "browse files on device"
working with pcmanfm?
thank you

Offline

#33 2009-09-25 12:05:28

jackbang
#! CrunchBanger
Registered: 2009-05-28
Posts: 244

Re: [Retired] HOWTO: Bluetooth

indeed, see my post #26 at the top of the page.

Offline

#34 2009-10-06 09:16:44

Mufasa
Member
Registered: 2009-10-04
Posts: 20

Re: [Retired] HOWTO: Bluetooth

san wrote:

Ok, got sending from phone working. I installed the package "obexpushd" and added it to the autostart script (on its own line)

Nice, thanks! Works for me too! The only thing is: How can I set the default place where the received files get pushed in?? I want the files to be saved on Desktop, so I wrote in autostart.sh /home/<User>/Desktop/obexpushd

But it still saves all files in root.

Any idea??

Offline

#35 2009-11-25 15:09:34

n00b
Member
Registered: 2009-11-25
Posts: 22

Re: [Retired] HOWTO: Bluetooth

Hi, i need help setting up bluetooth and my mouse.
It's a little harder as a noob navigating around the desktop without a mouse.
Im new to linux so if you could explain the process in simple terms that would help too, thanks.

Ok, so i have installed the livecd onto the hdd and it boots very quick. Impressed!
I have a Koran Agora Pro Netbook (http://www.kogan.com.au/shop/kogan-agora-netbook-pro/)
And an HP 'Targas' bluetooth mouse.
A bluetooth dongle.
(Vista used to be on it but i killdisked it)

I followed the first post instructions except it didnt say where to run the commands so i spent a while in the Run Dialog menu waiting for a response. Then i thought maybe the commands should go in the Terminal box!

I ran 'sudo apt-get install bluez-gnome bluetooth gnome-bluetooth' in the terminal and it installed fine.
I ran '(sleep 5s && bluetooth-applet) &' in the terminal next.
Plugged in my dongle and the bluetooth icon appears... great!
Until i rebooted and the bluetooth icon was gone.
So i ran '(sleep 5s && bluetooth-applet) &' once again in the terminal and plugged in the dongle and have it back again.

Problem is i cant figure out how to close the terminal box without a mouse and navigate to the bluetooth icon to configure my mouse to it. And second problem is how do i keep the bluetooth icon there after rebooting?

I know i probably sound like an idiot right lol
Things will be alot easier with a mouse
cool

================
Update: I managed to get the mouse working and it shows up on reboot. big_smile
Opened a terminal window (super +t) and typed "bluetooth-wizard". No mouse was available until i realised i had a reset button on the mouse. Soon as i hit reset button, the mouse appears. Wow, this is so cool.
================

Last edited by n00b (2009-11-26 03:29:19)

Offline

#36 2009-11-25 17:04:18

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 13,970

Re: [Retired] HOWTO: Bluetooth

If you need the BT icon, uncomment it in autostart.sh (Preferences >> Openbox Config >> Edit autostart.sh in the main Openbox menu).  Once you've set up your mouse, you really shouldn't need the applet unless your hardware doesn't autodiscover BT devices that have already been configured.  On my netbook with a built-in BT card, it takes a few seconds for it to "wake up" and recognize the mouse the first time I start moving it, but after that it works just fine; same performance with or without bluetooth-applet running.

The applet is more useful for BT storage devices like smartphones.

Offline

#37 2009-11-26 04:00:19

n00b
Member
Registered: 2009-11-25
Posts: 22

Re: [Retired] HOWTO: Bluetooth

pvsage wrote:

If you need the BT icon, uncomment it in autostart.sh (Preferences >> Openbox Config >> Edit autostart.sh in the main Openbox menu).  Once you've set up your mouse, you really shouldn't need the applet unless your hardware doesn't autodiscover BT devices that have already been configured.  On my netbook with a built-in BT card, it takes a few seconds for it to "wake up" and recognize the mouse the first time I start moving it, but after that it works just fine; same performance with or without bluetooth-applet running.

The applet is more useful for BT storage devices like smartphones.

Great thanks for the response pvsage. big_smile
I do have a smartphone too so i might leave it there until im confident with the phone which ill probably use as mobile internet access, or emergency net which is looking closer then i wanted.
Noticed there was eyecandy too and couldnt resist uncommenting that for day.

Now all i really have left to do is get the NM or Wicd working and ive tried them both.
Just finished reinstalling NM after trying Wicd which failed too.
The top post on this page worked for me; (http://ubuntuforums.org/showthread.php?p=7248351).. it was easy to follow but i think my problem isnt the network application's its, the network pci adapter itself... or something isnt switching it on because its not visible when i run all the commands.

Ive tried all the commands given on this site; (http://ubuntuforums.org/showthread.php?t=1195312) to identify the interface name or any info about it but it keeps on coming up blank. Followed all of pytheas's posts and still couldn't find its name.

Then i found a blog about my netbook at this page; (http://agoranetbook.kayno.net/2009/07/2 … a-adapter/) .. and it seems i either have the vt6656 via arena or the newer Ralink chipset, but i cant tell because i cant detect it. :S

Offline

#38 2010-02-22 16:28:15

rufong
Member
From: taipei
Registered: 2009-05-06
Posts: 17
Website

Re: [Retired] HOWTO: Bluetooth

iggykoopa wrote:

you could try blueman instead of the default bluetooth applet, I just switched and like it better...
after you follow the instructions on this page http://bigbrovar.wordpress.com/2009/02/ … or-ubuntu/
just change your autostart from bluetooth-applet to blueman-applet.

koopa koopa, u da bomba!

ty..

Offline

#39 2010-05-01 14:57:30

michaelrose
Member
From: Brighton, UK
Registered: 2010-04-29
Posts: 13

Re: [Retired] HOWTO: Bluetooth

This looks like quite an old thread so I'm not sure if it's the right place to ask or not...

I've got an Apple Bluetooth Keyboard and I'd love to get it working under #! - I've looked at the general Ubuntu FAQs and there seem to be some issues...

Bluetooth is working fine, my Netbook with #! can see my Mac, but not the keyboard.

Anyone had any luck with this?


Dell Mini 9 - 2GB RAM - 8GB SSD - Dropbox for all my files - Job Done!

Offline

#40 2010-05-16 08:37:35

soderstrom
Member
Registered: 2010-05-11
Posts: 14

Re: [Retired] HOWTO: Bluetooth

I can't get my bluetooth icon to show up in the system tray. I followed the guide and edited all autostart.sh files I found, restarted but still nothing shows up. Even tried installing blueman as well but it also didn't show in the system tray.

Please help because I need to set-up my handsfree to be able to talk on skype.

Edit: Solved, was missing the gnome bluetooth applet package. Guess I will wait longer before asking for help but it is weird that I've got a tendency to solve my own problems just after asking for help big_smile

Last edited by soderstrom (2010-05-16 08:52:33)


"If you put your mind to it, you can accomplish anything."

Offline

#41 2011-04-20 16:10:14

chaanakya
#! Die Hard
Registered: 2010-12-30
Posts: 940

Re: [Retired] HOWTO: Bluetooth

Okay, so I have inbuilt bluetooth which shows up fine with either blueman or gnome-bluetooth.  However...it never finds anything...I'm not sure if this is because of just random annoyance or whether I'm doing something wrong...any help would be appreciated.

Thanks!

- Chaanakya


Check out Musik - an easy-to-use text-to-music converter!
Join SpiderOak using this link and get an extra 1 GB free: https://spideroak.com/download/referral … 660e787ff1

Offline

#42 2011-12-01 05:41:54

pothi
New Member
From: Rajapalayam, TN, India
Registered: 2011-12-01
Posts: 9
Website

Re: [Retired] HOWTO: Bluetooth

This thread is at the top search result for "bluetooth mouse crunchbang linux". So, let me share what I did to enable Logitech MX Revolution mouse.

As of today with CrunchBang 10 “Statler” R20111125, it looks like a simple procedure. No need to install any additional package.

1. In a terminal... type bluetooth-applet
2. On the applet, click "Find a device" and follow the procedure to activate your mouse.
3. Once mouse is activated, close the bluetooth-applet from the terminal (CTRL+C). It is no longer needed.

Offline

#43 2013-02-18 13:18:03

floydpepper
#! Member
Registered: 2010-03-13
Posts: 56

Re: [Retired] HOWTO: Bluetooth

This thread seems to have outdated info on getting bluetooth to work? I'm using the latest Waldorf on my hp mini. I first tried using the Debian Bluetooth User guide http://wiki.debian.org/BluetoothUser but that didn't get me anywhere. Couldn't get the bluetooth icon to show up in the tray and hcitool dev command returns no devices. Installing blueman doesn't help either, running blueman-assistant tells me "No adapters found".


And trying the guide in this thread fails for me at the very first command:

$ sudo apt-get install bluez-gnome bluetooth gnome-bluetooth
[sudo] password for dayo: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package bluez-gnome is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'bluez-gnome' has no installation candidate

Does anybody have an updated guide to getting bluetooth up and running in Waldorf?

Offline

#44 2013-02-19 09:04:05

floydpepper
#! Member
Registered: 2010-03-13
Posts: 56

Re: [Retired] HOWTO: Bluetooth

Nevermind. It turned out I don't even have any bluetooth on my netbook.  sad

Offline

#45 2013-11-21 22:43:04

cwiggs
New Member
Registered: 2013-11-21
Posts: 1

Re: [Retired] HOWTO: Bluetooth

floydpepper wrote:

This thread seems to have outdated info on getting bluetooth to work? I'm using the latest Waldorf on my hp mini. I first tried using the Debian Bluetooth User guide http://wiki.debian.org/BluetoothUser but that didn't get me anywhere. Couldn't get the bluetooth icon to show up in the tray and hcitool dev command returns no devices. Installing blueman doesn't help either, running blueman-assistant tells me "No adapters found".


And trying the guide in this thread fails for me at the very first command:

$ sudo apt-get install bluez-gnome bluetooth gnome-bluetooth
[sudo] password for dayo: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package bluez-gnome is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'bluez-gnome' has no installation candidate

Does anybody have an updated guide to getting bluetooth up and running in Waldorf?

This is actually a problem for me still and i know for sure i have bluetooth.  anyone know what the updated package is?

Edit: i actually left the bluez-gnome package out and it seems to still work.  The bluetooth applet is black though, so it's almost impossible to see on the default background of crunchbang.  It also seems that the settings don't work,  the terminal says 'Couldn't execute command: gnome-control-center bluetooth'.  I'll try a restart and see if that fixes it.

Last edited by cwiggs (2013-11-21 23:01:10)

Offline

#46 2013-11-23 14:34:00

sysaxed
#! Member
Registered: 2013-03-25
Posts: 77

Re: [Retired] HOWTO: Bluetooth

sudo apt-get install blueman

then run blueman-applet or reboot.

Offline

#47 2013-12-01 08:38:30

murak
#! Member
From: Sweden
Registered: 2009-05-29
Posts: 86

Re: [Retired] HOWTO: Bluetooth

pothi wrote:

This thread is at the top search result for "bluetooth mouse crunchbang linux". So, let me share what I did to enable Logitech MX Revolution mouse.

As of today with CrunchBang 10 “Statler” R20111125, it looks like a simple procedure. No need to install any additional package.

1. In a terminal... type bluetooth-applet
2. On the applet, click "Find a device" and follow the procedure to activate your mouse.
3. Once mouse is activated, close the bluetooth-applet from the terminal (CTRL+C). It is no longer needed.

This helped me a lot, thanks!

Maby it's time to update the first post in the thread?


CrunchBang Linux 11 "Waldorf" 64-bit - Thinkpad X230 / i5 3320M / 16Gb ram / 240Gb Sandisk Extreme II

Offline

#48 2014-05-15 08:05:19

Probe34
Member
Registered: 2012-09-25
Posts: 47

Re: [Retired] HOWTO: Bluetooth

I installed blueman and then run blueman-browse seperately. Works like a breeze now.

Offline

#49 2014-05-15 08:20:41

chillicampari
Pinball Wizard
Registered: 2009-10-09
Posts: 2,728

Re: [Retired] HOWTO: Bluetooth

Thanks for posting what worked for you Probe34! The guide itself is really dated now so it'd probably be a good time to retire it.

(closed/retired)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo