SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#101 2014-06-13 14:07:59

joek
#! Junkie
Registered: 2011-09-06
Posts: 497

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

I wonder whether I might get some Steam on sid support here?

I have installed steam successfully (as far as I can tell), but whenever I try to run it, I get the message "OpenGL GLX extension not supported by display". My laptop has an integrated Intel Graphics Card and is 64-bit, so I think I require libgl1-mesa-glx:i386, which I have installed (and on a test installation of Xubuntu I put on the other partition, Steam worked out-of-the-box, so it's not an issue of the computer not being able to do it...)

I have googled around, and think I have confirmed that I do have the correct things installed, but I can't work out where to go next...

Offline

Help fund CrunchBang, donate to the project!

#102 2014-06-13 18:29:35

parkerlreed
Member
Registered: 2011-07-13
Posts: 15

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

joek wrote:

I wonder whether I might get some Steam on sid support here?

I have installed steam successfully (as far as I can tell), but whenever I try to run it, I get the message "OpenGL GLX extension not supported by display". My laptop has an integrated Intel Graphics Card and is 64-bit, so I think I require libgl1-mesa-glx:i386, which I have installed (and on a test installation of Xubuntu I put on the other partition, Steam worked out-of-the-box, so it's not an issue of the computer not being able to do it...)

I have googled around, and think I have confirmed that I do have the correct things installed, but I can't work out where to go next...

If you are on sid you don't follow this guide. Enable multilib like before, make sure you have non-free sources enabled, and then just apt-get install steam.

Offline

#103 2014-06-14 08:07:16

joek
#! Junkie
Registered: 2011-09-06
Posts: 497

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

parkerlreed wrote:
joek wrote:

I wonder whether I might get some Steam on sid support here?

I have installed steam successfully (as far as I can tell), but whenever I try to run it, I get the message "OpenGL GLX extension not supported by display". My laptop has an integrated Intel Graphics Card and is 64-bit, so I think I require libgl1-mesa-glx:i386, which I have installed (and on a test installation of Xubuntu I put on the other partition, Steam worked out-of-the-box, so it's not an issue of the computer not being able to do it...)

I have googled around, and think I have confirmed that I do have the correct things installed, but I can't work out where to go next...

If you are on sid you don't follow this guide. Enable multilib like before, make sure you have non-free sources enabled, and then just apt-get install steam.

I realise that, and I did so. And I get the error I have recorded above...

Offline

#104 2014-06-26 03:07:53

PixelPaintbrush
Member
Registered: 2014-06-24
Posts: 11

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Thanks! works like a charm

Offline

#105 2014-06-26 08:15:01

Milozzy
#! Die Hard
Registered: 2011-02-22
Posts: 633
Website

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Alad wrote:

^ Don't use the ghostsquad installer. Besides it usually not working, it imports third-party repos (some even reported their system turning to sid/unstable).

https://github.com/AladW/cb-scripts

If you get a checksum error just comment it out in the script.

Thanks for your work!
I am on a 64bit system... Do I still need to run sudo dpkg --add-architecture i386 before using your script?

Thanks again!

Offline

#106 2014-06-26 18:42:46

Alad
Software Satan
Registered: 2014-02-20
Posts: 1,512

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

^ Good call, I forgot to include that. Updated.

Last edited by Alad (2014-06-26 18:48:16)

Offline

#107 2014-06-27 11:24:37

Milozzy
#! Die Hard
Registered: 2011-02-22
Posts: 633
Website

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Alad wrote:

^ Good call, I forgot to include that. Updated.

No luck here anyway.

I received this error message:

~$ steam
Running Steam on debian 7 64-bit
STEAM_RUNTIME is enabled automatically
/home/milo/.local/share/Steam/ubuntu12_32/steam: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/milo/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libX11.so.6)
/home/milo/.local/share/Steam/ubuntu12_32/steam: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/milo/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libX11.so.6)
mv: impossibile eseguire stat di "/home/milo/.steam/registry.vdf": File o directory non esistente
Installing bootstrap /home/milo/.local/share/Steam/bootstrap.tar.xz
Reset complete!
Restarting Steam by request...
Running Steam on debian 7 64-bit
STEAM_RUNTIME has been set by the user to: /home/milo/.local/share/Steam/ubuntu12_32/steam-runtime
/home/milo/.local/share/Steam/ubuntu12_32/steam: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/milo/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libX11.so.6)
/home/milo/.local/share/Steam/ubuntu12_32/steam: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/milo/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libX11.so.6)

Any ideas?

Thanks!

Last edited by Milozzy (2014-06-27 11:30:46)

Offline

#108 2014-06-27 11:36:44

Milozzy
#! Die Hard
Registered: 2011-02-22
Posts: 633
Website

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

I better checked the output of cb-steam and in the and it says:

Elaborazione dei trigger per desktop-file-utils...
/home/milo/bin/cb-steam: 32: [: x86_64: unexpected operator
/home/milo/bin/cb-steam: 32: [: x86_64: unexpected operator
/home/milo/bin/cb-steam: 43: [: x86_64: unexpected operator

It seems that there's some problem in the script maybe...

Offline

#109 2014-06-27 11:59:52

Alad
Software Satan
Registered: 2014-02-20
Posts: 1,512

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

You have to run it with /usr/bin/cb-steam after installation.

/home/milo/bin/cb-steam: 32: [: x86_64: unexpected operator

The arch() function works for me - do you use the original script?

Last edited by Alad (2014-06-27 12:00:59)

Offline

#110 2014-06-27 12:11:45

Milozzy
#! Die Hard
Registered: 2011-02-22
Posts: 633
Website

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Alad wrote:

You have to run it with /usr/bin/cb-steam after installation.

/home/milo/bin/cb-steam: 32: [: x86_64: unexpected operator

The arch() function works for me - do you use the original script?

Same problem if I put and run the script from /usr/bin/cb-steam

I just cloned the script from your github...

Offline

#111 2014-06-27 12:14:11

Alad
Software Satan
Registered: 2014-02-20
Posts: 1,512

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Yes, but I meant that after you run the script, you have to run steam via /usr/bin/cb-steam - the script creates a wrapper in that location. I'll boot a #! x64 image and see what's wrong.

Offline

#112 2014-06-27 12:35:10

Milozzy
#! Die Hard
Registered: 2011-02-22
Posts: 633
Website

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Alad wrote:

Yes, but I meant that after you run the script, you have to run steam via /usr/bin/cb-steam - the script creates a wrapper in that location. I'll boot a #! x64 image and see what's wrong.

Oh ok, now I got it...but there is no cb-steam in my /usr/bin... probably due to the fact that the script doesn't finish his work cause of the unexpected operator error.

ps. I just saw your website and the round off posts...great work!

Offline

#113 2014-06-27 19:20:11

Alad
Software Satan
Registered: 2014-02-20
Posts: 1,512

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Glad you like the articles.

The script made a wrapper around the x64 libc6, while Steam uses x86. That and a bunch of typos. Derp. Updated, only tested until the welcome screen (ignoring a "missing libc6.so" error).

AWYn2F0s.png

Last edited by Alad (2014-06-27 19:24:24)

Offline

#114 2014-06-27 20:00:32

Milozzy
#! Die Hard
Registered: 2011-02-22
Posts: 633
Website

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Thank you very very much!

Now I can install it bun when I run /usr/bin/cb-steam I receive this

/usr/bin/cb-steam 
Running Steam on debian 7 64-bit
STEAM_RUNTIME is enabled automatically
Error: You are missing the following 32-bit libraries, and Steam may not run:
libc.so.6
Error:
You are missing the following 32-bit libraries, and Steam may not run:
libc.so.6
Press enter to continue: 

If I presso enter, the client starts, but is this warning ok?

Offline

#115 2014-06-27 20:15:45

Alad
Software Satan
Registered: 2014-02-20
Posts: 1,512

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Yeah it's the same warning I had - not sure why this happens as both the system libc6:i386 and steam one are there. I'd suggest to press enter, if it works, good, if not we'll fix it.

Last edited by Alad (2014-06-27 20:18:22)

Offline

#116 2014-06-27 20:21:03

Milozzy
#! Die Hard
Registered: 2011-02-22
Posts: 633
Website

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Yes, as I said the client start, but I already tried two different games and they don't work.
This is what I can read in the terminal

Game update: AppID 22000 "World of Goo", ProcID 8418, IP 0.0.0.0:0
ERROR: ld.so: object '/home/milo/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
/bin/sh: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/milo/.local/share/Steam/ubuntu12_64/gameoverlayrenderer.so)
/bin/sh: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/milo/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libstdc++.so.6)
/bin/sh: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/milo/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libXext.so.6)
/bin/sh: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/milo/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libXfixes.so.3)
/bin/sh: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/milo/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libX11.so.6)
/bin/sh: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by /home/milo/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libX11.so.6)
/bin/sh: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/milo/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libxcb.so.1)
/bin/sh: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /home/milo/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libgcc_s.so.1)
Game removed: AppID 22000 "World of Goo", ProcID 8418 

(steam:8062): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

I'm really sorry if I am bothering you... I hope that I can at least help as a tester smile

Thank you very much!

Offline

#117 2014-06-27 21:00:11

Alad
Software Satan
Registered: 2014-02-20
Posts: 1,512

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Aha - it wants *both* i386 and amd64 libcs. Updated again (though haven't tried it).

And your testing is much appreciated.

Offline

#118 2014-06-27 21:02:13

Milozzy
#! Die Hard
Registered: 2011-02-22
Posts: 633
Website

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Don't worry I will triy personally and report you back.
Do you think it is better doing some cleaning before reinstalling it?

Last edited by Milozzy (2014-06-27 21:02:31)

Offline

#119 2014-06-27 21:27:05

Alad
Software Satan
Registered: 2014-02-20
Posts: 1,512

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Probably:

sudo apt-get purge steam*
sudo rm -r /tmp/cb-steam /tmp/cb-steam.deb /usr/local/lib/steam /usr/bin/cb-steam

Last edited by Alad (2014-06-27 21:27:33)

Offline

#120 2014-06-27 22:23:40

Milozzy
#! Die Hard
Registered: 2011-02-22
Posts: 633
Website

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

No luck sad
Same error as above.

Offline

#121 2014-06-28 08:56:15

Alad
Software Satan
Registered: 2014-02-20
Posts: 1,512

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Bummer. Will need more investigating.

Offline

#122 2014-06-28 09:44:03

Milozzy
#! Die Hard
Registered: 2011-02-22
Posts: 633
Website

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Let me know if I can provide some more infos wink

Thanks!!

Offline

#123 2014-06-28 10:24:37

Alad
Software Satan
Registered: 2014-02-20
Posts: 1,512

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

I've pushed some more updates, but it seems Steam made some changes that prevent this from working - the GhostSquad installer (which has a similar approach) no longer works on 64bit either (feel free to try). No promises, but I'll see what I can come up with.

Last edited by Alad (2014-06-28 10:29:50)

Offline

#124 2014-06-28 10:52:58

Milozzy
#! Die Hard
Registered: 2011-02-22
Posts: 633
Website

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

Alad wrote:

I've pushed some more updates, but it seems Steam made some changes that prevent this from working - the GhostSquad installer (which has a similar approach) no longer works on 64bit either (feel free to try). No promises, but I'll see what I can come up with.

Thanks anyway!

Offline

Be excellent to each other!

#125 2014-07-08 04:09:48

gb9k
New Member
Registered: 2014-07-08
Posts: 2

Re: Steam on Debian Wheezy 64bit (and probably 32bit too!)

I'm a fresh convert from Ubuntu, and decided to get my L4D2 on. I had an issue identical to AndyinMokum, went through and tried all of cup_of_squirrel's awesome troubleshooting, but had pretty much the same output.

Horba mentioned smxi to change around some drivers, and I figured why not.  It failed. Something about ia32-libs-i386:i386 and to try --fix-missing.  I also jotted down: "failed to fetch libxcb-render-util0_0.3.8-1.1_i386.deb"

Thinking that was the missing key, I tried to install it. That was a no-go. So I gave smxi's recommendation a whirl:

sudo apt-get install ia32-libs-i386:i386 --fix-missing

It installed a lot of stuff.  Good news is I am now happily waiting on L4D2 to finish installing. So maybe it was a combination of everything, or just something in libgl1-nvidia-glx:i386 really hated our systems.

For now, I really want to kill me some zombies and blow off some steam (ha!).  Later, I'd love to figure out what exactly was holding us back & what I can get rid of.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo