SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2014-02-23 22:57:35

soraaru
New Member
Registered: 2014-02-15
Posts: 6

AwesomeWM not changing themes

Hello, I changed from to openbox to awesome to try and get a better desktop environment, but I is just like a train wreck, one mistake or error after another.
This is the last one that I couldn't find a solution:

I've installed awesome and a theme:
https://github.com/copycat-killer/awesome-copycats (Dremora) and I changed the rc.lua and checked the theme path, but it seems something is wrong, it doesn't change anything with the new rc.lua, even with one from a different theme.

The installation method was the unzip inside another the other folder, I don't know if that made any errors.

Even if awesome -k is ran, it says that there isn't any errors in the code.

I'm still new to all this crunchbang stuff and still struggle with a lot of stuff, any help would be amazing.

And sorry about my bad english.

Offline

Help fund CrunchBang, donate to the project!

#2 2014-02-25 18:54:51

anonymous
The Mystery Member
Registered: 2008-11-29
Posts: 9,419

Re: AwesomeWM not changing themes

What folder did you copy the theme to?

Did you remember to restart awesomewm afterwards?

Offline

#3 2014-02-25 22:01:35

xero
#! Junkie
From: 0x000000
Registered: 2013-09-30
Posts: 382
Website

Re: AwesomeWM not changing themes

perhaps doing a bit of debugging might help?

i have not tried any of the copycat themes, but this line:

Be sure to have the latest versions of Lua, Lua-lgi, and Awesome.

might be this issue. if you installed awesome from the #! repos you probably have version: 3.4.13-1 (that's what i got), but the newest version is 3.5. perhaps some of their themes use updated methods from 3.5 that dont work on 3.4 (just a thought). do any themes work? e.g. the default one?


▬▬ι═════════-
dotfiles http://git.io/.files

Offline

#4 2014-02-27 17:11:44

srccon
Member
From: US of 'Merica
Registered: 2013-04-21
Posts: 36

Re: AwesomeWM not changing themes

Another thing to look out for is that all of the github pages on Awesome indicate that the directory for the rc.lua and themes folders should be at

~/.config/awesome

but where Awesome WM checks first is where xdg calls home, which in !# is

/etc/xdg/awesome

So you can either work in that directory or move it to ~/.config

Offline

#5 2014-02-27 19:14:58

xero
#! Junkie
From: 0x000000
Registered: 2013-09-30
Posts: 382
Website

Re: AwesomeWM not changing themes

srccon wrote:

Another thing to look out for is that all of the github pages on Awesome indicate that the directory for the rc.lua and themes folders should be at

~/.config/awesome

but where Awesome WM checks first is where xdg calls home, which in !# is

/etc/xdg/awesome

So you can either work in that directory or move it to ~/.config

i personally leave /etc/xdg/awesome alone and dev in ~/.config/awesome, so if something in my config dir goes wrong it falls back to the working theme in /etc/xdg/awesome.


▬▬ι═════════-
dotfiles http://git.io/.files

Offline

#6 2014-02-27 23:17:57

srccon
Member
From: US of 'Merica
Registered: 2013-04-21
Posts: 36

Re: AwesomeWM not changing themes

I do my dev in .config too. It is a bad idea to do it in /etc/xdg/awesome.

Offline

#7 2014-02-27 23:26:47

srccon
Member
From: US of 'Merica
Registered: 2013-04-21
Posts: 36

Re: AwesomeWM not changing themes

Were you ever able to see the new themes?

Offline

#8 2014-02-28 15:04:23

xero
#! Junkie
From: 0x000000
Registered: 2013-09-30
Posts: 382
Website

Re: AwesomeWM not changing themes

nope. tried last night. some of the copycat-killer dependencies (e.g. lain) only work for awesome 3.5.

---------

ok so i was able to update to awesome 3.5.1 and install the themes. i add to add the sid + experimental repos to #! to pull it off. i read this article on apt-pinning to help.

add these entries to /etc/apt/sources.list

#EXPERIMENTAL
deb http://ftp.us.debian.org/debian/ experimental main contrib non-free

#SID
deb http://ftp.us.debian.org/debian/ sid main contrib non-free

update your /etc/apt/preferences

Package: *
Pin: release a=waldorf
Pin-Priority: 1001

Package: *
Pin: release a=wheezy
Pin-Priority: 500

Package: *
Pin: release a=experimental
Pin-Priority: 400

Package: *
Pin: release a=sid
Pin-Priority: 300

(not really sure how good those "pin-priorities" are, but they worked for me)

then run these two commands:

sudo apt-get update
sudo apt-get -t experimental install awesome

this will update you to the new sources you selected, then install awesome 3.5.1 from experimental. i had to add sid as well because awesome 3.5's dependencies (libc6 + libxcb-cursor0) were not at the right version anywhere but sid (weird).

after install run

awesome -v

and make sure you got the new version.

now follow the install instructions here (https://github.com/copycat-killer/awesome-copycats) git clone, submodule init, move to .config, select your theme, restart awesome!

hope that helps! (and thanx for giving me a reason to update!)

Last edited by xero (2014-02-28 16:02:20)


▬▬ι═════════-
dotfiles http://git.io/.files

Offline

#9 2014-02-28 16:06:40

srccon
Member
From: US of 'Merica
Registered: 2013-04-21
Posts: 36

Re: AwesomeWM not changing themes

Also, if you want some more themes.

https://github.com/mikar/awesome34-themes.git

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo