SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2014-01-15 16:16:16

vascowhite
Member
From: Wirral, UK
Registered: 2014-01-14
Posts: 17
Website

[Solved] Cannot create #! bootable USB

I know this topic has been discussed many times on these forums, believe me, I have read them all!

No matter what I do I cannot create a readable, bootable USB drive to install #!.

I have followed the instructions to the letter as well as trying every bootable USB creator I can get my hands on in both linux and windows. Here are the steps I have taken in roughly the correct order (I have been at this for 3 days and my memory is a bit shot):-

  • Used unetbootin  to create bootable USB
    This was not recognised by any of my machines windows desktop, ubuntu desktop & 2 windows laptops, one of which is the target machine. On bringing up the boot menu, the USB is not shown as a boot option, only the HDD.

  • Read the instructions and used Win32DiskImage to create the USB.
    Same  result.

  • Switched to Ubuntu and used DD
    Same result

  • Switched back to windows and tried every USB creator I could get hold of.
    Same result.

  • Ran up a virtual machine to verify the ISO
    #! installed flawlessly and ran like a dream, nothing wrong with the ISO file then.

  • Created a Debian installer on the USB and followed the instructions for a net install of #!
    This install went without a hitch except for the fact that there is no GUI available in #!. However, at last I have it installed on the target machine! Quite an achievement after all this effort. Some advice on why the GUI fails to load would be welcome, but my main question is the USB problem.

  • Used the cli of my newly installed #! machine to use the DD method again.
    Alas, same result!

I have run out of ideas, the USB drive is good, the target machine will boot from it if it is bootable and the ISO is good. Does anybody have any other ideas as to what the problem could be?

The target machine:-

Asus X102BA 10.1" touch screen with 4GB memory, 500GB HDD and AMD Radeon® HD 8180G video card.
Further specs.

Last edited by vascowhite (2014-01-16 13:46:05)

Offline

Be excellent to each other!

#2 2014-01-15 16:34:56

retf
#! CrunchBanger
From: On top of spaghetti
Registered: 2013-12-25
Posts: 200

Re: [Solved] Cannot create #! bootable USB

It's a little unclear exactly what is failing to occur with the USB install you indicated doesn't function.

Does the computer try to boot the USB and fail somewhere?
Does the computer skip the USB stick altogether and just boot like normal?
Do you get an error like, "Operating System Not Found."  ?
Does the computer not give a "post" beep when the USB stick is inserted and the power button pressed?
Have you checked the BIOS settings to ensure the USB drive is the top bootable device?
How do you know the ISO file is correct? Have you verified the md5sum?

sudo dd if=crunch-xxxx-.iso of=/dev/sdx

Should always work from nearly any GNU/Linux distribution to correctly copy the iso to the usb drive.  Also, since dd just copies bytes, there is no need to partition or format the USB stick - and in fact, any data stored on the drive will be overwritten anyway, including partition data.

BTW - I know some people swear by unetbootin, but I have never really gotten to get it to work correctly --- However, it's been many years since I last tried using it.

EDIT - PS. - BTW...
I found a MS Windows build of dd here:
http://www.chrysocome.net/dd
I've never used this build - and can't vouch for it - but maybe it will be helpful for you...

Last edited by retf (2014-01-15 16:40:26)

Offline

#3 2014-01-15 16:44:40

vascowhite
Member
From: Wirral, UK
Registered: 2014-01-14
Posts: 17
Website

Re: [Solved] Cannot create #! bootable USB

Thank you for your quick reply. Answers to your questions are below.

retf wrote:

Does the computer try to boot the USB and fail somewhere?

I bring up the boot menu and the drive is not listed as a boot option as  it normally would be. Other bootable USB's show up there., so it doesn't go as far as trying to boot from it. Also neither windows nor Linux recognise the USB as properly formatted once #! is on it.

retf wrote:

Does the computer skip the USB stick altogether and just boot like normal?

Yes

retf wrote:

Do you get an error like, "Operating System Not Found."  ?

No

retf wrote:

]Does the computer not give a "post" beep when the USB stick is inserted and the power button pressed?

No

retf wrote:

Have you checked the BIOS settings to ensure the USB drive is the top bootable device?

Yes, but mostly I use the boot menu.

retf wrote:

How do you know the ISO file is correct? Have you verified the md5sum?

Yes, also I booted a VM from it without problems as explained in my OP.

retf wrote:
sudo dd if=crunch-xxxx-.iso of=/dev/sdx

Should always work from nearly any GNU/Linux distribution to correctly copy the iso to the usb drive.  Also, since dd just copies bytes, there is no need to partition or format the USB stick - and in fact, any data stored on the drive will be overwritten anyway, including partition data.

I understand this to be the case.

Hopefully that is a little clearer now. Let me know if you have more questions, I'll answer as many as it takes to get this solved! smile

Last edited by vascowhite (2014-01-15 16:45:39)

Offline

#4 2014-01-15 16:45:26

iann
#! Die Hard
Registered: 2010-09-10
Posts: 720

Re: [Solved] Cannot create #! bootable USB

Is this another UEFI secure boot issue?

You say that you can boot from the USB, but every example you gave said it failed to boot.  What have you booted from it?

Offline

#5 2014-01-15 16:47:48

vascowhite
Member
From: Wirral, UK
Registered: 2014-01-14
Posts: 17
Website

Re: [Solved] Cannot create #! bootable USB

iann wrote:

Is this another UEFI secure boot issue?

You say that you can boot from the USB, but every example you gave said it failed to boot.  What have you booted from it?

The only thing that fails to boot is #!. I have booted Ubuntu, Debian, Xubuntu and Lubuntu from the same USB in the same slot. Secure boot is turned off in the BIOS.

Offline

#6 2014-01-15 16:56:03

retf
#! CrunchBanger
From: On top of spaghetti
Registered: 2013-12-25
Posts: 200

Re: [Solved] Cannot create #! bootable USB

Normally a BIOS level boot menu doesn't check the media for a valid bootable source before listing it - or at least that's been my experience with about 10 different PCs/servers.  So, I'm at a bit of a loss as to why the USB stick wouldn't be listed as a bootable media.  If you have a second USB stick that is either blank or only has regular files on it, you could test this out on your PC --- if this second USB stick shows up on the BIOS level boot menu, then I would suspect the USB stick as the problem...

Offline

#7 2014-01-15 16:59:24

vascowhite
Member
From: Wirral, UK
Registered: 2014-01-14
Posts: 17
Website

Re: [Solved] Cannot create #! bootable USB

The same USB stick shows up fine with other distro's on it. Strange eh? I have tried three different sticks so far!

This is a strange one.

Offline

#8 2014-01-15 17:03:23

retf
#! CrunchBanger
From: On top of spaghetti
Registered: 2013-12-25
Posts: 200

Re: [Solved] Cannot create #! bootable USB

So, does an unprepared, definitely non-bootable USB stick show up in the boot menu?

Offline

#9 2014-01-15 17:05:17

vascowhite
Member
From: Wirral, UK
Registered: 2014-01-14
Posts: 17
Website

Re: [Solved] Cannot create #! bootable USB

Yes.

Offline

#10 2014-01-15 17:08:27

retf
#! CrunchBanger
From: On top of spaghetti
Registered: 2013-12-25
Posts: 200

Re: [Solved] Cannot create #! bootable USB

I've been paging through the manual for the laptop you linked to in your first post...
What is your "Boot Option #1" in your BIOS?  Is it "Windows Boot Manager" ?

Offline

#11 2014-01-15 17:11:21

vascowhite
Member
From: Wirral, UK
Registered: 2014-01-14
Posts: 17
Website

Re: [Solved] Cannot create #! bootable USB

Well it was, but now it is Debian. I have tried moving the USB up to position 1 already.

Offline

#12 2014-01-15 17:19:05

retf
#! CrunchBanger
From: On top of spaghetti
Registered: 2013-12-25
Posts: 200

Re: [Solved] Cannot create #! bootable USB

Well - I think I'm stuck on this one...

You've indicated that the BIOS level boot menu on your ASUS laptop somehow includes every USB device except for one that has a crunchbang iso written to it...

The last test would be to try an unformated, unpartitioned USB stick...  if you remove all partitions on a sacrificial USB stick and overwrite the whole drive with random data like this:

dd if=/dev/urandom of=/dev/sdx bs=1M

Then insert this very blank USB stick and see if it appears in the boot menu... if it does, then - well - I really don't what to tell you about the boot menu refusing to 'see' the crunchbang USB stick...

EDIT:
using /dev/urandom might take a VERY long time... so if you are going to try a VERY blank USB use this:

dd if=/dev/zero of=/dev/sdx bs=1M

Last edited by retf (2014-01-15 17:27:32)

Offline

#13 2014-01-15 18:45:35

vascowhite
Member
From: Wirral, UK
Registered: 2014-01-14
Posts: 17
Website

Re: [Solved] Cannot create #! bootable USB

The zero'd USB drive did not show in the boot menu, however, the same drive formatted as FAT32, but empty does show up.

I'm going to buy a couple of new drives tomorrow and try again in case I'm just unlucky with the ones I have here. I'll let you know how I get on.

Offline

#14 2014-01-15 19:04:32

retf
#! CrunchBanger
From: On top of spaghetti
Registered: 2013-12-25
Posts: 200

Re: [Solved] Cannot create #! bootable USB

I think the #! installation iso runs from an NTFS partition.
Try formatting a USB stick with a generic NTFS partition and see if that shows in the boot menu...
Of course, you could run down the list of common linux filesystems...
EXT2
EXT3
EXT4

To create each of these in a GNU/Linux distro command line:
1. Use fdisk to create a partition.
2. Change partition type to either 83 for Linux FS's or 86 maybe 87 for NTFS.
3. Write partition table and exit.
4. Create filesystem using:

mkfs -t ntfs /dev/sdx1
or
mkfs -t ext2 /dev/sdx1
etc.

Then see if each filesystem shows up in the boot menu...
You could then determine which FS's show up and which ones don't...

I think Debian and Ubuntu use FAT32 for the USB boot images.

If the computer will only boot FAT32 FS than you might be able to get #! working by playing around with the iso in isomaster or something like it...
http://www.littlesvr.ca/isomaster/

installable via the repos...

apt-get install isomaster

Offline

#15 2014-01-16 12:02:17

vascowhite
Member
From: Wirral, UK
Registered: 2014-01-14
Posts: 17
Website

Re: [Solved] Cannot create #! bootable USB

I tried all those file systems, with no luck. I didn't expect it to work as DD writes the fs on the ISO to the USB drive anyway, but it was worth a try. I bought two new USB drives this morning and have had the same result with them both. I can boot from them if they have any of Lubuntu, Xubuntu, Ubuntu, Debian, Fedora, or CentOs on them, however once I write the crunchbang ISO to the USB the computer will not boot from it! Interestingly, I just discovered the same issue with Puppy Linux.

Basically, I think I'm going to have to give up on #!, which is a shame as I like the look of it. However, I can't find out why the ISO produces an unreadable USB drive.

If I ever find a solution I'll repost here with an update.

Offline

#16 2014-01-16 12:08:53

retf
#! CrunchBanger
From: On top of spaghetti
Registered: 2013-12-25
Posts: 200

Re: [Solved] Cannot create #! bootable USB

It seems you've misunderstood me...
I figured it might useful to figure out if a blank USB stick formatted in various filesystems would show up in your boot menu...
You've now done lots more work by formatting [yes] and then using dd [no]
sorry neutral

Given the discussion, I think it's fairly safe to say that your BIOS will only recongize FAT32 formatted USB sticks as bootable devices.  In that case, it doesn't look like an unmodified #! live install iso image will work for you on this machine using a USB stick.

Last edited by retf (2014-01-16 12:10:11)

Offline

#17 2014-01-16 12:15:19

vascowhite
Member
From: Wirral, UK
Registered: 2014-01-14
Posts: 17
Website

Re: [Solved] Cannot create #! bootable USB

Oops, sorry :8

I really do appreciate the help you've provided so far. I will probably keep on trying as I hate giving up before I understand why I can't achieve what I set out to do.

retf wrote:

Given the discussion, I think it's fairly safe to say that your BIOS will only recongize FAT32 formatted USB sticks as bootable devices.  In that case, it doesn't look like an unmodified #! live install iso image will work for you on this machine using a USB stick.

I think you are right, I'll continue investigating along those lines.

Offline

#18 2014-01-16 12:21:33

iMBeCil
WAAAT?
From: Edrychwch o'ch cwmpas
Registered: 2012-03-22
Posts: 1,026
Website

Re: [Solved] Cannot create #! bootable USB

How about BIOS update? (You should probably have to install MSWin for this ...).


Postpone all your duties; if you die, you won't have to do them ..
--> The very new BL forum! <--

Offline

#19 2014-01-16 12:26:54

pdc
#! Member
From: America
Registered: 2013-12-03
Posts: 52
Website

Re: [Solved] Cannot create #! bootable USB

Crazy shot in the dark. The #! .iso is supposed to be isohybrid, but maybe something is wrong with the way that is being created.

If you're not completely out of patience, you could try manually applying isohybrid [.iso filename] from the command line and then using dd.

EDIT: explanation of isohybrid here

Last edited by pdc (2014-01-16 12:29:51)


Anything that doesn't take years of your life and drive you to suicide hardly seems worth doing.
-Cormac McCarthy

Offline

#20 2014-01-16 12:48:17

retf
#! CrunchBanger
From: On top of spaghetti
Registered: 2013-12-25
Posts: 200

Re: [Solved] Cannot create #! bootable USB

If you want to get creative you could use dd to copy over an uefi boot image - expanded, of course, to be large enough to include a copy of the #! iso... and then copy over the iso...  This is similar to the Debian USB install...

Offline

#21 2014-01-16 13:45:46

vascowhite
Member
From: Wirral, UK
Registered: 2014-01-14
Posts: 17
Website

Re: [Solved] Cannot create #! bootable USB

I had another look through the BIOS and came across a menu item called CSM in the boot menu. I hadn't taken any notice of it before, but I had a look on the AMI web site and found that CSM stands for Compatibility Support Module, so I enabled it and #! booted and installed from the USB!

Thanks for all your help. I think I would have given up before now without it.

Hopefully this will help others having problems booting from USB on a UEFI machine.

Offline

#22 2014-03-14 21:14:55

xenoph
New Member
Registered: 2014-03-14
Posts: 4

Re: [Solved] Cannot create #! bootable USB

vascowhite wrote:

I had another look through the BIOS and came across a menu item called CSM in the boot menu. I hadn't taken any notice of it before, but I had a look on the AMI web site and found that CSM stands for Compatibility Support Module, so I enabled it and #! booted and installed from the USB!

Thanks for all your help. I think I would have given up before now without it.

Hopefully this will help others having problems booting from USB on a UEFI machine.

You, my distant and fantastic human, I owe you great thanks, as I finally found this thread and managed to boot up #!.
If I didn't have the wife sitting close to me, I'd pour my heart out of my undying love for this thread.

Offline

#23 2014-03-14 21:31:08

vascowhite
Member
From: Wirral, UK
Registered: 2014-01-14
Posts: 17
Website

Re: [Solved] Cannot create #! bootable USB

I'm happy that this helped somebody else. It seems that only those who are distant think I'm fantastic smile

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo