SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2014-01-07 18:05:23

oinkerz
Member
Registered: 2014-01-07
Posts: 20

CrunchBang on VPS - No Internet

Hey guys, I rented out a VPS just to throw a lightweight linux distro such as crunchbang on. I know that's not ideal, but just go with it  big_smile

Basically I have a VPS using a e1000 virtual NIC, however when I boot up #! it just says that both wired networks (eth0/eth1) are "disconnected" and that's it. I'm not sure what really to try and do to fix this.

I installed the #! 32-bit Waldorf for Modern PCs (crunchbang-11-20130506-i686.iso)

Any help would be greatly appreciated!

Offline

Help fund CrunchBang, donate to the project!

#2 2014-01-07 20:10:41

dot|not
#! Junkie
From: /dev/null
Registered: 2013-09-05
Posts: 371

Re: CrunchBang on VPS - No Internet

What does

ifconfig -a

say? Also what kind of VPS? KVM, OpenVZ? (Just for the records: Install Debian.)

Offline

#3 2014-01-07 21:13:34

oinkerz
Member
Registered: 2014-01-07
Posts: 20

Re: CrunchBang on VPS - No Internet

Hi dot|not, thanks for the reply. I'm 99% sure they run xen. And here is my ifconfig -a output:

xdcPJWz.png


Edit: also lspci shows no network/ethernet controller

Last edited by oinkerz (2014-01-07 21:29:55)

Offline

#4 2014-01-07 22:38:28

oinkerz
Member
Registered: 2014-01-07
Posts: 20

Re: CrunchBang on VPS - No Internet

Found the solution to the problem.

Turns out there's a slight, bug if you will, with running Debian and Xen.

I had to navigate to /boot/grub/ and edit the grub.cfg file.

There is a line that looks similar to this:

linux	/boot/vmlinuz-3.2.0-4-686-pae root=UUID=xxx-xxx-xxx-xxx	ro	quiet

I added this bit of code onto the end:

xen_emul_unplug=never

So it looks like this:

linux	/boot/vmlinuz-3.2.0-4-686-pae root=UUID=xxx-xxx-xxx-xxx	ro	quiet	xen_emul_unplug=never

Hope this helps anyone who runs into a similar situation.

Offline

#5 2014-02-14 02:28:29

tradetaxfree
#! CrunchBanger
Registered: 2011-03-05
Posts: 126

Re: CrunchBang on VPS - No Internet

The best way to add kernel options @ boot time:

Edit /etc/default/grub & add them to the following line:

GRUB_CMDLINE_LINUX="xen_emul_unplug=never"

& then run

sudo update grub

This way the kernel options will survive kernel upgrades.

Also for a lightweight distro for a VPS - look at Alpine Linux "small simple secure" If you are going to run any internet facing services (http / mail / mysql / php / vpn etc...) - you can isolate the services from the host system with an Alpine LXC Guest (a basic working guest is 5 megabytes in size). The Alpine LXC Templates are also included with LXC in Debian so you could also run Alpine Guests in Crunchbang (or Debian LXC Guests in Alpine)

To setup networking in Alpine:

setup-interfaces
ifup eth0
setup-apkrepos
rc-update add networking boot
rc-service networking start

(& maybe change the nameserver in /etc/resolv.conf)

This guide on LXC Networking is very helpful for setting up a DMZ.

The LXC currently in the Testing Repos is 0.90 & does not have Unprivileged Containers). A 32 bit Debian Testing deb file is here for the latest LXC 1.0 RC4 (which does have Unprivileged Containers). It also has a newer template version for Alpine which works out of the box. To build a 64 bit LXC deb you will need autogen & checkinstall installed:

sudo apt-get install autogen checkinstall
# & in the source directory
./autogen.sh
./configure
make
checkinstall --install=no

& this will build a deb that installs under /usr/local.

Last edited by tradetaxfree (2014-02-20 08:06:28)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo