SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-12-23 10:32:19

Malice
#! Member
From: Poland
Registered: 2013-10-15
Posts: 50

X(openbox?) won't open automatically

At least that's my guess.
Yesterday I switched from Wheezy to jessie. It turned out that Jessie downloaded gnome and made it default. Yet it would not start - after login screen, when I enter login and password, the "login" window disappears, and nothing else happens.

If I go to tty, login, and type "startx", after a (longer then before) while, everything will load fine. Now, there are two things I would like to change:
1. I would like X(openbox?) to open automatically, so I don't have to type "startx" every time I log in.
2. In the process of switching, my mouse pointer also changed - now it's black, and looks like it's taken from gnome... I would like simple white mouse pointer back.

Output of update-alternatives:

malice@crunchbang:~$ sudo update-alternatives --config x-session-manager
[sudo] password for malice: 
There is 1 choice for the alternative x-session-manager (providing /usr/bin/x-session-manager).

  Selection    Path                      Priority   Status
------------------------------------------------------------
*  0            /usr/bin/openbox-session   40        auto mode
   1            /usr/bin/openbox-session   40        manual mode

And dpkg -l *gnome* gave me this output:

malice@crunchbang:~$ dpkg -l gnome*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
un  gnome          <none>                    (no description available)
ii  gnome-accessib 3.8.4-1      all          Accessibility themes for the GNOM
ii  gnome-bluetoot 3.8.1-2      amd64        GNOME Bluetooth tools
un  gnome-codec-in <none>                    (no description available)
un  gnome-color-ma <none>                    (no description available)
ii  gnome-contacts 3.8.3-1+b1   amd64        Contacts manager for GNOME
ii  gnome-control- 1:3.8.3-4    amd64        utilities to configure the GNOME 
ii  gnome-control- 1:3.8.3-4    all          configuration applets for GNOME -
ii  gnome-desktop- 2.32.1-2     all          Common files for GNOME desktop ap
ii  gnome-desktop3 3.8.4-2      all          Common files for GNOME desktop ap
un  gnome-games    <none>                    (no description available)
ii  gnome-icon-the 3.10.0-1     all          GNOME Desktop icon theme
ii  gnome-icon-the 3.6.2-3      all          GNOME Desktop icon theme (additio
ii  gnome-icon-the 3.10.1-1     all          GNOME desktop icon theme (symboli
ii  gnome-keyring  3.8.2-2      amd64        GNOME keyring services (daemon an
un  gnome-media-co <none>                    (no description available)
ii  gnome-menus    3.8.0-2      amd64        GNOME implementation of the freed
ii  gnome-mime-dat 2.18.0-1     all          base MIME and Application databas
ii  gnome-online-a 3.8.3-2      amd64        GNOME Online Accounts
un  gnome-orca     <none>                    (no description available)
un  gnome-osd      <none>                    (no description available)
un  gnome-panel    <none>                    (no description available)
un  gnome-phone-ma <none>                    (no description available)
un  gnome-power-ma <none>                    (no description available)
un  gnome-screensa <none>                    (no description available)
un  gnome-session  <none>                    (no description available)
ii  gnome-session- 3.8.4-3      amd64        GNOME Session Manager - Minimal r
ii  gnome-session- 3.8.4-3      all          GNOME Session Manager - common fi
ii  gnome-settings 3.8.5-2      amd64        daemon handling the GNOME session
ii  gnome-shell    3.8.4-5      amd64        graphical shell for the GNOME des
ii  gnome-shell-co 3.8.4-5      all          common files for the GNOME graphi
un  gnome-sudo     <none>                    (no description available)
un  gnome-terminal <none>                    (no description available)
un  gnome-themes-e <none>                    (no description available)
ii  gnome-themes-s 3.8.4-1      amd64        Standard GNOME themes
ii  gnome-themes-s 3.8.4-1      all          Data files for GNOME standard the
un  gnome-tweak-to <none>                    (no description available)
ii  gnome-user-gui 3.8.2-1      all          GNOME user's guide
ii  gnome-user-sha 3.8.3-1      amd64        User level public file sharing vi
un  gnome-utils    <none>                    (no description available)
un  gnome-www-brow <none>                    (no description available)

I would like to get rid of gnome, if it's possible.
If I didn't include some information, feel free to ask.
Thank you in advance.

Last edited by Malice (2013-12-28 13:23:09)

Offline

Be excellent to each other!

#2 2013-12-23 11:43:37

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: X(openbox?) won't open automatically

many, many, many people have recently borked their systems in the way you describe.
please use the forum search (magnifying glass in the top right corner) to locate appropriate threads.

Offline

#3 2013-12-23 13:09:19

Malice
#! Member
From: Poland
Registered: 2013-10-15
Posts: 50

Re: X(openbox?) won't open automatically

Maybe some suggestions what to look for or links, please? I have been looking for solution for an hour and didn't find anything...

PS. This may be caused by gnome - after upgrading to jessie I had openbox and gnome. I removed gnome-session with apt-get, but nothing more.

Last edited by Malice (2013-12-23 13:52:48)

Offline

#4 2013-12-23 14:18:44

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: X(openbox?) won't open automatically

Couple of thoughts....

I'm not at a linux box right now, but the output of update-alternatives --config x-session-manager doesn't look right - should there be 2 entries for OB?

Check out slim.conf and see if that looks ok; remove alternative wm's from the list if you have them maybe?

You can change cursor with obconf (OB settings) iirc. Or if it still applies in this release, update-alternatives may have an x-cursor-theme choice


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#5 2013-12-23 15:10:52

Malice
#! Member
From: Poland
Registered: 2013-10-15
Posts: 50

Re: X(openbox?) won't open automatically

My slim.conf:
http://pastebin.com/bMYrGkyg

Doesn't look like there's anything wrong.

Offline

#6 2013-12-23 15:54:41

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: X(openbox?) won't open automatically

Next thing I might try is

sudo service slim stop/start

and see if there are any error messages in the terminal. Also find where slim's log is and tail the last few lines to see what it says.

(The trouble is most of the hardware and system gurus are spending their time on Arch, Vsido and BBQ these days, and I don't know enough! sad )


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#7 2013-12-23 16:12:14

Malice
#! Member
From: Poland
Registered: 2013-10-15
Posts: 50

Re: X(openbox?) won't open automatically

Your command gave this output:

Usage: /etc/init.d/slim {start|stop|restart|force-reload}

So I don't see any error messages.
Other logs:

/var/log/Xorg.0.log | grep WW :

http://pastebin.com/munj6DTA

/var/log/slim.log :

http://pastebin.com/asJCCrZH

I just installed newest NVidia drivers using smxi, but nothing happened...

Last edited by Malice (2013-12-23 16:13:09)

Offline

#8 2013-12-23 16:27:25

Malice
#! Member
From: Poland
Registered: 2013-10-15
Posts: 50

Re: X(openbox?) won't open automatically

Is there anyone that can help me? I'm having this trouble since yesterday, nothing seems to work, only more things are breaking. Now my alt menu doesn't work properly(it opens programs, but it doesn't list programs nor suggests anything when I input name.

Also, steam isn't working now - it says that I'm missing following 32-bit library:
libGL.so.1

Please help... If you want to contact me directly, I'm logged in on #crunchbang IRC channel, as Malice.

Offline

#9 2013-12-23 16:29:21

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: X(openbox?) won't open automatically

Yesterday I switched from Wheezy to jessie.

NVIDIA(GPU-0): The EDID for Idek Iiyama PL2209HD (DFP-1) contradicts itself:

I bet that's the culprit. I had a major nvidia problem with a recent dist-upgrade with testing, so I used smxi to go back to an earlier driver. What happens if you boot to your previous kernel?

Did you actually do

sudo service slim start

then

sudo service slim stop

the order depending on whether it is running or not

I hope you didn't actually try

sudo service slim stop/start

- that was just supposed to be a bit of shorthand! Sorry if I wasn't clear enough.


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#10 2013-12-23 16:33:15

Malice
#! Member
From: Poland
Registered: 2013-10-15
Posts: 50

Re: X(openbox?) won't open automatically

damo - I did... tongue
anyway, output from your commands:

malice@crunchbang:~$ sudo service slim start
[sudo] password for malice: 
Starting X display manager: slim already running.
malice@crunchbang:~$ sudo service slim stop
Stopping X display manager: slim.

Also, now every time I open terminator, I can see the line:

bash: /usr/lib/git-core/git-sh-prompt: No such file or directory
malice@crunchbang:~$ 

I just reinstalled drivers to the newest ones, and as I said - now steam isn't working at all, and alt menu isn't working as it should...

Offline

#11 2013-12-23 16:37:30

Malice
#! Member
From: Poland
Registered: 2013-10-15
Posts: 50

Re: X(openbox?) won't open automatically

Your commands do not show any errors. These only let me  go to login screen, where everything goes as usual.

Maybe it will tell you something, that now I have ttys at F1-F6, at F7 I have the non-working blank after-login screen, and I'm using GUI at F8.

Offline

#12 2013-12-23 22:17:47

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: X(openbox?) won't open automatically

Malice wrote:

Maybe some suggestions what to look for or links, please? I have been looking for solution for an hour and didn't find anything...

http://crunchbang.org/forums/viewtopic.php?id=29740
http://crunchbang.org/forums/viewtopic.php?id=30691
would you like a foot massage with that?

Offline

#13 2013-12-23 23:08:28

Malice
#! Member
From: Poland
Registered: 2013-10-15
Posts: 50

Re: X(openbox?) won't open automatically

Links are sufficient. Thank you for that.

Offline

#14 2013-12-23 23:55:26

Malice
#! Member
From: Poland
Registered: 2013-10-15
Posts: 50

Re: X(openbox?) won't open automatically

Okay, fixed. Thank you ohnonot, dano, and many people from #! IRC help channel for helping me.
if anyone encounter the same problem:
I kind of did the same thing as ew in this topic: http://crunchbang.org/forums/viewtopic.php?id=27309
Unfortunately, I didn't know about dependencies before, so after I installed it, I first had to (re)install nVidia drivers.
After that, I reinstalled them with smxi, and I could login using startx.
However, it threw me to gnome, so I uninstalled gnome-session, switched using update--alternatives to openbox, and rebooted.
Now It would log me to openbox... but I still had to use startx.
Then I uninstalled the things mentioned in ew's topic(gnome-bluetooth, and bluez). Reinstalled, and now it seems to be working.

Last edited by Malice (2013-12-23 23:56:03)

Offline

#15 2013-12-24 08:13:03

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: X(openbox?) won't open automatically

Great! All part of the linux learning experience big_smile


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#16 2013-12-28 13:22:48

Malice
#! Member
From: Poland
Registered: 2013-10-15
Posts: 50

Re: X(openbox?) won't open automatically

Okay. No point in creating new thread. Turns out it isn't solved, I still have to use startx to log in. It worked at the first time, and then maybe twice. Any ideas?

When I use startx, I am sent to tty8(I hope it's called so - I get there with C-M-F8). tty7(C-M-F7) is the screen where I was logging in without success - I can see only default login background there, nothing more.

Offline

#17 2013-12-28 18:15:40

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: X(openbox?) won't open automatically

does that mean you're coming to a text interface (terminal, console...), where you have to login first and then type startx?
and when you do that, is your desktop ok otherwise?

if so, i'd say it's a login or display manager problem.
check if you have any installed.
there's a file somewhere in the dungeons of /etc which defines the default display manager, maybe it points to a non-existing one?
i had this problem once and got it solved by sudo-editing one textfile, but i don't remember exactly...
i can help you, but please do the first steps yourself.

if you have more problems than that, i'd say the easiest solution is a reinstall. my opinion.
btw, respect that you got it back on track.

Offline

#18 2013-12-28 19:10:37

Malice
#! Member
From: Poland
Registered: 2013-10-15
Posts: 50

Re: X(openbox?) won't open automatically

@ohnonot - After grub(choosing kernel), slim opens normally. I can enter login and password in GUI, but after that nothing happens.
"Window", where I wrote my login and password is gone, and nothing but background can be seen. No mouse pointer, nothing at all.
All of this happens in C-M-F7 space(so it's probably called tty7, I guess).
After that, I enter other tty(doesn't matter which one), log in there, and type "startx". It sends me to C-M-F8("tty8"?), and I am logged-in. Everything works there. However, on C-M-F7 there's still this blank login screen.

Reinstalling is not an option.
I tried solving this problem. Also, not alone - many people on IRC tried too, but it seems that this isn't so simple to fix. smile

I've found this about Slim:
https://bugs.freedesktop.org/show_bug.cgi?id=62866#c1

Where I don't understand much apart from that Slim may not be working correctly with systemd.
@ohnonot - if you are logged-in now, I'm on #crunchbang. You may come here and try to help me directly. I'm sitting on #crunchbang IRC channel quite often, it shouldn't be hard to catch me there.

As for doing first steps myself - I checked some files in /etc(slim.conf, grub), but grub seems unrelated, and in slim.conf I can't find anything wrong. I don't know what else should I look for.

Help would be appreciated.
Also, thanks for reply.

Edit:
Okay, checked /etc/X11/default-display-manager and it points to /usr/bin/slim, which exists.

Last edited by Malice (2013-12-28 19:19:44)

Offline

#19 2013-12-30 17:02:20

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: X(openbox?) won't open automatically

hmm, i recently read a thread where someone had this exact same problem:
logging in with the display manager did not succesfully start an xsession, but changing tty and starting x "manually" did.

it could be that your displays got confused and only when the first display is occupied, the login works on the second.

anyhow i will try to find the thread (i think it was on archlinux' forums) and return.

Offline

#20 2014-01-04 18:05:16

Malice
#! Member
From: Poland
Registered: 2013-10-15
Posts: 50

Re: X(openbox?) won't open automatically

I see this problem is tough smile I decided to uninstall slime. If that's causing problem, then I'll just get rid of it... Unfortunately.
I won't mark as solved, since it wasn't really solved, but the case is closed.

Offline

#21 2014-03-03 23:39:03

auxym
New Member
Registered: 2014-03-03
Posts: 3

Re: X(openbox?) won't open automatically

Hi, I'm having the exact same problem, with openbox not starting after slim login. This is also after upgrading to jessie sources. Manually doing startx in a tty does work. Has anybody found a solution yet? Here's some more info.

I tweaked a copy of /etc/X11/Xsession like indicated in this thread to understand what is going. Upon running it, this gets output:

xrdb: Can't open display ''

Also, the script never gets to the final

exec $STARTUP

Any ideas?

Offline

#22 2014-03-04 01:58:44

ew
#! Die Hard
Registered: 2012-09-27
Posts: 1,975

Re: X(openbox?) won't open automatically

Someone should warn people not to upgrade to Jessie before they have removed gnome-bluetooth, or as I do. I change my sources to Jessie or Sid. Then I do this:

sudo apt-get update && sudo apt-get --no-install-recommends install gnome-bluetooth

Then gnome-bluetooth gets upgraded without dragging in the full gnome-desktop, and then I run a simulate dist-upgrade to see if everything is fine:

sudo apt-get -s dist-upgrade

If this shows a lot of gnome-packages related to the gnome-desktop, then it`s time to hunt down the packages that drags in gnome, and upgrade them with "--no-install-recommends". First when a simulate dist-upgrade looks fine, first then is it ok to actually do the upgrade, and if anyone are in doubt, abort and post the output on the forum, so we can approve the package list that are going to be installed.

Even the "openbox" package triggered the gnome stuff a while ago, and Jessie or Sid shouldn't be recommended to newbies, without a mentor holding their hands trough it. If the newbies have a little patience, there will always be some of us that are willing to help them. Why not ask for help before you break it, instead of asking for help to fix the breakage. It`s much much easier to avoid issues like this, than it is to fix them.

But of course, we will help them afterwards too, but I really think that this community should have a big sticky thread somewhere with warnings about things to watch for when upgrading to jessie/sid. And it needs to be a highly visible thread, that`s not possible to miss.

Last edited by ew (2014-03-04 01:59:13)


- apt-mark hold account

Offline

#23 2014-03-04 07:30:06

Jimbo_G
#! Barcalounger
From: Paris, France
Registered: 2009-12-08
Posts: 136

Re: X(openbox?) won't open automatically

Isn't that the purpose of this thread in testing / unstable : http://crunchbang.org/forums/viewtopic.php?id=29337

Offline

#24 2014-03-04 12:19:13

ew
#! Die Hard
Registered: 2012-09-27
Posts: 1,975

Re: X(openbox?) won't open automatically

Jimbo_G wrote:

Isn't that the purpose of this thread in testing / unstable : http://crunchbang.org/forums/viewtopic.php?id=29337

Probably. But there isn`t a initial post that contains the most important things to look out for, and my guess is that nobody is reading trough the entire thread before they upgrade.... This issue with the gnome-desktop being dragged in are a very old issue, well-known, and probably the single most important information before a upgrade, along with the issues because the waldorf-theme doesn`t support gtk-3.8. People make those errors over and over again....


- apt-mark hold account

Offline

Be excellent to each other!

#25 2014-03-04 13:08:14

Jimbo_G
#! Barcalounger
From: Paris, France
Registered: 2009-12-08
Posts: 136

Re: X(openbox?) won't open automatically

I agree that it's not very clear how to upgrade and what to watch out for if you do upgrade. From my point of view this is actually a good thing as it means I can't be tempted to break my computer and have to keep asking for help on here wink

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo