SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-06-27 19:03:59

annoyingbeggar
#! Junkie
From: Florida
Registered: 2013-05-30
Posts: 430

[SOLVED] Suspend works in #! but not Vanilla Debian

Posting here first instead of the Debian forums because suspend works in #!... I'd rather not have two threads open so I want to try and get you all's ideas first.

My netbook is currently dual-booting #! tracking both testing and unstable and vanilla Debian-XFCE full testing and tracking unstable. Both systems are running the same kernel and have the same graphics modules loaded and both use the XFCE power manager and the same version of pm-utils but #! uses the Waldorf specific xfce4-power-manager while Debian uses the testing/unstable version. (I don't think this is the issue as the problem exists when running pm-suspend from the command line.)

In #! pm-suspend and xfce4-power-manager work as they should. In Debian both successfully suspend and (according to the logs) successfully resume as well. However, in Debian the screen fragments and it appears the gfx module crashes (no access to TTY terminals.) The card is Polsubo/CedarTrail and the issue seems to be the same as it was in kernels <3.3.

Some details below with my thoughts:

uname -r (same in both)

3.9-7.dmz.1-liquorix-686

(The same issue exists in the regular Debian kernels as well including 3.8 and earlier 3.9 builds. I have not tried to roll my own on the Debian system because I don't have the time at the moment but considering how well this one works in #! I think it should work similarly in Debian.)

lsmod | grep gfx (same in both)

gma500_gfx            161040  2 
drm_kms_helper         38384  1 gma500_gfx
drm                   227819  2 drm_kms_helper,gma500_gfx
i2c_algo_bit            4965  1 gma500_gfx
i2c_core               21660  6 drm,i2c_i801,drm_kms_helper,i2c_algo_bit,gma500_gfx,videodev
video                  10955  2 acer_wmi,gma500_gfx

Running nomodeset doesn't fix the issue. The only boot option in Grub is "quiet" for both. Changing acpi settings hasn't been tested but I haven't had a need to do that for about a year now thanks to kernel/gma500_gfx improvements.

I've tried messing around with quirk options in the Debian system but the commonly available ones haven't worked. Does #! have any preset quirks enable with pm-suspend? Is that even possible?

Software differences:

Debian uses a slightly newer version of upower. I have no idea if this makes a difference because, to be honest, I'm not quite sure what upower actually does or if it's polled during suspend.

Debian uses xfce4-power-manager 1.2, #! uses 1.0 from the Waldorf repositories.

My final thoughts:

Debian obviously comes with non-free and contrib disabled by default, though they are enabled now. Does anyone know of a non-free or contrib package that may lead to this issue? Previously pm-suspend has also worked on Xubuntu, Lubuntu, and AntiX -- all of which are Debian-based with non-free and contrib enabled which is leading me to think this may be a part of the problem. Unfortunately the package differences between the two installs are too large to compare and see.

EDIT:

Xorg.0.log, pm-suspend.log show no errors. In fact, running cat /var/log/*.log | grep EE shows nothing out of the ordinary.

Last edited by annoyingbeggar (2013-06-28 04:44:52)


“I don't believe in charity. I believe in solidarity. Charity is so vertical. It goes from the top to the bottom. Solidarity is horizontal. It respects the other person. I have a lot to learn from other people.” - Eduardo Hughes Galeano

Offline

Help fund CrunchBang, donate to the project!

#2 2013-06-27 22:25:39

DogMatix
Member
From: UK
Registered: 2012-05-04
Posts: 34

Re: [SOLVED] Suspend works in #! but not Vanilla Debian

uname -r

3.2.0-4-686-pae

!# tracking Jessie and pm-suspend & pm-hibernate seem to work fine. They certainly did not in Ubuntu 12.04, last time I tried and I don't believe they did in Waldorf !#.

Not sure about Lubuntu 13.04 (as that machine is elsewhere currently) but I'll check that tomorrow as that is a 3.9 kernel (I think).

I'd love to see an end to suspend/hibernate issues as we have had several desktops burning the midnight oil needlessly for over a year now.


Your mind will answer most questions if you learn to relax and wait for the answer. - William Burroughs

Offline

#3 2013-06-28 00:06:32

annoyingbeggar
#! Junkie
From: Florida
Registered: 2013-05-30
Posts: 430

Re: [SOLVED] Suspend works in #! but not Vanilla Debian

Updated upower (it is involved) and #! remains fine. I'm going to check versions on packages listed here and will report back.

DogMatix wrote:

uname -r

3.2.0-4-686-pae

!# tracking Jessie and pm-suspend & pm-hibernate seem to work fine. They certainly did not in Ubuntu 12.04, last time I tried and I don't believe they did in Waldorf !#.

Not sure about Lubuntu 13.04 (as that machine is elsewhere currently) but I'll check that tomorrow as that is a 3.9 kernel (I think).

I'd love to see an end to suspend/hibernate issues as we have had several desktops burning the midnight oil needlessly for over a year now.

3.2 is not possible for me, I lose too many things I need and it kills my battery.

If you are having a similar issue I would suggest checking what card you are using and searching for specific configurations that work. Most of them have some options which can be tweaked to make them work properly. The Arch wiki is particularly helpful. If you can find out (or post the output of lspci and lsmod here) I can help you look for a solution.


“I don't believe in charity. I believe in solidarity. Charity is so vertical. It goes from the top to the bottom. Solidarity is horizontal. It respects the other person. I have a lot to learn from other people.” - Eduardo Hughes Galeano

Offline

#4 2013-06-28 04:50:27

annoyingbeggar
#! Junkie
From: Florida
Registered: 2013-05-30
Posts: 430

Re: [SOLVED] Suspend works in #! but not Vanilla Debian

Getting rid of the 99video script inside /usr/lib/pm-utils/sleep.d/ ended up doing the trick!

I was able to replace it with the file from #! and it worked perfectly.


“I don't believe in charity. I believe in solidarity. Charity is so vertical. It goes from the top to the bottom. Solidarity is horizontal. It respects the other person. I have a lot to learn from other people.” - Eduardo Hughes Galeano

Offline

#5 2013-06-28 10:32:35

iann
#! Die Hard
Registered: 2010-09-10
Posts: 720

Re: [SOLVED] Suspend works in #! but not Vanilla Debian

annoyingbeggar wrote:

Getting rid of the 99video script inside /usr/lib/pm-utils/sleep.d/ ended up doing the trick!

I was able to replace it with the file from #! and it worked perfectly.

Spam?

Offline

#6 2013-06-28 10:44:41

rkwurth
#! Junkie
Registered: 2012-09-04
Posts: 365

Re: [SOLVED] Suspend works in #! but not Vanilla Debian

iann wrote:
annoyingbeggar wrote:

Getting rid of the 99video script inside /usr/lib/pm-utils/sleep.d/ ended up doing the trick!

I was able to replace it with the file from #! and it worked perfectly.

Spam?

No.

Offline

#7 2013-06-28 11:04:29

iann
#! Die Hard
Registered: 2010-09-10
Posts: 720

Re: [SOLVED] Suspend works in #! but not Vanilla Debian

furqan wrote:

/spam

Sorry, quoted the wrong message in my previous reply :8

So... spam?

Last edited by pvsage (2013-06-28 18:57:17)

Offline

#8 2013-06-28 19:01:10

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 13,970

Re: [SOLVED] Suspend works in #! but not Vanilla Debian

^ Spam.  (Well, 99.44% probability of becoming a spammer.)  Gone now.  "Noting to see here.  Move along."

Please do not respond to such messages in-thread; simply use the Report link, and one of us mods will take care of it.  "Thank you for your cooperation." cool

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo