SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-06-03 00:50:34

BogeyOne
New Member
Registered: 2013-05-22
Posts: 8

[SOLVED] Iceweasel alteration

Is it possible to make Iceweasel open without the "decorate" option in place?  I know it can be turned off, but is there a way to stop it from defaulting in the on setting?

Fingers crossed here. . .

Martin

Last edited by BogeyOne (2013-06-06 03:26:38)

Offline

Help fund CrunchBang, donate to the project!

#2 2013-06-03 09:46:15

joek
#! Junkie
Registered: 2011-09-06
Posts: 497

Re: [SOLVED] Iceweasel alteration

If you are running openbox:

  <applications>
    <application class="Iceweasel">
      <decor>no</decor>
    </application>
  </applications>

Should go in your ~/.config/openbox/rc.xml

Last edited by joek (2013-06-03 09:46:45)

Offline

#3 2013-06-05 02:48:27

BogeyOne
New Member
Registered: 2013-05-22
Posts: 8

Re: [SOLVED] Iceweasel alteration

If you are running openbox:

  <applications>
    <application class="Iceweasel">
      <decor>no</decor>
    </application>
  </applications>

Should go in your ~/.config/openbox/rc.xml

I copied and pasted your exact code to the location you prescribed, then saved it.  Nothing changed.  Iceweasel still starts with the deorate bar at the top.

Offline

#4 2013-06-05 03:25:41

kiiroitori
#! CrunchBanger
From: Tokyo, Japan
Registered: 2010-12-07
Posts: 229

Re: [SOLVED] Iceweasel alteration

Hello BogeyOne,

You can set such parameters with the "GUI applications settings editor", under setting->openbox from your openbox menu. Have a look and tell us how you are doing!


I love #! more than my own kids. I told them and they sympathized.

Offline

#5 2013-06-05 04:43:44

BogeyOne
New Member
Registered: 2013-05-22
Posts: 8

Re: [SOLVED] Iceweasel alteration

Hmm.  That will not open when I click on it.

Offline

#6 2013-06-05 05:31:50

anonymous
The Mystery Member
Registered: 2008-11-29
Posts: 9,419

Re: [SOLVED] Iceweasel alteration

BogeyOne wrote:

If you are running openbox:

  <applications>
    <application class="Iceweasel">
      <decor>no</decor>
    </application>
  </applications>

Should go in your ~/.config/openbox/rc.xml

I copied and pasted your exact code to the location you prescribed, then saved it.  Nothing changed.  Iceweasel still starts with the deorate bar at the top.

Did you restart/reconfigure Openbox afterwards?

Also try using class="Firefox*" instead. I know you're asking about Iceweasel, but just try it.

Offline

#7 2013-06-05 11:43:42

BogeyOne
New Member
Registered: 2013-05-22
Posts: 8

Re: [SOLVED] Iceweasel alteration

Well, upon rebooting the computer I get the message on startup about extra script in the prescribed location.  I close that box and start iceweasel and the decorate bar is gone.

Offline

#8 2014-10-02 19:05:36

Pi
#! Member
Registered: 2009-10-12
Posts: 76

Re: [SOLVED] Iceweasel alteration

I hate to bump an ancient thread, but because this shows up in a Google search, it's appropriate to have the answer.

http://unix.stackexchange.com/questions … ndecorated

This code is correct

    <application class="Iceweasel">
      <decor>no</decor>
    </application>

and should be put at the very end of the file, just before

</applications>
</openbox_config>

then run this to make the changes instant and to check the rc.xml file for errors.

openbox --reconfigure

Toadsworth on #crunchbang

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo