SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-01-23 00:40:05

adRn
New Member
Registered: 2013-01-22
Posts: 9

Language & Keyboard layout

First of all: CrunchBang, Openbox and Debian rocks! smile

Now, I'd like to suggest to change the installation process (graph install, at least).

Even though I'm from argentina and spanish is my mother tongue I like to install my linux(es) with all their software(s) and distro(s) in english since when I search for information on the internet for any how-to I've to do things like "Check the box that says <something in english>" instead of "Check the box that says <something in spanish with a bad translation that I won't be able to find".

Anyway, thing is that I wasn't unable to install crunchbang in english because the keyboard layout options where trimmed to the ones related to the language (that is, no Latinoamerica option).

Cheers. Keep up the good work.


How are we going to explain the future generations that "it was good for economy" when they'll be unable to farm their soils, breath some fresh air or drink the water?...

Offline

Be excellent to each other!

#2 2013-01-24 11:33:39

MekkaGodzilla
Member
From: Lyon, France
Registered: 2011-07-02
Posts: 18

Re: Language & Keyboard layout

I think at this step you can choose "other" and go "up" to choose your keyboard layout, starting from the continent level.
I know because I tend to install in French but with a us keyboard layout.

Worst case scenario, install with whatever keyboard layout, reboot, log in, and run "sudo dpkg-reconfigure keyboard-configuration" to change your keyboard layout. Reboot to apply.

Offline

#3 2013-10-02 23:08:38

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: Language & Keyboard layout

Are you using a "Spanish" keyboard or a "Latin American" keyboard?

They still sell "Latin American" keyboard here?  I thought it was all "Spanish" now.

You can change your keyboard layout with "sudo dpkg-reconfigure keyboard-configuration" as MekkaGodzilla said, closest choice is:

Spanish (Latin American) and that is available in the choices when installing.

A few years back there was a "Latin American" option but now with Portuguese (Brazil) they dropped it.

My file: /etc/default/keyboard looks like this:

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="microsoftpro"
XKBLAYOUT="latam"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

Last edited by Sector11 (2013-10-02 23:09:48)


·  ↓   ↓   ↓   ↓   ↓   ↓  ·
BunsenLabs Forums now Open for Registration
·  ↑   ↑   ↑   ↑   ↑   ↑  · BL ModSquad

Offline

#4 2013-10-02 23:20:57

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: Language & Keyboard layout

MekkaGodzilla wrote:

I know because I tend to install in French but with a us keyboard layout.

Worst case scenario, install with whatever keyboard layout, reboot, log in, and run "sudo dpkg-reconfigure keyboard-configuration" to change your keyboard layout. Reboot to apply.

You don't use a French Keyboard?  Interesting.

My worst case scenario that I applied just a little while back when I was having problems was to create a text file:
etc.default.keyboard.txt
which is an exact duplicate of the file above that I can copy/paste (as root) if needed.


·  ↓   ↓   ↓   ↓   ↓   ↓  ·
BunsenLabs Forums now Open for Registration
·  ↑   ↑   ↑   ↑   ↑   ↑  · BL ModSquad

Offline

#5 2013-10-03 11:18:52

GekkoP
#! Junkie
From: Vicenza (Italy)
Registered: 2013-06-17
Posts: 297
Website

Re: Language & Keyboard layout

I used sudo dpkg-reconfigure locales to fix my locale, and then sudo dpgk-reconfigure keyboard-configuration for the the keyboard.

Offline

#6 2013-10-14 06:51:09

alexx
New Member
Registered: 2013-10-14
Posts: 1

Re: Language & Keyboard layout

#!/bin/sh

# When I first installed #! (that was a good day) I created a script to "patch" my install to add everything that I need such as swapping between Qwerty and Azerty quickly. This is an extract of that script.

# toggle between query and azerty using Alt+caps_lock
setxkbmap -option grp:alt_caps_toggle,terminate:ctrl_alt_bksp,grp_led:scroll gb,fr &

# set it in place
sudo echo '
XKBMODEL="pc105"
XKBLAYOUT="gb,fr"
XKBVARIANT=","
XKBOPTIONS="grp:alt_caps_toggle,terminate:ctrl_alt_bksp,grp_led:scroll"

BACKSPACE="guess"
' > /etc/default/keyboard

sudo apt-get -y install fbxkb
echo 'fbxkb &' >> ~/.config/openbox/autostart

# Hope that helps.

Offline

#7 2013-11-16 13:53:52

ferenc
#! Member
Registered: 2012-11-20
Posts: 69

Re: Language & Keyboard layout

hi guys,

I need some help. I installed a new #! with slovenian language and keyb.

Hate it. Iceweasel is English, Geany is slovenian... sucks...

I would like to have the English system (menus are now is Slovenian, some programs in English) - but I want to keep the keyboard in Slovenian.

So - i need to change the system language to English, but to keep the keyboard and other settings (like how to handle time and currencies) Slovenian.

How do I do that? I need some step-by-step guides...

thnx,

b

Offline

#8 2013-11-16 15:59:10

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: Language & Keyboard layout

@ ferenc

Set system Language:

sudo dpkg-reconfigure locales

only select what you want.

Set system keyboard:

sudo dpkg-reconfigure keyboard-configuration

Last edited by Sector11 (2013-11-16 16:00:00)


·  ↓   ↓   ↓   ↓   ↓   ↓  ·
BunsenLabs Forums now Open for Registration
·  ↑   ↑   ↑   ↑   ↑   ↑  · BL ModSquad

Offline

#9 2013-11-21 21:58:35

saprabolt
Member
Registered: 2013-04-19
Posts: 16

Re: Language & Keyboard layout

will try. will hopefully not mess up.

Thnx,

blaž

Offline

#10 2013-12-02 10:57:06

ferenc
#! Member
Registered: 2012-11-20
Posts: 69

Re: Language & Keyboard layout

omfg... so easy.

Thnx so much!!!

blaž

Offline

#11 2014-05-11 11:30:01

saljut7
#! CrunchBanger
Registered: 2013-10-31
Posts: 101

Re: Language & Keyboard layout

Sector11 wrote:

@ ferenc

Set system Language:

sudo dpkg-reconfigure locales

only select what you want.

Set system keyboard:

sudo dpkg-reconfigure keyboard-configuration

Hey crunchbangers,

want to use a german keyboard with an english #!. I thought I chose the right layout while installing but unfortunately the kayboard layout is english as well. I tried both commands above, restarted, nothing changed.

Something else I can try to use a keyboard with german layout?

Thank you in advance!
sj7

Offline

#12 2014-05-19 22:41:34

saljut7
#! CrunchBanger
Registered: 2013-10-31
Posts: 101

Re: Language & Keyboard layout

saljut7 wrote:
sudo dpkg-reconfigure keyboard-configuration

want to use a german keyboard with an english #!. I thought I chose the right layout while installing but unfortunately the keyboard layout is english as well. I tried both commands above, restarted, nothing changed.

Have to quote myself. I tried to find the reason for my problem and found a strange bug:

I control two PCs (installed #! in english on both) with one keyboard (german layout) using Synergy. Both systems have installed Solaar to support a Logitech-unify-adapter.

I recognized that the layout changed to english after I put the unify-adapter from one PC to the other.

With dpkg-reconfigure I checked the right keyboard-setting on both machines. The Synergy-Master got it's german keyboard-layout back. The Synergy-Slave recognizes a german keyboard as well - as long as I don't use Synergy (using the keyboard directly connected there).

Switching from Master to Slave with Synergy the keyboard on the Slave-side becomes english. Is this a Synergy-bug or is there something I can modify in cb-settings?

Last edited by saljut7 (2014-05-19 22:42:39)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo