SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2012-12-19 19:34:06

Digit
#! Die Hard
From: the internet
Registered: 2009-05-26
Posts: 1,083
Website

[SOLVED] cant upgrade|install|remove; procps & live-tools use uptimed.

###UPDATE### SOLVED.  ~ Careful what you apt-pin ~ removed the offending portions from apt's preferences, and all's well again.


i've had this problem in sid for a while now.  life's been so hectic i've not found the time to sit down and get it sorted... or rather, what vast amount of time i have spent on it, has been insufficient.   definately time to ask.


E: /var/cache/apt/archives/procps_1%3a3.3.4-2_amd64.deb: trying to overwrite '/usr/bin/uptime', which is also in package live-tools 3.0.8-1

^ so there's the gist of the problem.

procps wont update, because uptimed's also in live-tools.  i've tried removing live-tools, but apt always insists, it neeeeeeds procps to be upgraded first.  this is blocking me from installing, or uninstalling, anything.

is there some simple "one-shot" or "force" type deal to get around this?

should i try pinning my way out of it?  (considered, but doubt it would make a difference).

any suggestions to point me in the right direction, greatly appreciated.  smile



~ ADDITIONAL INFO ~

adding -f seems insufficient.

$ sudo apt-get -f install procps                                                 
[sudo] password for root:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be upgraded:
  procps
1 upgraded, 0 newly installed, 0 to remove and 480 not upgraded.
3 not fully installed or removed.
Need to get 259 kB of archives.
After this operation, 9,216 B of additional disk space will be used.
Get:1 http://ftp.de.debian.org/debian/ sid/main procps amd64 1:3.3.4-2 [259 kB]
Fetched 259 kB in 14s (17.4 kB/s)                                                                                 
(Reading database ... 292904 files and directories currently installed.)
Preparing to replace procps 1:3.3.3-2 (using .../procps_1%3a3.3.4-2_amd64.deb) ...
Unpacking replacement procps ...
dpkg: error processing /var/cache/apt/archives/procps_1%3a3.3.4-2_amd64.deb (--unpack):
trying to overwrite '/usr/bin/uptime', which is also in package live-tools 3.0.8-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
dpkg: error while cleaning up:
subprocess new post-removal script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/procps_1%3a3.3.4-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Last edited by Digit (2013-01-17 04:04:55)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo