SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2009-08-24 21:58:56

Zwopper
The GIMP Pimp
From: Deep in The Swedish Woods
Registered: 2008-11-28
Posts: 580
Website

How to make the touchpad turn off automatically when typing

syndaemon -d

Offline

Help fund CrunchBang, donate to the project!

#2 2009-08-24 22:34:37

Awebb
The Singularity
Registered: 2009-07-23
Posts: 2,812

Re: How to make the touchpad turn off automatically when typing

<merge key="input.x11_options.PalmDetect" type="string">1</merge>

Last edited by Awebb (2009-08-24 22:38:21)


I'm so meta, even this acronym

Offline

#3 2009-08-24 22:49:18

Zwopper
The GIMP Pimp
From: Deep in The Swedish Woods
Registered: 2008-11-28
Posts: 580
Website

Re: How to make the touchpad turn off automatically when typing

Well true... roll
I merely added

syndaemon -d &

to autostart.sh and it works fine... big_smile
I'm just glad I found it... big_smile

Last edited by Zwopper (2009-08-24 22:50:46)

Offline

#4 2009-08-25 06:18:18

iggykoopa
Script Master
Registered: 2008-12-13
Posts: 1,486

Re: How to make the touchpad turn off automatically when typing

I believe in the newer releases of ubuntu those xorg settings are ignored and you have to set it with hal. I usually go the syndeamon route as well, just haven't set it up again yet. Thanks for the reminder Zwopper wink


I say never be complete, I say stop being perfect, I say lets evolve, let the chips fall where they may.

Offline

#5 2009-08-25 06:59:33

omns
#! wanderer
From: ~/
Registered: 2008-11-25
Posts: 5,131

Re: How to make the touchpad turn off automatically when typing

I'm not having any luck with this. syndaemon generates the following errors. Time to check out some of the launchpad bugs in relation to this.

X Error of failed request:  BadDevice, invalid or uninitialized input device
  Major opcode of failed request:  141 (XInputExtension)
  Minor opcode of failed request:  3 (X_OpenDevice)
  Serial number of failed request:  12
  Current serial number in output stream:  12

Offline

#6 2009-08-25 07:03:21

omns
#! wanderer
From: ~/
Registered: 2008-11-25
Posts: 5,131

Re: How to make the touchpad turn off automatically when typing

I need to use something like

syndaemon -i 0.5 -S -d

to get things working.

Appears to be ok at this stage but will keep investigating.

Offline

#7 2009-08-25 12:08:34

zeltak
Member
Registered: 2009-08-10
Posts: 23

Re: How to make the touchpad turn off automatically when typing

Hi

i tried your method  in addition to every possible way google search threw at me (enabling it through xorg, the new jaunty way through the hsl/policy/fdi way etc..) but nothing works.

I keep getting the following error:

"Cant access shared memory area. SHMConfig disabled?"

Even though i did do the hal xml thing

any ideas?

btw runing it on msi wind u-100 and crunch bang 9.04

thx in advance

Zeltak

Offline

#8 2012-09-14 00:52:10

No-Thing
Member
From: Denmark
Registered: 2012-09-11
Posts: 43

Re: How to make the touchpad turn off automatically when typing

It worked! smile
Just running:

syndaemon -d &

And il see if it suits me or if it needs any more tuning of the syndaemon.
Very very very neat - I was getting so anoyed about my touchpad!

Another problem bites the dust! *He he he*

Thx - I love you.

With love and gratitude -
No-Thing But Divine

Last edited by No-Thing (2012-09-14 00:54:48)


With love and gratitude - No-Thing But Divine
I am an orphan, alone; nevertheless I am found everywhere. I am one, but opposed to myself. I am youth and an old man at one and the same time. In woods and mountains I roam, but I am hidden in the innermost soul of man. I am mortal for everyone, yet I am not touched by the cycle of the aeons.

Offline

#9 2014-03-06 00:29:58

marmotBreath
Member
Registered: 2014-02-27
Posts: 15

Re: How to make the touchpad turn off automatically when typing

So yes, this is a pretty old thread, but the touchpad on my Lenovo S10-3 was driving me completely insane, and this solution solved it quite simply. I did not need to use the XML and the

syndaemon -d &

and the addition of the shmconfig.fdi file was all it took to start working. Awesome!

I post this because the instructions suggest that there is already an /etc/hal tree. On my Waldorf/Sid build there was no such directory. This makes me wonder if hal has been replaced with something else we should be using for this kind of thing?

Last edited by marmotBreath (2014-03-06 00:30:57)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: bleh

Debian Logo