SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-09-22 10:31:14

drum
#! Member
From: /home/drum
Registered: 2011-04-23
Posts: 74

[solved]unable to install mintstick on bunsenlabs

[Moved from Ideas & Suggestions]

when i do this in a terminal

$ sudo sh -c 'echo "deb http://packages.linuxmint.com/ qiana main" >> /etc/apt/sources.list.d/mint.list'
$ sudo apt-get update
$ sudo apt-get install linuxmint-keyring
$ sudo apt-get install mintstick

i get this:

Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd       
De statusinformatie wordt gelezen... Klaar
Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen
dat u om een onmogelijke situatie gevraagd heeft, of, indien u
de distributie 'unstable' gebruikt, dat sommige benodigde pakketten nog gemaakt moeten worden of uit 'Incoming' verwijderd werden.
De volgende informatie kan misschien helpen de situatie op te lossen:

De volgende pakketten hebben niet-voldane vereisten:
 mintstick : Vereisten: gir1.2-polkit-1.0 maar het is niet installeerbaar
             Vereisten: python-parted maar het is niet installeerbaar
             Vereisten: udisks maar het is niet installeerbaar
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast.

someone can solve this? I really love this little program but it want install

Last edited by damo (2015-09-22 15:58:36)

Offline

Be excellent to each other!

#2 2015-09-22 11:05:26

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: [solved]unable to install mintstick on bunsenlabs

Before you try and use packages from a different distribution, please read this:
DontBreakDebian


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#3 2015-09-22 11:13:23

drum
#! Member
From: /home/drum
Registered: 2011-04-23
Posts: 74

Re: [solved]unable to install mintstick on bunsenlabs

let me say it otherwise, is there a gui-tool like mintstick for bunsen?

Offline

#4 2015-09-22 11:47:12

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: [solved]unable to install mintstick on bunsenlabs

drum wrote:

let me say it otherwise, is there a gui-tool like mintstick for bunsen?

BunsenLabs only uses Debian Stable packages (plus a few BL backports if required).

It seems that mintstick is a gui frontend for dd, which you can use from the commandline quite easily for writing images/isos to usb.

There is a package called gnome-multi-writer which may do what you want (but most people don't want gnome apps when dd does the job wink )

If you insist on a gui, then for safety, you could try making your own backport of mintstick: SimpleBackportCreation


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#5 2015-09-22 12:34:36

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: [solved]unable to install mintstick on bunsenlabs

this builds https://github.com/linuxmint/mintstick on jessie, but its not a gui tool (or I have missed something).

Last edited by brontosaurusrex (2015-09-22 12:58:56)

Offline

#6 2015-09-22 13:06:35

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: [solved]unable to install mintstick on bunsenlabs

brontosaurusrex wrote:

this builds https://github.com/linuxmint/mintstick on jessie, but its not a gui tool (or I have missed something).

If you look in install.sh, it refers to ui and .desktop files.


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#7 2015-09-22 13:06:46

twoion
Emerald Caffeine
From: 星界
Registered: 2012-05-11
Posts: 1,648

Re: [solved]unable to install mintstick on bunsenlabs

@drum, I felt free to build the package for Debian Jessie: mintstick_1.2.5_all.deb. Download and install with dpkg -i $package. If it complains that there are missing dependencies, install all of those dependencies via apt-get first.

Note that there is no warranty smile


Tannhäuser ~ {www,pkg,ddl}.bunsenlabs.org/{gitlog,repoidx}

Offline

#8 2015-09-22 13:13:40

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: [solved]unable to install mintstick on bunsenlabs

damo wrote:
brontosaurusrex wrote:

this builds https://github.com/linuxmint/mintstick on jessie, but its not a gui tool (or I have missed something).

If you look in install.sh, it refers to ui and .desktop files.

Only took 30s for compiling/testing, but it seems cli ready as well

Usage: mintstick [--debug] -m [format|iso]              : mode (format usb stick or burn iso image)
       mintstick [--debug] -m iso [-i|--iso] iso_path
       mintstick [--debug] -m format [-u|--usb] usb_device 
                           [-f|--filesystem] filesystem

Offline

#9 2015-09-22 13:47:54

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: [solved]unable to install mintstick on bunsenlabs

brontosaurusrex wrote:

....
Only took 30s for compiling/testing, but it seems cli ready as well

Have you tried it? How does it compare to plain old dd?


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#10 2015-09-22 14:06:29

drum
#! Member
From: /home/drum
Registered: 2011-04-23
Posts: 74

Re: [solved]unable to install mintstick on bunsenlabs

@Emerald Caffeine, tnx for building the package.
when i try to install (missing dependencies)it gives me

sudo apt-get install gir1.2-polkit-1.0

there is no such package, i looked in synaptic and could find it neither there.
When i reload synaptic it says that i gave 1889 packages in the list, is that normal?
As packagesources i have: deb http://pkg.bunsenlabs.org/debian/
                                        deb http://security.debian.org/
                                        deb-src http://security.debian.org/

Offline

#11 2015-09-22 14:07:29

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: [solved]unable to install mintstick on bunsenlabs

damo wrote:
brontosaurusrex wrote:

....
Only took 30s for compiling/testing, but it seems cli ready as well

Have you tried it? How does it compare to plain old dd?

Of course not, why would I test mint tools? tongue (dd roxors)
p.s. still trying to find time to test new blender (opensubd section mostly).

Last edited by brontosaurusrex (2015-09-22 14:10:15)

Offline

#12 2015-09-22 14:30:41

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: [solved]unable to install mintstick on bunsenlabs

drum wrote:

@Emerald Caffeine, tnx for building the package.

You mean @twoion tongue

when i try to install (missing dependencies)it gives me

sudo apt-get install gir1.2-polkit-1.0

there is no such package, i looked in synaptic and could find it neither there.
When i reload synaptic it says that i gave 1889 packages in the list, is that normal?
As packagesources i have: deb http://pkg.bunsenlabs.org/debian/
                                        deb http://security.debian.org/
                                        deb-src http://security.debian.org/

Well, the package exists in Debian Stable:

$ apt-cache policy gir1.2-polkit-1.0
gir1.2-polkit-1.0:
  Installed: (none)
  Candidate: 0.105-8
  Version table:
     0.105-8 0
        500 http://ftp.uk.debian.org/debian/ jessie/main amd64 Packages

You don't seem to have jessie main sources in your sources.list. Did you choose not to enable a network mirror during the installation?


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#13 2015-09-22 14:57:42

drum
#! Member
From: /home/drum
Registered: 2011-04-23
Posts: 74

Re: [solved]unable to install mintstick on bunsenlabs

@damo, indeed i did not choose  to enable a network mirror during the installation
it was a install on a mini-dell inspiron, when the installer was running i had no internet connection.
So what i'm missing right now?

Offline

#14 2015-09-22 15:11:13

drum
#! Member
From: /home/drum
Registered: 2011-04-23
Posts: 74

Re: [solved]unable to install mintstick on bunsenlabs

I have added:
deb http://ftp.be.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.be.debian.org/debian/ jessie main contrib non-free
to my sourcelist and now i have 43018 packages in synaptic instead of 1889 before
Installation of mintstick is done, so problem solved.

Last edited by drum (2015-09-22 15:16:12)

Offline

#15 2015-09-22 15:27:28

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: [solved]unable to install mintstick on bunsenlabs

Let us see your sources.list.

The package list is everything that is available to install.


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#16 2015-09-22 16:08:24

drum
#! Member
From: /home/drum
Registered: 2011-04-23
Posts: 74

Re: [solved]unable to install mintstick on bunsenlabs

here it is:

deb http://ftp.be.debian.org/debian/ jessie main contrib non-free 
deb-src http://ftp.be.debian.org/debian/ jessie main contrib non-free 

deb http://security.debian.org/ jessie/updates main contrib non-free 
deb-src http://security.debian.org/ jessie/updates non-free contrib main 
# deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot i386 LIVE/INSTALL Binary 20150908-13:17]/ jessie contrib main non-free  

# deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot i386 LIVE/INSTALL Binary 20150908-13:17]/ jessie contrib main non-free  

Offline

#17 2015-09-22 16:24:28

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: [solved]unable to install mintstick on bunsenlabs

Unless you intend to do packaging or development work, there is no need to use the deb-src lines. You may as well comment them out again.
Debian SourcesList


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo