SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-09-16 18:17:13

phle
Member
From: Sweden
Registered: 2015-02-17
Posts: 21

[SOLVED] GRUB problems with BunsenLabs (rc1) on UEFI system

Since Friday 11/9 (that's 11th September for those of you who usually swap them wink ), I'm running BunsenLabs as my main OS.

It could have been a quick install, buuut then I began tweaking it ... tongue
I think I'm set now, though. smile


One oddity, though:
Installing it on my 32-bit machine (where it presently resides as the sole installed OS) was painless.
Installing it on my 64-bit UEFI-enriched machine (which also has Windows 8.1 installed (albeit seldom logged in to)) was ... trickier.
It somehow failed to give me GRUB.
Re-installed, but did some extra fiddling (re-ran the "Install GRUB"-part, which actually gave me a bit more of the Installing GRUB-dialogues (instead of basically skipping it)). Same thing.
So I just installed "regular" Debian 8.2 (LXDE, but "no desktop" would probably have been enough) on a smaller partition, which gave me a working GRUB, with Debian, Windows and BunsenLabs in the startup menu.
SomeDay™ I'll fix it (I've found snippets of how-to:s). It works for now - I just have to remember to select BunsenLabs during startup.

This far, I like it. big_smile

My "meanwhile"-Debian 8.1 LXDE, modified worked fine, but I assume there were quite a bit of stuff added that I never really needed. I did learn a bunch, when tweaking the LXDE Openbox, so I wouldn't say the wait was wasted.
When BL is out of the Release Candidate-stage, I guess I'll re-install it, and hopefully I've read up on how to fix GRUB by then.


edit: see comment below for work-around solution

Last edited by phle (2015-09-18 16:46:47)


2015-09-30: officially moved over to the BunsenLabs Forums.

Offline

Help fund CrunchBang, donate to the project!

#2 2015-09-16 18:34:10

tknomanzr
#! Die Hard
From: Heavener, OK
Registered: 2014-12-09
Posts: 777

Re: [SOLVED] GRUB problems with BunsenLabs (rc1) on UEFI system

In order to get efi support with Bunsen Labs, use the netinstall on top of Debian Jessie Method. Live Build does not yet include support for EFI partitions and grub64efi, so the Live ISO's have to still use the old bios support.

Offline

#3 2015-09-16 18:36:43

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: [SOLVED] GRUB problems with BunsenLabs (rc1) on UEFI system

phle wrote:

I just have to remember to select BunsenLabs during startup.

Well that's one way ...
When you select Bunsen and are in, open a terminal pick an alias:

##################################################################### GRUB ###
alias gri='echo "alias gri = sudo grub-install /dev/sda" ; sudo grub-install /dev/sda'
alias gru='echo "alias gru = sudo update-grub" ; sudo update-grub'
alias griu='echo "alias griu = sudo grub-install /dev/sda ; sudo update-grub" ; sudo grub-install /dev/sda ; sudo update-grub'

Since grub is already installed you shouldn't need to reinstall it... a "gru" should be enough to put BunsenLabs at the top of the list.

 16 Sep 15 | 15:34:22 ~
    $ gru
alias gru = sudo update-grub
[sudo] password for sector11: 
Generating grub configuration file ...
Found background image: /usr/share/images/desktop-base/desktop-grub.png
Found linux image: /boot/vmlinuz-3.16.0-4-amd64
Found initrd image: /boot/initrd.img-3.16.0-4-amd64
Found Debian GNU/Linux (7.8) on /dev/sda1
Found BunsenLabs GNU/Linux 8.1 (Hydrogen) (8.1) on /dev/sda10
Found BunsenLabs GNU/Linux 8.1 (Hydrogen) (8.1) on /dev/sda12
Found Debian GNU/Linux (8.1) on /dev/sda6
done
 
 16 Sep 15 | 15:35:09 ~
    $ 

·  ↓   ↓   ↓   ↓   ↓   ↓  ·
BunsenLabs Forums now Open for Registration
·  ↑   ↑   ↑   ↑   ↑   ↑  · BL ModSquad

Offline

#4 2015-09-16 19:05:32

phle
Member
From: Sweden
Registered: 2015-02-17
Posts: 21

Re: [SOLVED] GRUB problems with BunsenLabs (rc1) on UEFI system

tknomanzr wrote:

In order to get efi support with Bunsen Labs, use the netinstall on top of Debian Jessie Method. Live Build does not yet include support for EFI partitions and grub64efi, so the Live ISO's have to still use the old bios support.

Ah ...
Despite several tries, I never managed to get online after having done the bare netinstall (during the Wally-rounds; I have WiFi only, no Ethernet), so I guess I'll make do with the present solution (i.e., to later on find out how to rearrange the stuff in GRUB, to give me BunsenLabs as the first option), then.

Thanks for the heads-up, though!


Sector11 wrote:
phle wrote:

I just have to remember to select BunsenLabs during startup.

Well that's one way ...
When you select Bunsen and are in, open a terminal pick an alias:

/.../

I assume it doesn't have to be an alias ... ?
I actually did

$ sudo update-grub

rather early on (just double-checked my ~/.bash_history ), but it obviously didn't "catch'em all" ...

Just re-did it, "just in case":
[uhm, I'm not at home, and I have no external mouse, so I can't really "middle-click" to paste my marked-in-terminal
basically, I never get the expected

Found BunsenLabs GNU/Linux 8.1 (Hydrogen) (8.1) on /dev/sda5
Found BunsenLabs GNU/Linux 8.1 (Hydrogen) (8.1) on /dev/sda8

lines]


2015-09-30: officially moved over to the BunsenLabs Forums.

Offline

#5 2015-09-16 19:49:46

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: [SOLVED] GRUB problems with BunsenLabs (rc1) on UEFI system

No you don't need aliases ... I don't type so well and typos are a pita!

$ sudo update-grub

is just fine.

Looks like you have two BL  installs sda5 and sda8

OK, why not try went in the BL you want as the default boot system:

sudo grub-install /dev/sda ; sudo update-grub

IF /dev/sda is where you want grub


·  ↓   ↓   ↓   ↓   ↓   ↓  ·
BunsenLabs Forums now Open for Registration
·  ↑   ↑   ↑   ↑   ↑   ↑  · BL ModSquad

Offline

#6 2015-09-17 12:26:25

phle
Member
From: Sweden
Registered: 2015-02-17
Posts: 21

Re: [SOLVED] GRUB problems with BunsenLabs (rc1) on UEFI system

Sector11 wrote:

IF /dev/sda is where you want grub

Hm. Isn't GRUB already on /dev/sda (with the Debian install)?

Oh, and I'm at home right now, so I can actually paste now:

pcl@rosita:~$ sudo update-grub
[sudo] password for pcl: 
Generating grub configuration file ...
Found background: /usr/share/backgrounds/bunsen/bunsen-images/bl-default/bl-grub.png
Found background image: /usr/share/backgrounds/bunsen/bunsen-images/bl-default/bl-grub.png
Found linux image: /boot/vmlinuz-3.16.0-4-amd64
Found initrd image: /boot/initrd.img-3.16.0-4-amd64
Found Windows Boot Manager on /dev/sda1@/efi/Microsoft/Boot/bootmgfw.efi
Found Debian GNU/Linux (8.2) on /dev/sda9
done
pcl@rosita:~$ 

(I fiddled in the GRUB files at some point, which is why it lists bl-grub.png (no idea why it does so twice, though). In reality, GRUB is Debian blue on startup.)

These are the actual partitions: (yes, I have a bad memory for this, so I write this down; yeah, I guess I don't really need swap partitions, but they're there out of old habit)

                    1.0 MB        FREE SPACE                                
     #1           104.9 MB  B  K  fat32       EFI system partition          ← leave this be
     #2           943.7 MB        ntfs        Basic data partition          ← for Windows 8.1
     #3           134.2 MB                    Microsoft reserved partition  ← for Windows 8.1
     #4           200.0 GB        ntfs        Basic data partition          ← Microsoft Windows 8.1: C:\
     #5            15.0 GB        ext4                      /               ← BunsenLabs Linux 8.1 (Hydrogen) RC1  /installed 2015-09-11²
     #6             7.4 GB        swap                      swap            ← Linux swap
     #8           205.0 GB        ext4                      /home           ← BunsenLabs Linux 8.1 (Hydrogen) RC1
     #9            10.0 GB     F  ext4                      /               ← Debian GNU/Linux 8.2 "Jessie"        /installed 2015-09-11³
     #10            4.0 GB     F  swap                      swap            ← Linux swap
     #11           36.0 GB     F  ext4                      /home           ← Debian GNU/Linux 8.2 "Jessie"
     #7            21.5 GB        ntfs        Basic data partition          ← for Windows 8.1
                    7.7 kB        FREE SPACE                                

... sooo, it seems as if it actually can't find BunsenLabs.  neutral

(If I go into this matter further, I guess I ought to start a separate thread for it ... )


2015-09-30: officially moved over to the BunsenLabs Forums.

Offline

#7 2015-09-18 07:05:43

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: [SOLVED] GRUB problems with BunsenLabs (rc1) on UEFI system

phle wrote:

start a separate thread for it

Good idea, done!

Attempting to install & update the non-UEFI version of GRUB in your UEFI system will *not* change the boot process unless UEFI is disabled in the firmware ("BIOS") menus by enabling "CSM" or "Legacy" mode.

The default order in the other Debian system can be changed.

Boot into the other system and edit /etc/default/grub (as root!) then modify the "GRUB_DEFAULT" line (entries are counted from zero), save the file & run `update-grub` to reconfigure the system.

Whenever BunsenLabs gets a kernel update, be sure to boot up the other Debian system & run `update-grub` again.

Offline

#8 2015-09-18 15:44:32

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: [SOLVED] GRUB problems with BunsenLabs (rc1) on UEFI system

phle wrote:
Sector11 wrote:

IF /dev/sda is where you want grub

Hm. Isn't GRUB already on /dev/sda (with the Debian install)?

If you only have one drive yes, if you have multiple drives it could be anywhere.


·  ↓   ↓   ↓   ↓   ↓   ↓  ·
BunsenLabs Forums now Open for Registration
·  ↑   ↑   ↑   ↑   ↑   ↑  · BL ModSquad

Offline

#9 2015-09-18 16:43:35

phle
Member
From: Sweden
Registered: 2015-02-17
Posts: 21

Re: [SOLVED] GRUB problems with BunsenLabs (rc1) on UEFI system

Head_on_a_Stick wrote:

Attempting to install & update the non-UEFI version of GRUB in your UEFI system will *not* change the boot process unless UEFI is disabled in the firmware ("BIOS") menus by enabling "CSM" or "Legacy" mode.

The default order in the other Debian system can be changed.

/.../

Thanks!

Hard-drive space isn't presently an issue, so I consider this a good-as-any workaround for this issue.
If I re-install BunsenLabs together with the Debian "help installation", I'm probably just going to install Debian on one single partition (I guess 10 GB should be well enough for it), and probably sans desktop environment (as all of the above is do-able from the command line, as well as not requiring a working internet connection).


For anyone else wondering:

1. Boot up. When you get to the startup-menu (the GRUB-menu), check what line the option you want as default is on (start counting from 0), then let it boot into the default alternative.
This is what my GRUB first looked like:

*Debian GNU/Linux
 Advanced options for Debian GNU/Linux
 Windows Boot Manager (on /dev/sda1)
 BunsenLabs GNU/Linux 8.1 (Hydrogen) (8.1) (on /dev/sda5)
 Advanced options for BunsenLabs GNU/Linux 8.1 (Hydrogen) (8.1) (on /dev/sda5)

So: I want the present GRUB_DEFAULT=0 changed to GRUB_DEFAULT=3.

2. Log in. Open a terminal, then

$ sudo nano /etc/default/grub

Find the GRUB_DEFAULT=0 line, and change it to GRUB_DEFAULT=3
then [Ctrl]+[x] to exit the nano editor - it asks you whether you want to save the file: answer [y] on that, and then [Enter] to verify that you want to save to the suggested filenamn.
Now you're back at the prompt.

3. Update GRUB

$ sudo update-grub

(watch it update GRUB)

4. Reboot.
The GRUB menu is still Debian blue, and in the same order, but: BunsenLabs is now set as the default!

 Debian GNU/Linux
 Advanced options for Debian GNU/Linux
 Windows Boot Manager (on /dev/sda1)
*BunsenLabs GNU/Linux 8.1 (Hydrogen) (8.1) (on /dev/sda5)
 Advanced options for BunsenLabs GNU/Linux 8.1 (Hydrogen) (8.1) (on /dev/sda5)

big_smile

Don't forget the last part of the advice, though:

Head_on_a_Stick wrote:

Whenever BunsenLabs gets a kernel update, be sure to boot up the other Debian system & run `update-grub` again.


2015-09-30: officially moved over to the BunsenLabs Forums.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo