SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-09-17 19:17:00

photonucleon
Quantum Geek
From: Hogwarts
Registered: 2013-06-10
Posts: 952

[solved (hopefully)] VLC won't display video, only plays audio

Running BunsenLabs RC1, VLC is only playing the audio of video files, the video just appears black. This is not quite the same as when it is playing actual audio files and the orange cone logo is visible in the centre of the window - when playing videos it is just plain black. Bizarrely, VLC played some videos fine earlier today - without any settings changing, as far as I am aware - and then went back to showing just black. The only clue I have is this file that VLC dropped into the folder that I was trying to play a video from:

-- logger module started --
core error: Could not convert timestamp 9732362666
-- logger module stopped --

I googled that, but nothing came up. I googled just "core error vlc" and found this, but none of the solutions suggested there seem to help - I tried changing the "hardware accelerated decoding" option to other values, but the problem persists.

Any ideas? smile

EDIT: Running VLC from a terminal produced this output:

$ vlc Movie.m4v 
VLC media player 2.2.0-rc2 Weatherwax (revision 2.2.0-rc1-118-g22fda39)
[0000000001c75118] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory

EDIT 2: videos don't play in gnome-mplayer either, just the audio. Aaaaaaand it's a known bug: https://bugs.debian.org/cgi-bin/bugrepo … bug=617940

Last edited by photonucleon (2015-09-18 17:21:22)


- Ai! Aníron Undómiel. -
- Some things are certain. -
- Et Eärello Endorenna utúlien. Sinome maruvan ar Hildinyar tenn' Ambar-metta. -

Offline

Be excellent to each other!

#2 2015-09-17 19:28:27

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: [solved (hopefully)] VLC won't display video, only plays audio

try some other player?

mpv file.mp4
mpv -vo x11 file.mp4

Last edited by brontosaurusrex (2015-09-17 19:31:59)

Offline

#3 2015-09-17 20:18:37

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: [solved (hopefully)] VLC won't display video, only plays audio

so this isn't the same machine as the graphical tearing problem? because nvidia.

anyhow, it's an .m4v video?
do all .m4v (some apple format iirc) behave thusly? or only 1 particular video? or other formats. too? on all media players?

many questions.

vlc also has a nice messages window, crank up the verbosity just 1 notch (from fatal to warning, i think, otherwise you'll get flooded with messages) and see what you get.

ps:
bug report is 4.5 ys old. sure it's still relevant?

Last edited by ohnonot (2015-09-17 20:20:39)

Offline

#4 2015-09-17 20:56:16

photonucleon
Quantum Geek
From: Hogwarts
Registered: 2013-06-10
Posts: 952

Re: [solved (hopefully)] VLC won't display video, only plays audio

This *is* the same machine as the graphical tearing, I don't have an nvidia card though, so no idea why that is showing up.

Also, trial and error has shown that videos will play fine just after booting up. About 3-5 minutes after booting up, any videos that are opened just play the audio over a black screen. This happens in both vlc and gnome-mplayer, and across all the video formats that I have (including m4v, mp4, mov). M4V files are mp4/AAC files iirc. I'll have a look at the messages window when I get back to my laptop.

Thanks for your help so far, guys smile


- Ai! Aníron Undómiel. -
- Some things are certain. -
- Et Eärello Endorenna utúlien. Sinome maruvan ar Hildinyar tenn' Ambar-metta. -

Offline

#5 2015-09-17 21:06:22

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: [solved (hopefully)] VLC won't display video, only plays audio

^ Something eating memory? Card overheating?


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#6 2015-09-17 21:45:54

photonucleon
Quantum Geek
From: Hogwarts
Registered: 2013-06-10
Posts: 952

Re: [solved (hopefully)] VLC won't display video, only plays audio

damo wrote:

^ Something eating memory? Card overheating?

I don't think so, but I'll double check that (I'm not with my laptop right now). The fact that it complains about a timestamp makes me wonder if there's some kind of timing thing in the system that gradually gets out of sync somehow...?

hmm


- Ai! Aníron Undómiel. -
- Some things are certain. -
- Et Eärello Endorenna utúlien. Sinome maruvan ar Hildinyar tenn' Ambar-metta. -

Offline

#7 2015-09-18 01:48:23

photonucleon
Quantum Geek
From: Hogwarts
Registered: 2013-06-10
Posts: 952

Re: [solved (hopefully)] VLC won't display video, only plays audio

OK, there doesn't seem to be any problems with the amount of memory, and nothing seems to be overheating.

Nothing appears in the VLC messages window until I crank the verbosity all the way up, at which point I get flooded with:

xcb_xv debug: cannot put image: X11 error 11

I shall come back to this thread when it's not nearly 3 in the morning wink


- Ai! Aníron Undómiel. -
- Some things are certain. -
- Et Eärello Endorenna utúlien. Sinome maruvan ar Hildinyar tenn' Ambar-metta. -

Offline

#8 2015-09-18 06:48:53

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: [solved (hopefully)] VLC won't display video, only plays audio

try telling vlc (or in fact any media player) which video driver to use. there's dozens and always more than 1 should work.
obviously vdpau can't be the right one.
usually you have to restart the app for that to take effect.

Offline

#9 2015-09-18 11:18:49

photonucleon
Quantum Geek
From: Hogwarts
Registered: 2013-06-10
Posts: 952

Re: [solved (hopefully)] VLC won't display video, only plays audio

ohnonot wrote:

try telling vlc (or in fact any media player) which video driver to use. there's dozens and always more than 1 should work.
obviously vdpau can't be the right one.
usually you have to restart the app for that to take effect.

It's really hard to tell what works, as even the default setting works immediately after boot. Then, after an amount of time (which varies wildly) it stops showing video. It's a very strange and random error.

Could it possibly be something to do with battery charge? (I'll see if I can work that out, but is it possible in theory?)


- Ai! Aníron Undómiel. -
- Some things are certain. -
- Et Eärello Endorenna utúlien. Sinome maruvan ar Hildinyar tenn' Ambar-metta. -

Offline

#10 2015-09-18 15:43:59

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: [solved (hopefully)] VLC won't display video, only plays audio

photonucleon wrote:

even the default setting works immediately after boot. Then, after an amount of time (which varies wildly) it stops showing video. It's a very strange and random error.

you know what the usual reply to these sort of errors is, right?
maybe you should take it into account. how old is the machine, can you find reports about hardware fatigue, is it possible to run some tests (akin to memtest86+ or whatever the name is) on the gpu.

another idea: try media playback on a distro that is very different from debian, e.g. archlinux (manjaro) or even BSD.

Offline

#11 2015-09-18 17:20:10

photonucleon
Quantum Geek
From: Hogwarts
Registered: 2013-06-10
Posts: 952

Re: [solved (hopefully)] VLC won't display video, only plays audio

OK, so the non-playback of video seems to be sort of related to the battery level - it will play fine when the battery has a high level of charge. Any videos I opened once the battery had got down to 40-30% were just black but then when I changed the output to "X11 video output (XCB)", videos started playing properly again, and seemed to be fine at that point.

Thank you all for your help, guys - I'll mark this solved for now, though I'm still not 100% sure what is happening... I'll look into testing the GPU...

big_smile


- Ai! Aníron Undómiel. -
- Some things are certain. -
- Et Eärello Endorenna utúlien. Sinome maruvan ar Hildinyar tenn' Ambar-metta. -

Offline

#12 2015-09-19 06:57:55

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: [solved (hopefully)] VLC won't display video, only plays audio

wow, so it's like a combination of hardware & linux driver problem. weeeeiiiird.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo