SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-08-21 11:58:49

dave13
Member
Registered: 2015-08-19
Posts: 16

[SOLVED] ERR_CONNECTION_REFUSED on Transmission Remote

I'm trying to set up the Remote Transmission app on my android phone.
After filling up the required fields such as username, password, port...
An error message was shown saying that the connection was refused.
I've read somewhere that this can be fixed by the port I specified(9091)
Can somebody teach me how to open the port. I'm new to this.
Thanks in advance

Last edited by dave13 (2015-10-14 23:58:25)

Offline

Help fund CrunchBang, donate to the project!

#2 2015-08-21 12:08:29

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: [SOLVED] ERR_CONNECTION_REFUSED on Transmission Remote

Does this work:

sudo iptables -I INPUT -p tcp --dport 9091 --syn -j ACCEPT

I've deleted your other thread -- in future, please use the "Report" button and ask one of the mod team to move the thread to the correct location wink

Offline

#3 2015-08-21 13:58:46

dave13
Member
Registered: 2015-08-19
Posts: 16

Re: [SOLVED] ERR_CONNECTION_REFUSED on Transmission Remote

On my laptop: nothing happens when I type the code like what I get when I type a correct code

On my phone: I still get the "failed to connect to /112.210.49.74 (port 9091) after 3000ms: isConnected failed: ECONNREFUSED (Connection refused)

Previous thread: Thanks for deleting my other thread. I'll take note of that next time. smile

Offline

#4 2015-08-21 14:54:17

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: [SOLVED] ERR_CONNECTION_REFUSED on Transmission Remote

After running the `iptables` command, what is the output of:

sudo iptables -nvL

I don't really know what this "Remote Transmission" app is, can you explain more please?

Offline

#5 2015-08-21 15:16:47

twoion
Moderator
Registered: 2012-05-11
Posts: 1,648

Re: [SOLVED] ERR_CONNECTION_REFUSED on Transmission Remote

Check the settings.json of transmission-daemon (if this is what you are talking about), check the keys

    "rpc-authentication-required": false,
    "rpc-bind-address": "127.0.0.1", 
    "rpc-enabled": true, 
    "rpc-password": "{93951ea0f45c0aa2cf2a79957d10999e3a4fd6e9MNCvmS41", 
    "rpc-port": 9091, 
    "rpc-url": "/transmission/", 
    "rpc-username": "transmission", 
    "rpc-whitelist": "127.0.0.1", 
    "rpc-whitelist-enabled": true

Bind to 0.0.0.0, make sure RPC is enabled, make sure the whitelist is disabled or your android device's IP address is whitelisted. If you enabled authentication, make sure the password is set correctly.


Tannhäuser ~ {www,pkg,ddl}.bunsenlabs.org/{gitlog,repoidx}

Offline

#6 2015-08-23 06:01:38

ohnonot
...again
Registered: 2012-05-22
Posts: 2,205

Re: [SOLVED] ERR_CONNECTION_REFUSED on Transmission Remote

what sort of internet connection does your laptop (the machine hosting transmission) have?

how are you starting transmission on your laptop?
if you're using transmission GUI (gtk3 most probably), have you enabled the web interface? how exactly?

have you tried connecting to the transmission daemon directly through your phone's browser?

@HoaS: i suspect the android app offers exactly that as a seperate app.

Offline

#7 2015-08-23 11:22:15

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: [SOLVED] ERR_CONNECTION_REFUSED on Transmission Remote

It is worth noting here that the default Debian system leaves all the ports open by default.

Offline

#8 2015-08-25 01:55:30

dave13
Member
Registered: 2015-08-19
Posts: 16

Re: [SOLVED] ERR_CONNECTION_REFUSED on Transmission Remote

Head_on_a_Stick wrote:

After running the `iptables` command, what is the output of:

sudo iptables -nvL

I don't really know what this "Remote Transmission" app is, can you explain more please?

This is the output:

Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target       prot opt in      out      source                              destination

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target       prot opt in      out      source                              destination

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target       prot opt in      out      source                              destination



The Remote Transmission I am talking about is an app on my android phone. It works the same way as the web client, it lets me control my downloads and add new torrents to download.

Offline

#9 2015-08-25 05:27:25

dave13
Member
Registered: 2015-08-19
Posts: 16

Re: [SOLVED] ERR_CONNECTION_REFUSED on Transmission Remote

HOORAY!
I solved it already. After trying diffenrent settings, I found out that the error was the wrong IP address. I used ipchicken.com to check my IP address, then it came to me that maybe it is showing the IP of my router so I tried it on my phone, same IP address given by ipchicken.com. So I googled on how to look for my laptop's IP address and used this:

ip addr show

also, I
changed my settings.json into this:

    "rpc-authentication-required": true,
    "rpc-bind-address": "127.0.0.1", 
    "rpc-enabled": true, 
    "rpc-password": "{93951ea0f45c0aa2cf2a79957d10999e3a4fd6e9MNCvmS41", 
    "rpc-port": 9091, 
    "rpc-url": "/transmission/", 
    "rpc-username": "dave13", 
    "rpc-whitelist": "127.0.0.1", 
    "rpc-whitelist-enabled": false

I had a hard time looking for settings.json, I thought it doesn't exist on mine. I tried various directory addresses I found on google and still no luck, then I ran into a forum saying that it is a hidden file. enabled: "Show Hidden Files" on the View tab on the upper left corner of the File Manager
I used:

sudo find / -iname settings.json

Lesson learned:
Don't trust ipchicken.com to know your IP address. Use this:

ip addr show

if you are looking for a file use this(saves time)

sudo find / -iname "filename"

I tried to be detailed so that when others who are having the same problem can easily solve it. Thanks Head_on_a_Stick and twoion.

Offline

#10 2015-08-25 05:44:17

dave13
Member
Registered: 2015-08-19
Posts: 16

Re: [SOLVED] ERR_CONNECTION_REFUSED on Transmission Remote

ohnonot wrote:

what sort of internet connection does your laptop (the machine hosting transmission) have?

how are you starting transmission on your laptop?
if you're using transmission GUI (gtk3 most probably), have you enabled the web interface? how exactly?

have you tried connecting to the transmission daemon directly through your phone's browser?

@HoaS: i suspect the android app offers exactly that as a seperate app.

I just clicked the Transmission that came with #!
I think this Transmission GUI is gtk
I don't know if this is right, this is how I did it: while on Transmission, click "Edit", then click "Preferences" , go to "Web" tab, then check "Enable web client"
If by web interface you mean opening Transmission from a web browser, after checking "Enable web client", you can go to the browser and type this http://your.device.ip.address:9091 (you can change 9091 if you are using a different port) then you will be askend for a username and password(same as what you typed on the web tab in the Transmission GUI) then you will be able to manage the downloads of your device through the browser.
BUT, if you are far more advanced than me which I assume you are and you are not using the transmission-gtk GUI, you can configure  the settings.json this way:

    "rpc-authentication-required": true,
    "rpc-bind-address": "127.0.0.1", 
    "rpc-enabled": true, 
    "rpc-password": "yourpassword", 
    "rpc-port": 9091, 
    "rpc-url": "/transmission/", 
    "rpc-username": "ohnonot", 
    "rpc-whitelist": "127.0.0.1", 
    "rpc-whitelist-enabled": false

No, I haven't tried it on my phone, but I tried connecting through the browser of another laptop.
You are right I am referring to a separate android app which basically makes a GUI to remotely control your Transmission instead of the usual way of accessing it through a web browser.

Offline

#11 2015-08-25 15:10:48

twoion
Moderator
Registered: 2012-05-11
Posts: 1,648

Re: [SOLVED] ERR_CONNECTION_REFUSED on Transmission Remote

^ You need to change the settings as I did say in the accompanying comment to the snippet. rpc-bind-address must be "0.0.0.0" which means "all networks". "127.0.0.1" is only accessible from the local loopback device meaning NO external device, including your phone app, will be able to reach the address. I suggest something like:

"rpc-authentication-required": true,
    "rpc-bind-address": "0.0.0.0", 
    "rpc-enabled": true, 
    "rpc-password": "bar", 
    "rpc-port": 9091, 
    "rpc-url": "/transmission/", 
    "rpc-username": "foo", 
    "rpc-whitelist-enabled": false

Which should allow you to reach the web client from your phone's browser by typing

http://$your_computers_ip_address:9091

into the URL field. Then enter username and password. On your phone, you'd have to configure the IP, port, username and password in the app you're using.


Tannhäuser ~ {www,pkg,ddl}.bunsenlabs.org/{gitlog,repoidx}

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo