SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-05-27 22:19:03

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

dwm in BunsenLabs

If dwm is installed, there is no .desktop file created in /usr/share/xsessions and so the option to select dwm does not appear in the BunsenLabs display manager (LightDM)

Whilst it is possible to create one and make dwm available as an option [1], this will just launch dwm with no other options possible.

In order to use other startup options with dwm (ie, things that would be added to Openbox's autostart file), simply create a file at ~/.xsession and add the desired commands to that file with "exec dwm" as the last line.

By way of an example, here is mine:

#!/bin/sh
source /etc/X11/Xsession
xset s 300 -dpms
setxkbmap -option caps:none
urxvtd -q -f -o
(conky -q|while read LINE;do xsetroot -name "$LINE";done) & # [2]
feh --bg-center '/usr/share/backgrounds/bunsen/bunsen-images/wallpapers/bl_bgpack_ututo/bl_1920x1080b.png'
exec dwm

If the "Default Xsession" option is then selected in the LightDM desktop chooser (top right, next to the "power off" button), this file will then be parsed (just like Openbox's autostart file).

Behold the glory:
screen_Fetch_2015_05_27_23_09_41.jpg
Direct link

[1] /usr/share/xsessions/dwm.desktop

[Desktop Entry]
Name=DWM
Comment=Dynamic Window Manager
Exec=/usr/local/bin/dwm
Icon=openbox
Type=Application

[2] My .conkyrc for the dwm status bar:

out_to_console yes
out_to_x no
background no
update_interval 1
total_run_times 0
use_spacer none
TEXT
Battery $battery · ${time %A %d %B · %T}

Last edited by Head_on_a_Stick (2015-06-29 07:01:46)

Offline

Help fund CrunchBang, donate to the project!

#2 2015-05-28 06:09:05

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: dwm in BunsenLabs

Short and sweet, a reason for "setxkbmap -option caps:none"?

I have similar (boring) conky
https://raw.githubusercontent.com/bront … conkyrcdwm

Last edited by brontosaurusrex (2015-05-28 07:50:24)

Offline

#3 2015-05-28 07:49:56

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: dwm in BunsenLabs

brontosaurusrex wrote:

a reason for "setxkbmap -option caps:none"?

My laptop doesn't have an LED on the caps-lock key so I can never tell when I flick it on by mistake...

Turning the caps-lock key off entirely solves this problem smile

Offline

#4 2015-05-28 07:51:30

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: dwm in BunsenLabs

Right, looking at some Vim tutorials I see some people are interchanging esc with capslock.

Offline

#5 2015-05-28 07:55:15

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: dwm in BunsenLabs

^ That's not a bad idea actually -- I may try that.

Offline

#6 2015-05-28 09:26:18

twoion
Moderator
Registered: 2012-05-11
Posts: 1,648

Re: dwm in BunsenLabs

Head_on_a_Stick wrote:

^ That's not a bad idea actually -- I may try that.

For example:

setxkbmap -option ctrl:swapcaps de

All done.


Tannhäuser ~ {www,pkg,ddl}.bunsenlabs.org/{gitlog,repoidx}

Offline

#7 2015-05-31 13:42:14

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: dwm in BunsenLabs

For newcomers to dwm, read this rather excellent guide from the Debian forums:
http://forums.debian.net/viewtopic.php?f=16&t=65110

Last edited by Head_on_a_Stick (2015-06-29 07:02:07)

Offline

#8 2015-05-31 21:02:31

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: dwm in BunsenLabs

For those wanting Xft support, download the latest HEAD branch using:

git clone http://git.suckless.org/dwm

Install the necessary dependencies:

sudo apt-get install build-essential xfonts-terminus suckless-tools libxinerama-dev libx11-dev libxft-dev

Then change to the directory and copy the configuration file:

cd dwm
cp config.def.h config.h

The configuration file can then be modified to taste:

vim config.h

The Debian forums guide linked above explains the configuration file in more detail.

You may wish to change the terminal emulator to something else by modifying this line:

static const char *termcmd[]  = { "<name of terminal emulator>", NULL };

Once set up to your liking, compile and install the program:

make && sudo make install

The default keybinds are:

  • <Alt>+t: dmenu (launcher)

  • <Alt>+<Shift>+<Return>: terminal emulator

  • <Alt>+<Shift>+q: kill dwm (ie, log out)

Last edited by Head_on_a_Stick (2015-06-29 07:02:23)

Offline

#9 2015-06-29 21:38:30

hudson
Member
Registered: 2015-06-28
Posts: 16

Re: dwm in BunsenLabs

That's a super nice screenshot smile

Offline

#10 2015-08-14 17:45:29

twodogs
#! CrunchBanger
From: Saint Cloud, Florida
Registered: 2009-06-08
Posts: 129

Re: dwm in BunsenLabs

hudson wrote:

That's a super nice screenshot smile

I concur!


Lenovo B575 Laptop, 8G Memory 750G Hard Drive and #! CrunchBang Linux!

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo