SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-02-03 01:40:19

pjbrunet
#! CrunchBanger
From: Austin, Texas
Registered: 2011-07-30
Posts: 115
Website

[Solved] Your browser is too old.

Lately I have nag messages everywhere I go: "Your browser is too old." It's irritating, but on the other hand I appreciate the scolding. 

Is there any way to get automatic updates? Seems like with Iceweasel I can never keep up. I just upgraded to Wheezy and got the backports and I'm still waaay behind.

I'm still getting nag messages everywhere.  Google says anything < 2 latest versions is unsupported.

What can I do? Switch browsers?

Is there any way to get "one click" browser upgrades with Debian?

UPDATE: The problem was obmenu wasn't really executing Iceweasel.

Last edited by pjbrunet (2015-02-04 20:40:29)

Offline

Help fund CrunchBang, donate to the project!

#2 2015-02-03 02:20:34

pjbrunet
#! CrunchBanger
From: Austin, Texas
Registered: 2011-07-30
Posts: 115
Website

Re: [Solved] Your browser is too old.

I'm going to try getting Jessie and hope I don't break everything.

Offline

#3 2015-02-03 02:22:06

schwim
#! Die Hard
From: Interweb's #1 Devotee
Registered: 2012-10-11
Posts: 1,031
Website

Re: [Solved] Your browser is too old.

I always download the browser from the guys that actually make the browser.  I don't need a middleman slowing down my browser's security updates.

Offline

#4 2015-02-03 02:38:29

AnInkedSoul
#! CrunchBanger
Registered: 2010-06-30
Posts: 232

Re: [Solved] Your browser is too old.

Last edited by AnInkedSoul (2015-02-03 02:39:06)

Offline

#5 2015-02-03 03:15:54

pjbrunet
#! CrunchBanger
From: Austin, Texas
Registered: 2011-07-30
Posts: 115
Website

Re: [Solved] Your browser is too old.

Last edited by pjbrunet (2015-02-03 03:16:35)

Offline

#6 2015-02-03 03:27:07

AnInkedSoul
#! CrunchBanger
Registered: 2010-06-30
Posts: 232

Re: [Solved] Your browser is too old.

well I am kinda oldschool,  if I say you can get X from Y then I am absolutely positive that you can get X from Y otherwise I would say something to the effect that I wasn't sure of what I say...

I suspect if you are running #! then it may have a firefox version installed and pinned or it is something you have configured. That is why I think that derivatives should not say they are the same as debian as they have often tweaked/configured things enough to be very different.

Anyway...

root@debian:~# cat /etc/debian_version
7.8
root@debian:~# cat /etc/apt/sources.list
deb http://ftp.debian.org/debian/ wheezy main
deb http://security.debian.org/ wheezy/updates main
deb http://ftp.debian.org/debian/ wheezy-updates main

deb http://mozilla.debian.net/ wheezy-backports iceweasel-release
root@debian:~# apt-cache policy iceweasel
iceweasel:
  Installed: 35.0.1-1~bpo70+1
  Candidate: 35.0.1-1~bpo70+1
  Version table:
 *** 35.0.1-1~bpo70+1 0
        500 http://mozilla.debian.net/ wheezy-backports/iceweasel-release i386 Packages
        100 /var/lib/dpkg/status
     31.4.0esr-1~deb7u1 0
        500 http://security.debian.org/ wheezy/updates/main i386 Packages
     31.3.0esr-1~deb7u1 0
        500 http://ftp.debian.org/debian/ wheezy/main i386 Packages

Offline

#7 2015-02-03 11:59:10

hhh
Cityspeak
Registered: 2010-08-04
Posts: 3,253

Re: [Solved] Your browser is too old.

Offline

#8 2015-02-04 17:52:14

pjbrunet
#! CrunchBanger
From: Austin, Texas
Registered: 2011-07-30
Posts: 115
Website

Re: [Solved] Your browser is too old.

Just realized the problem, I had been launching Iceweasel from Openbox instead of the CLI. 

Somehow obmenu is launching an older version of Iceweasel (version 13) and I never noticed till now :-/ 

If I launch "iceweasel" from a terminal I get version 31.

Oops!

Offline

#9 2015-02-04 17:55:52

CSCoder4ever
BL Keyboard Troll
From: /dev/zero
Registered: 2013-09-03
Posts: 2,256

Re: [Solved] Your browser is too old.

browser too old? Just manually install firefox

Offline

#10 2015-02-04 17:57:10

schwim
#! Die Hard
From: Interweb's #1 Devotee
Registered: 2012-10-11
Posts: 1,031
Website

Re: [Solved] Your browser is too old.

Offline

#11 2015-02-04 20:38:49

pjbrunet
#! CrunchBanger
From: Austin, Texas
Registered: 2011-07-30
Posts: 115
Website

Re: [Solved] Your browser is too old.

Offline

#12 2015-02-04 20:44:48

pjbrunet
#! CrunchBanger
From: Austin, Texas
Registered: 2011-07-30
Posts: 115
Website

Re: [Solved] Your browser is too old.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: bleh

Debian Logo