SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2015-01-20 03:07:38

calid
New Member
From: Chicago, IL
Registered: 2015-01-19
Posts: 1
Website

[Solved] wifi disconnects every few minutes (iwlwifi)

tl;dr: my connection kept dropping and required reloading the driver just to reconnect (but would then disconnect again after several minutes). Installing a backported kernel and driver from wheezy-backports, as well as setting certain driver options resolved all the issues.


Getting linux wireless working can be exhausting. Typically things 'just work' with crunch, but on my latest laptop I experienced many, many problems setting up my wireless.  I'll outline my wireless specs, symptoms, and steps I took to resolve below. Hopefully this will be of use to others experiencing similar problems.

Specs

Wireless chipset = Intel Centrino Advanced-N 6200
Wireless driver  = iwlwifi
Driver version (before backporting) = 0.36+wheezy.1
Kernel (before backporting) = 3.2.0-4-amd64

Symptoms

Wireless connects but then disconnects after a few minutes. 

tail -f /var/log/{messages,dmesg,syslog}

shows

wlan0: authenticate with [hex string] (try 1)
wlan0: authenticate with [hex string] (try 2)
wlan0: authenticate with [hex string] (try 3)
wlan0: authentication with [hex string] timed out

repeated ad nauseum. Reconnecting fails, and only by fully reloading  network-manager and the drivers is it possible to even reconnect.  However after several minutes the disconnect occurs again and the cycle repeats.

# this is necessary just to reconnect (you may need to also unload cfg80211, mac80211, etc)
$ service network-manager stop
$ modprobe -r iwlwifi
$ modprobe  iwlwifi
$ service network-manager start

# ... but the disconnect occurs again after a few minutes

At this point some common advice for this problem is to disable the watchdog timeout and 11n functionality. This did not initially work for me (but I'll revisit this below).

Resolution

Finally I came across this thread which matched my issue. The recommendation here was to install a backported kernel from wheezy-backports, and that's exactly what I did.

# Add backports to apt sources
$ cat /etc/apt/sources.list
...
## DEBIAN BACKPORTS
deb http://http.debian.net/debian wheezy-backports main contrib non-free

# Install backported kernel
$ sudo apt-get install -t wheezy-backports linux-image-3.16

# Install backported iwlwifi driver
$ sudo apt-get install -t wheezy-backports firmware-iwlwifi

This greatly improved my situation, but alas I still ran into some issues. Specifically, I was getting periodic disconnects and the error in my system logs was:

wpa_supplicant[6800]: wlan0: CTRL-EVENT-DISCONNECTED bssid=[hex string] reason=4

However after a minute or two my connection would recover without any manual intervention. It was annoying, but was still a big improvement from the 'disconnect loop of death' I previously experienced.

This brings me back to the driver options. The final step which fully resolved my issues was to add the following options to my iwlwifi modprobe config:

$ cat /etc/modprobe.d/iwlwifi.conf
options iwlwifi wd_disable=1 11n_disable=1

Now, with these options and the backported kernel/driver, I've been able to connect and stay connected without issue.


Cheers!

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo