SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2014-10-02 20:30:23

StackSmasher
Member
Registered: 2014-09-04
Posts: 14

(Solved) Please Help. Can't downgrade libc6.

Hello.

Today, I tried to install Steam on my machine, by following a guide on the interwebz.
While Steam installed fine, and worked like a charm, I got an extemely serious problem.

I updated libc6 from testing (I know, I should have read the sticky first.)
During the update the following packages were updated :

libc-dev-bin libc6 libc6:i386 libc6-dev libc6-i686:i386

The thing I didn't notice however, was that locales was also removed. Trying to downgrade libc6 like this :
apt-get install libc6=version, also removes a TON of necessary packages.

Any ideas? I want to restore the system to its previous state.

Reinstalling is not quite an option here , as this is my main system and I don't have enough time to
set everything up from scratch.

Please help, I'm desperate.
Thanks a lot.

Last edited by StackSmasher (2014-10-03 21:27:21)

Offline

Be excellent to each other!

#2 2014-10-02 20:38:23

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: (Solved) Please Help. Can't downgrade libc6.

StackSmasher wrote:

Any ideas? I want to restore the system to its previous state.

Reinstalling is not quite an option here , as this is my main system and I don't have enough time to
set everything up from scratch.

Please help, I'm desperate.
Thanks a lot.

Reinstalling may be your only option, if you want to continue with Waldorf (Wheezy). It would have been really, really helpful to you to have done a brief forum search about the dangers of upgrading libc6. There is even a HowTo for installing Steam on Crunchbang.

Why not dist-upgrade to Jessie, now you are halfway there?


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#3 2014-10-02 20:42:38

twoion
Moderator
Registered: 2012-05-11
Posts: 1,648

Re: (Solved) Please Help. Can't downgrade libc6.

If you are sure that only the above listed packages were updated or removed (I believe that at least libc-bin is *missing* from that list): Find the exact version of locales you need on stable. This should be 2.13-38+deb7u4, the same as for the libc6 packages, if you're using the security repository.

Remove all testing repositories from the sources.list and apt-get update.

Use dpkg directorydirectly (<-I'm sleeping?) to force the installation of the packages in the desired versions:

dpkg --force-all --install libc6=$version
dpkg --force-all --install libc-bin=$version
dpkg --force-all --install libc-dev-bin=$version
dpkg --force-all --install libc6:i386=$version
dpkg --force-all --install libc6-i686:i386=$version
dpkg --configure --pending
apt-get install -f

This might or might not work. No guarantees. None.

Last edited by twoion (2014-10-02 20:47:38)


Tannhäuser ~ {www,pkg,ddl}.bunsenlabs.org/{gitlog,repoidx}

Offline

#4 2014-10-02 20:44:53

StackSmasher
Member
Registered: 2014-09-04
Posts: 14

Re: (Solved) Please Help. Can't downgrade libc6.

@twolon These packages were taken from the apt-get output.
Here's a snippet :

Selected version '2.19-11' (Debian:testing [i386]) for 'libc6:i386'
The following extra packages will be installed:
  libc-dev-bin libc6 libc6-dev libc6-i686:i386
Suggested packages:
  glibc-doc glibc-doc:i386 locales:i386
The following packages will be REMOVED:
  locales
The following packages will be upgraded:
  libc-dev-bin libc6 libc6:i386 libc6-dev libc6-i686:i386

I am going to test this now. Pray for me.

Offline

#5 2014-10-02 20:53:13

StackSmasher
Member
Registered: 2014-09-04
Posts: 14

Re: (Solved) Please Help. Can't downgrade libc6.

Wait. I'm confused (Oh man I totally messed up.)

Can I use apt-get? Where do I get the .debs for dpkg?
(Sorry for my dumb questions. I'm so disoriented right now.)

Last edited by StackSmasher (2014-10-02 20:53:36)

Offline

#6 2014-10-02 20:58:19

twoion
Moderator
Registered: 2012-05-11
Posts: 1,648

Re: (Solved) Please Help. Can't downgrade libc6.

Easiest would be: remove the testing entries from the sources.list and apt-get update as I said. Do

sudo apt-get --download-only --reinstall install package=version package1=version package2=version # and so on

apt will ONLY download the packages and NOT try to intall them. You will find the retrieved packages in the directory /var/cache/apt/archives. Pick the ones in the correct version smile
--
Alternatively:

sudo apt-get install devscripts
dget package=version

Last edited by twoion (2014-10-02 20:59:53)


Tannhäuser ~ {www,pkg,ddl}.bunsenlabs.org/{gitlog,repoidx}

Offline

#7 2014-10-02 21:19:42

StackSmasher
Member
Registered: 2014-09-04
Posts: 14

Re: (Solved) Please Help. Can't downgrade libc6.

Nevermind. I messed up (I feel really disappointed right now.)

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libc6 : Breaks: libc6:i386 (!= 2.19-11) but 2.13-38+deb7u4 is to be installed
 libc6:i386 : Breaks: libc6 (!= 2.13-38+deb7u4) but 2.19-11 is to be installed
 libc6-i686:i386 : PreDepends: libc6:i386 (= 2.19-11) but 2.13-38+deb7u4 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

It's late. I have to get some sleep. Thank you all for your help.
If you have any other suggestions, please leave them on this topic, and I will try them tomorrow.
Otherwise, I will have to find some time this and the next weekend to, at least, fresh install and set up the basics on my system.

(I feel so bad right now... I did something extremely stupid, and I wanted to work this weekend on my PC.
I failed spectacularly hard.)

Good Night. Thanks.

Offline

#8 2014-10-02 22:02:12

twoion
Moderator
Registered: 2012-05-11
Posts: 1,648

Re: (Solved) Please Help. Can't downgrade libc6.

Looks better than before; it seems that what remains to be fixed is just

libc6:i386 : Breaks: libc6 (!= 2.13-38+deb7u4) but 2.19-11 is to be installed

In /var/cache/apt/archives, you should have a libc6 package ending in _i686 or _i386 or similar. Did you install that with dpkg --force-all --install? Otherwise, download it with

sudo apt-get -d --reinstall install libc6:i386

and try installing it.


Tannhäuser ~ {www,pkg,ddl}.bunsenlabs.org/{gitlog,repoidx}

Offline

#9 2014-10-03 14:07:05

StackSmasher
Member
Registered: 2014-09-04
Posts: 14

Re: (Solved) Please Help. Can't downgrade libc6.

YES!!! I'm so happy right now!
After booting into recovery(openbox couldn't open because of locales missing), I downloaded all versions of broken packages that were needed (using apt-get download, apt-get --download-only install didn't work), and installed them the way you suggested.

The system works like a charm!!!

I can't literally thank you enough! You saved me from a TON of hours of head scraching, trying to restore everything as it is now.
(I have now however learned the hard way not to mix Stable with Testing. And not to use sudo late at night!)
smile

Offline

#10 2014-10-03 14:23:51

StackSmasher
Member
Registered: 2014-09-04
Posts: 14

Re: (Solved) Please Help. Can't downgrade libc6.

Just one tiny question (I'm kinda paranoid).

Can what happened have any impact to the stability of the system?

Thanks a lot once more!

Offline

#11 2014-10-03 20:30:14

Head_on_a_Stick
CatMod
From: A world of pure imagination
Registered: 2014-01-21
Posts: 4,797

Re: (Solved) Please Help. Can't downgrade libc6.

It should be OK, but it's impossible to be sure.
Make sure your sources.list is back to stock (& run `apt-get update`) and make sure you backup any important files at regular intervals.
smile

Offline

#12 2014-10-03 21:00:30

vic
#! by Default
From: /grill
Registered: 2009-02-13
Posts: 3,361

Re: (Solved) Please Help. Can't downgrade libc6.

And how about a "solved" edit of thread title  smile


Time to move on!#

Offline

#13 2014-10-03 21:27:03

StackSmasher
Member
Registered: 2014-09-04
Posts: 14

Re: (Solved) Please Help. Can't downgrade libc6.

Head_on_a_Stick wrote:

It should be OK, but it's impossible to be sure.
Make sure your sources.list is back to stock (& run `apt-get update`) and make sure you backup any important files at regular intervals.
smile

Yeah, I learned the backup thing the hard way, too!


@vicshrike hehe yes, of course!

Thank you all for your great help.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo