SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2014-06-12 06:07:53

krabbe
Member
Registered: 2014-05-11
Posts: 11

[Openbox] Disable cycling through all desktops [solved]

Hello,

Is it possible to disable that on mouse wheel scroll I can switch from desktop 1 to 4 and from 4 to 1?

I do not want to have this continous but the mouse wheel scrolling should stop at desktop 1 and 4.

Thanks!

Last edited by krabbe (2014-06-13 06:15:14)

Offline

Help fund CrunchBang, donate to the project!

#2 2014-06-12 11:36:08

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: [Openbox] Disable cycling through all desktops [solved]

Putting

<wrap>no</wrap>

in the desktop switching section of rc.xml does what you want, and my reading of the documentation suggests that you can do the same for the mousebinds - Openbox wiki Help:Actions

     <mousebind action="Click" button="Up">
        <action name="DesktopPrevious" />
        <to>previous</to>
        <wrap>no</wrap>
      </mousebind>
      <mousebind action="Click" button="Down">
        <action name="DesktopNext" />
        <to>next</to>
        <wrap>no</wrap>
      </mousebind>

...but it doesn't work for me sad
EDIT:  You may be able to configure Tint2 Tint2 Mouse action

Last edited by damo (2014-06-12 11:55:02)


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#3 2014-06-12 23:42:17

krabbe
Member
Registered: 2014-05-11
Posts: 11

Re: [Openbox] Disable cycling through all desktops [solved]

Cool! This is indeed working. smile

The solution:

    <context name="Desktop">
      <mousebind button="Up" action="Click">
        <action name="GoToDesktop">
          <to>previous</to>
          <wrap>no</wrap>
        </action>
      </mousebind>
      <mousebind button="Down" action="Click">
        <action name="GoToDesktop">
          <to>next</to>
          <wrap>no</wrap>
        </action>
      </mousebind>

Thanks!

Offline

#4 2014-06-13 00:01:28

damo
#! gimpbanger
From: N51.5 W002.8 (mostly)
Registered: 2011-11-24
Posts: 5,434

Re: [Openbox] Disable cycling through all desktops [solved]

That's good you found it - I guessed the answer was around there somewhere smile

EDIT: Just to clarify for others - in the <context name="Desktop"> section of rc.xml comment out the DesktopPrevious/Next stanza, and replace with the lines that krabbe found

    <context name="Desktop">
<!--
     <mousebind action="Click" button="Up">
        <action name="DesktopPrevious" />
      </mousebind>
      <mousebind action="Click" button="Down">
        <action name="DesktopNext" />
      </mousebind>
-->
<!-- Prevent wrapping when mouse-scrolling desktops. Replace section above with... -->
    <mousebind action="Click" button="Up">
        <action name="GoToDesktop">
          <to>previous</to>
          <wrap>no</wrap>
        </action>
      </mousebind>
      <mousebind action="Click" button="Down">
        <action name="GoToDesktop">
          <to>next</to>
          <wrap>no</wrap>
        </action>
      </mousebind>

(and if the OP could add eg [SOLVED] by editing the first post, that would help others looking for the answer wink )

Last edited by damo (2014-06-13 00:17:55)


BunsenLabs Group on deviantArt
damo's gallery on deviantArt
Openbox themes
Forum Moderator smile

Offline

#5 2014-06-13 06:15:22

krabbe
Member
Registered: 2014-05-11
Posts: 11

Re: [Openbox] Disable cycling through all desktops [solved]

Done. smile

Offline

#6 2014-09-19 04:37:31

Cyan
New Member
Registered: 2014-09-19
Posts: 3

Re: [Openbox] Disable cycling through all desktops [solved]

Hi,

I'm having this exact problem, except that when I edit the rc.xml file, I don't see "DesktopNext" or "DesktopPrevious" *anywhere* in the text. I only see "GoToDesktop," and that's the closest thing to the others I see at all. Anyway, I tried commenting *that* out, but haven't had any luck--it still switches desktops with any scroll of the mouse wheel, which drives me insane and is the only reason I don't use Manjaro more.  Any ideas? Thanks in advance!

Offline

#7 2014-09-19 14:25:54

nore
>2^9
From: Lakeland
Registered: 2009-11-28
Posts: 740

Re: [Openbox] Disable cycling through all desktops [solved]

Do you want scrolling to stop at last desktop like krabbe did, or do you want to disable changing desktops with the wheel altogether?
Search for

<context name="Desktop">

and read carefully everything between it and the next </context>, snip it and post here between code tags.

(Default rc.xml in Manjaro may be a little different from CB's, I'm not on my Manjaro box right now.)

Edit: since this thread is already solved, it might be better to start a new thread and link to the original one.

Last edited by nore (2014-09-19 14:33:16)

Offline

#8 2014-09-21 21:23:32

Cyan
New Member
Registered: 2014-09-19
Posts: 3

Re: [Openbox] Disable cycling through all desktops [solved]

nore wrote:

Do you want scrolling to stop at last desktop like krabbe did, or do you want to disable changing desktops with the wheel altogether?
Search for

<context name="Desktop">

and read carefully everything between it and the next </context>, snip it and post here between code tags.

(Default rc.xml in Manjaro may be a little different from CB's, I'm not on my Manjaro box right now.)

Edit: since this thread is already solved, it might be better to start a new thread and link to the original one.


Hi nore,

I'll post in a new forum. Just wanted to let you know here before leaving this thread. I'll post the url to this one in the new one. Thanks!

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo