SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-11-10 07:42:45

MidGe
Member
Registered: 2012-05-27
Posts: 29

[SOLVED] how to get around ssh fail as "Roaming not allowed by server"

First of all, I have been a grateful user of CrunchBang for nearly three years now and I have not seen a distribution more suitable to my needs and inclinations.

But now, for something not related to CrunchBang specifically, but maybe Debian related, my problems with OpenSSH.

I have had quite a lot of trouble with openssh and would like some help, if at all possible.

I am trying to ssh to my localhost.  Maybe that is the problem, and this is not possible.  However, I think that I have succeeded with this quite a while ago.

I have re-installed ssh a number of times, after deleting all traces of openssh, all to no avail.

Searching for the issues on Google raises a very large number of posts with a similar issue but no answer that fits my situation.  I think I must have tried close to twenty different alternatives, mostly to do with directories permissions.  This is not the issue since the key is seen as correct.

When I try to ssh with verbose turned on everything works fine, it connects to the server, gets the key, validates the key as correct(!) then gives a message "debug1: Roaming not allowed by server" and tries alternative means of identifying where it expectedly fails.

The problems is that I am not sure where ssh gets this debug message from and I cannot find a way to enable the server to allow roaming (whatever that is in the context of a server or desktop!?).

Has anyone got an answer for this? I would really appreciate it, given the inordinate amount of time I have spent on this.

Last edited by MidGe (2013-11-10 13:05:16)

Offline

Help fund CrunchBang, donate to the project!

#2 2013-11-10 13:04:46

MidGe
Member
Registered: 2012-05-27
Posts: 29

Re: [SOLVED] how to get around ssh fail as "Roaming not allowed by server"

Got the answer, and it had nothing to do with directories permissions.

The problem was that /etc/ssh/sshd_config did not have "HostbasedAuthentication" set to yes!

Ah well, I guess HostbasedAuthentication vaguely means that "Roaming is not allowed"!?!  smile I love meaningful error messages.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: bleh

Debian Logo