SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-09-22 18:18:29

antiv0rtex
#! Die Hard
From: Earth
Registered: 2012-10-05
Posts: 574

My ProFTPD installation isn't happy, and I don't know why.

Status:	        Connecting to 0.0.0.0:2112...
Status:	        Connection established, waiting for welcome message...
Response:	220 ProFTPD 1.3.4a Server (Debian) [::ffff:192.168.1.116]
Command:	USER username
Response:	331 Password required for username
Command:	PASS *************
Response:	230 User username logged in
Command:	OPTS UTF8 ON
Response:	200 UTF8 set to on
Status:	        Connected
Status:	        Retrieving directory listing...
Command:	PWD
Response:	257 "/home/username" is the current directory
Command:	TYPE I
Response:	200 Type set to I
Command:	PORT 192,168,1,141,202,249
Response:	500 Illegal PORT command
Command:	PASV
Response:	227 Entering Passive Mode (192,168,1,116,141,64).
Status:	Server sent passive reply with unroutable address. Using server address instead.
Command:	MLSD
Error:	        Connection timed out
Error:	        Failed to retrieve directory listing

Offline

Help fund CrunchBang, donate to the project!

#2 2013-09-22 18:36:52

dot|not
#! Junkie
From: /dev/null
Registered: 2013-09-05
Posts: 371

Re: My ProFTPD installation isn't happy, and I don't know why.

Offline

#3 2013-09-22 19:22:45

antiv0rtex
#! Die Hard
From: Earth
Registered: 2012-10-05
Posts: 574

Re: My ProFTPD installation isn't happy, and I don't know why.

#
# /etc/proftpd/proftpd.conf -- This is a basic ProFTPD configuration file.
# To really apply changes, reload proftpd after modifications, if
# it runs in daemon mode. It is not required in inetd/xinetd mode.
# 

# Includes DSO modules
Include /etc/proftpd/modules.conf

# Set off to disable IPv6 support which is annoying on IPv4 only boxes.
UseIPv6				on
# If set on you can experience a longer connection delay in many cases.
IdentLookups			off

ServerName			"Debian"
ServerType			standalone
DeferWelcome			off

MultilineRFC2228		on
DefaultServer			on
ShowSymlinks			on

TimeoutNoTransfer		600
TimeoutStalled			600
TimeoutIdle			1200

DisplayLogin                    welcome.msg
DisplayChdir               	.message true
ListOptions                	"-l"

DenyFilter			\*.*/

# Use this to jail all users in their homes 
# DefaultRoot			~

# Users require a valid shell listed in /etc/shells to login.
# Use this directive to release that constrain.
# RequireValidShell		off

# Port 21 is the standard FTP port.
Port				2112

# In some cases you have to specify passive ports range to by-pass
# firewall limitations. Ephemeral ports can be used for that, but
# feel free to use a more narrow range.
# PassivePorts                  49152 65534

# If your host was NATted, this option is useful in order to
# allow passive tranfers to work. You have to use your public
# address and opening the passive ports used on your firewall as well.
# MasqueradeAddress		1.2.3.4

# This is useful for masquerading address with dynamic IPs:
# refresh any configured MasqueradeAddress directives every 8 hours
<IfModule mod_dynmasq.c>
# DynMasqRefresh 28800
</IfModule>

# To prevent DoS attacks, set the maximum number of child processes
# to 30.  If you need to allow more than 30 concurrent connections
# at once, simply increase this value.  Note that this ONLY works
# in standalone mode, in inetd mode you should use an inetd server
# that allows you to limit maximum number of processes per service
# (such as xinetd)
MaxInstances			30

# Set the user and group that the server normally runs at.
User				proftpd
Group				nogroup

# Umask 022 is a good standard umask to prevent new files and dirs
# (second parm) from being group and world writable.
Umask				022  022
# Normally, we want files to be overwriteable.
AllowOverwrite			on

# Uncomment this if you are using NIS or LDAP via NSS to retrieve passwords:
# PersistentPasswd		off

# This is required to use both PAM-based authentication and local passwords
# AuthOrder			mod_auth_pam.c* mod_auth_unix.c

# Be warned: use of this directive impacts CPU average load!
# Uncomment this if you like to see progress and transfer rate with ftpwho
# in downloads. That is not needed for uploads rates.
#
# UseSendFile			off

TransferLog /var/log/proftpd/xferlog
SystemLog   /var/log/proftpd/proftpd.log

# Logging onto /var/log/lastlog is enabled but set to off by default
#UseLastlog on

# In order to keep log file dates consistent after chroot, use timezone info
# from /etc/localtime.  If this is not set, and proftpd is configured to
# chroot (e.g. DefaultRoot or <Anonymous>), it will use the non-daylight
# savings timezone regardless of whether DST is in effect.
#SetEnv TZ :/etc/localtime

<IfModule mod_quotatab.c>
QuotaEngine off
</IfModule>

<IfModule mod_ratio.c>
Ratios off
</IfModule>


# Delay engine reduces impact of the so-called Timing Attack described in
# http://www.securityfocus.com/bid/11430/discuss
# It is on by default. 
<IfModule mod_delay.c>
DelayEngine on
</IfModule>

<IfModule mod_ctrls.c>
ControlsEngine        off
ControlsMaxClients    2
ControlsLog           /var/log/proftpd/controls.log
ControlsInterval      5
ControlsSocket        /var/run/proftpd/proftpd.sock
</IfModule>

<IfModule mod_ctrls_admin.c>
AdminControlsEngine off
</IfModule>

#
# Alternative authentication frameworks
#
#Include /etc/proftpd/ldap.conf
#Include /etc/proftpd/sql.conf

#
# This is used for FTPS connections
#
#Include /etc/proftpd/tls.conf

#
# Useful to keep VirtualHost/VirtualRoot directives separated
#
#Include /etc/proftpd/virtuals.conf

# A basic anonymous configuration, no upload directories.

# <Anonymous ~ftp>
#   User				ftp
#   Group				nogroup
#   # We want clients to be able to login with "anonymous" as well as "ftp"
#   UserAlias			anonymous ftp
#   # Cosmetic changes, all files belongs to ftp user
#   DirFakeUser	on ftp
#   DirFakeGroup on ftp
# 
#   RequireValidShell		off
# 
#   # Limit the maximum number of anonymous logins
#   MaxClients			10
# 
#   # We want 'welcome.msg' displayed at login, and '.message' displayed
#   # in each newly chdired directory.
#   DisplayLogin			welcome.msg
#   DisplayChdir		.message
# 
#   # Limit WRITE everywhere in the anonymous chroot
#   <Directory *>
#     <Limit WRITE>
#       DenyAll
#     </Limit>
#   </Directory>
# 
#   # Uncomment this if you're brave.
#   # <Directory incoming>
#   #   # Umask 022 is a good standard umask to prevent new files and dirs
#   #   # (second parm) from being group and world writable.
#   #   Umask				022  022
#   #            <Limit READ WRITE>
#   #            DenyAll
#   #            </Limit>
#   #            <Limit STOR>
#   #            AllowAll
#   #            </Limit>
#   # </Directory>
# 
# </Anonymous>

# Include other custom configuration files
Include /etc/proftpd/conf.d/

Offline

#4 2013-09-22 19:35:41

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,643

Re: My ProFTPD installation isn't happy, and I don't know why.

Maybe is your isp blocking larger port numbers, try port 22 for example (if you are not running ssh).

Offline

#5 2013-09-22 20:23:51

dot|not
#! Junkie
From: /dev/null
Registered: 2013-09-05
Posts: 371

Re: My ProFTPD installation isn't happy, and I don't know why.

Offline

#6 2013-09-22 23:52:26

antiv0rtex
#! Die Hard
From: Earth
Registered: 2012-10-05
Posts: 574

Re: My ProFTPD installation isn't happy, and I don't know why.

thanks very much for the suggestions. will update this thread when i have tried them, probably next weekend or something (really busy atm).

Offline

#7 2013-09-28 19:15:06

antiv0rtex
#! Die Hard
From: Earth
Registered: 2012-10-05
Posts: 574

Re: My ProFTPD installation isn't happy, and I don't know why.

Last edited by antiv0rtex (2013-09-28 19:17:44)

Offline

#8 2013-09-29 15:28:48

antiv0rtex
#! Die Hard
From: Earth
Registered: 2012-10-05
Posts: 574

Re: My ProFTPD installation isn't happy, and I don't know why.

Switched FTP clients last night, from Filezilla to the more lightweight gFTP. I still can't connect via external IP in passive mode, but internal IP connection works. Hoping to get connections from the outside world resolved, though.

Offline

#9 2013-09-29 20:58:16

dot|not
#! Junkie
From: /dev/null
Registered: 2013-09-05
Posts: 371

Re: My ProFTPD installation isn't happy, and I don't know why.

I'm no expert for setting up FTP servers, I avoid this - in my humble opinion - nowadays broken protocol where I can. Did you read the link I posted warlier?

Offline

#10 2013-09-30 05:05:54

antiv0rtex
#! Die Hard
From: Earth
Registered: 2012-10-05
Posts: 574

Re: My ProFTPD installation isn't happy, and I don't know why.

^ Yes.

As a sidebar: you've convinced me to switch to SFTP. Modifying proftpd as such at the moment.

Offline

#11 2013-09-30 13:04:34

dot|not
#! Junkie
From: /dev/null
Registered: 2013-09-05
Posts: 371

Re: My ProFTPD installation isn't happy, and I don't know why.

Offline

#12 2013-10-05 03:14:31

antiv0rtex
#! Die Hard
From: Earth
Registered: 2012-10-05
Posts: 574

Re: My ProFTPD installation isn't happy, and I don't know why.

Gaah. I'm lost. How should I go about configuring proftpd for SFTP? Or should I use a different daemon altogether?

Offline

#13 2013-10-05 09:46:36

dot|not
#! Junkie
From: /dev/null
Registered: 2013-09-05
Posts: 371

Re: My ProFTPD installation isn't happy, and I don't know why.

SFTP is built into OpenSSH, I am not quite sure if ProFTPd fully supports SFTP.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo