SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-09-03 09:14:32

Hy
#! CrunchBanger
Registered: 2012-02-18
Posts: 112

[SOLVED] No sound on xgalaga or xgalaga++?

(  Please move if posted in the wrong section, but i think i got it right smile  )

Back in '06 i was using Puppy Linux and it came with the great retro game 'xGalaga' (i'm seriously old-skool) and i loved it. You can imagine my joy upon finding the same game in the Wheezy repos!

Sadly though there doesn't appear to be any sound output when i play it now, and that really hampers my enjoyment. I seemed to remember there was also a later version where your ship could dodge baddies by disappearing off one side of the screen and reappear on the other side (Just like the baddies do), so, on spotting another version (the ++ mentioned in the title) I installed that one too, thinking that was it. It wasn't, though it's also very good (you can resize the play area just by dragging the edges of the window), however, it too has no sound output.

So, I know the games have sound, i just don't know how to enable it.

Can anyone help me out here? Is there a command line switch i need to set, or maybe something i need to adjust under Volume control?

TIA for any suggestions! smile

Last edited by Hy (2013-09-04 13:34:15)


~ Wait - what? ~

Offline

Be excellent to each other!

#2 2013-09-04 00:05:56

frankob
#! CrunchBanger
From: Croatia
Registered: 2012-06-08
Posts: 204
Website

Re: [SOLVED] No sound on xgalaga or xgalaga++?

Just tried it now, and no sound here, too... Couldn't figure out why. The "later version where your ship could dodge baddies by disappearing off one side of the screen and reappear on the other side" is xgalaga-hyperspace. You have it installed, just run it from terminal.
As for the sound, I got no clue...


Omnia sunt communia.

Offline

#3 2013-09-04 02:21:16

drp6
#! Member
Registered: 2013-06-30
Posts: 52

Re: [SOLVED] No sound on xgalaga or xgalaga++?

xgalaga is available in the repos?! Sweet.  big_smile

Sorry, no idea on the audio, but wanted to thank you for pointing out xgalaga was available. I'm going to install it, if I get sound or don't will post here.

Offline

#4 2013-09-04 04:42:26

Hy
#! CrunchBanger
Registered: 2012-02-18
Posts: 112

Re: [SOLVED] No sound on xgalaga or xgalaga++?

frankob wrote:

Just tried it now, and no sound here, too... Couldn't figure out why. The "later version where your ship could dodge baddies by disappearing off one side of the screen and reappear on the other side" is xgalaga-hyperspace. You have it installed, just run it from terminal.
As for the sound, I got no clue...


Wow! so 'hyperspace' installed with the regular version! I notice they share the same scoreboard too.

Also, thanks to your tip off i located what the issue is! When launching the game from the terminal it reports:

xgal.sndsrv: Couldn't open DSP /dev/dsp

I'm still none the wiser how to fix it though, but i know that i don't have a /dev/dsp folder on my machine....


~ Wait - what? ~

Offline

#5 2013-09-04 05:55:33

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 13,970

Re: [SOLVED] No sound on xgalaga or xgalaga++?

Figured it out.
https://wiki.debian.org/SoundFAQ
Install oss-compat, then `modprobe snd-pcm-oss`.

Offline

#6 2013-09-04 08:10:10

Hy
#! CrunchBanger
Registered: 2012-02-18
Posts: 112

Re: [SOLVED] No sound on xgalaga or xgalaga++?

installed oss-compat then entered the modprobe line (sudo) in terminal.
Logged out and back in: still no sound,
Rebooted: still no sound.

What did i miss?


~ Wait - what? ~

Offline

#7 2013-09-04 12:01:27

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 13,970

Re: [SOLVED] No sound on xgalaga or xgalaga++?

Shouldn't even need to reboot...do you have a /dev/dsp at this point?

By the way, you know you need to actually start game play to get sound; xgalaga doesn't produce sound in attract mode.

Offline

#8 2013-09-04 13:09:23

frankob
#! CrunchBanger
From: Croatia
Registered: 2012-06-08
Posts: 204
Website

Re: [SOLVED] No sound on xgalaga or xgalaga++?

Yep, I have sound now. But not before I started the game in full screen mode, or without flags, anyway... I first ran it in windowed mode, still didn't have sound and gave me an IO error, too. Then I tried to run it without any flags, and it worked. Now it works also in windowed mode. Cool! :-)


Omnia sunt communia.

Offline

#9 2013-09-04 13:20:15

Hy
#! CrunchBanger
Registered: 2012-02-18
Posts: 112

Re: [SOLVED] No sound on xgalaga or xgalaga++?

Cheers folks! I now have sound (though still not in xgalaga++).

Now, how do i get windowed mode?  big_smile

xgalaga -window

Thanks for all your help!  smile

Last edited by Hy (2013-09-04 13:24:01)


~ Wait - what? ~

Offline

#10 2013-09-04 13:27:01

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 13,970

Re: [SOLVED] No sound on xgalaga or xgalaga++?

^ I think this thread can be marked [solved] now, don't you? wink  (Hint:  Edit first post.)

As for windowed mode, the man page suggests `xgalaga -window` should get you this.  (`man {name-of-executable}` is usually a true true friend. 8o )  (EDIT:  I see you found it. cool )

By the way, according to the xgalaga++ project page, that port currently has no sound.

Last edited by pvsage (2013-09-04 13:33:28)

Offline

#11 2013-09-05 11:06:32

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 13,970

Re: [SOLVED] No sound on xgalaga or xgalaga++?

Since you like Galaga, I was wondering if you've heard about Chromium BSU?  It is in the Debian repos as well.
http://chromium-bsu.sourceforge.net/

Offline

#12 2013-09-05 19:02:25

frankob
#! CrunchBanger
From: Croatia
Registered: 2012-06-08
Posts: 204
Website

Re: [SOLVED] No sound on xgalaga or xgalaga++?

Is it just me being rather the adventure/RPG guy, or Chroumium is really quite a difficult game? :-D


Omnia sunt communia.

Offline

#13 2013-09-05 20:46:04

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 13,970

Re: [SOLVED] No sound on xgalaga or xgalaga++?

IMHO, the drone fighter just moves too fast; the one time I played it I kept overshooting the weapon upgrade & healing/repair thingies on the screen when I tried to catch them.

Last edited by pvsage (2013-09-05 23:52:13)

Offline

#14 2013-09-05 23:20:31

frankob
#! CrunchBanger
From: Croatia
Registered: 2012-06-08
Posts: 204
Website

Re: [SOLVED] No sound on xgalaga or xgalaga++?

Yeh, this is exactly where I felt frustration, too... I guess I should just go back to Neverwinter Nights. :-D


Omnia sunt communia.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo