SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-05-04 02:42:16

sqlpython
#! Die Hard
From: New England
Registered: 2011-11-28
Posts: 931

Disable Synaptic TouchPad while typing: Waldorf OpenBox 2013

I Searched and found some examples of the Subject title which apparently worked perfectly in 2009 but do not seem to with Waldorf .and OpenBox this year.
Each Fix to Disable while typing that I found in my Search utilized shmconfig.fdi which does not seem evident in Waldorf in 2013.
I did a through Google and also some other Distros and I found some of the same plus references to using synclient which does not seem successful when used with Waldorf/OpenBox either.
If your process the command

synclient -l

You get lots of very useful modifications for the Touchpad but none on the list seem to address Disable Touchpad while Typing.

So, I looked at syndaemon

man syndaemon

and saw that I could delay the Touchpad with the daemon like so

sudo  syndaemon -i 2 -d

And was happy to see this works very well.
You can increase the Numeric Value such as -i 3 Or -i 4 Or what ever Delay that you fell comfortable with.........
The setting of -i 2 gets me a delay of about One Second which is what I want but you choose what works.

My next job was add this via a script.
Then I decided instead to simply add it to the Touchpad Section of  /home/sqlpython/.config/openbox/autostart
Which in my opinion was a better choice.

In this section I modified by adding the syndaemon -i 2 -d line to run the command upon starting OpenBox as a User.

## Detect and configure touchpad. See 'man synclient' for more info.
if egrep -iq 'touchpad' /proc/bus/input/devices; then
    synclient VertEdgeScroll=1 &
    synclient TapButton1=1 &
fi
syndaemon -i 2 -d

If you Need your Waldorf OpenBox Desktop to begin a  Delay on the TouchPad as you Start Typing then this may be what the Doctor Order.. Simple and Direct.

Last edited by sqlpython (2013-05-04 23:46:10)


OHCG #!, Jessie,, Siduction-13.1Slackware 14Bridge,, Sabayon 13.4,

Offline

Be excellent to each other!

#2 2013-05-17 20:09:41

ztp
New Member
Registered: 2013-05-17
Posts: 1

Re: Disable Synaptic TouchPad while typing: Waldorf OpenBox 2013

Thanks for this! Simple and it works great.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo