SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-05-01 15:40:00

dmesg
New Member
Registered: 2013-05-01
Posts: 8

LVM setup - grub fails

Hi forum

I have downloaded  crunchbang-11-20130119-amd64.iso and transfered it via 'dd'  on a 1GB USB stick. Live session works but installing it at top of a simple LVM setup do not work as it fails with installing grub and I have checked that I do not install grub by accident on my USB stick. Used settings were:

o Guided - use entire disk and set up LVM
o All files in one partition (recommended for new users)
o ext4 / (user_xattr)

and grub should be installed at /dev/sda (laptop with one hd, DVD-drive and crunchbang usb stick) but it fails. I hope it is ok to post the error here as I was unable to find a crunchbang bugzilla address and I'm not sure whether launchpad.net/crunchbang is the correct place (seems to be dead) to post this kind of information. Any help is welcome and at the moment I'm on Debian wheezy with xfce.

Offline

Be excellent to each other!

#2 2013-05-01 16:06:37

VDP76
#! Bean Roaster
Registered: 2012-04-12
Posts: 840

Re: LVM setup - grub fails

Offline

#3 2013-05-01 16:39:47

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: LVM setup - grub fails

More info on why grub could not be installed in the MBR would be welcome.
Switching to virtual console 4 - Ctrl+Alt+F4 - should give you a detailed log on what is happening exactly.

I am guessing that there is not  enough space in the pre-partition gap to store the GRUB core image, but I could be totally wrong.

You can avoid this by starting the first partition on the disk on the cyl 2 boundary for instance. That should leave enough space for the grub core image.

Offline

#4 2013-05-01 16:43:30

babouk
#! CrunchBanger
From: #!_de
Registered: 2009-08-10
Posts: 110
Website

Re: LVM setup - grub fails

Last edited by babouk (2013-05-01 17:17:42)

Offline

#5 2013-05-01 16:44:47

dmesg
New Member
Registered: 2013-05-01
Posts: 8

Re: LVM setup - grub fails

Offline

#6 2013-05-01 17:56:01

dmesg
New Member
Registered: 2013-05-01
Posts: 8

Re: LVM setup - grub fails

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: bleh

Debian Logo