SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-01-22 17:51:25

ergomatic
New Member
Registered: 2013-01-22
Posts: 1

fixed my wifi on waldorf- here's how

I was having problems with my Atheros USB wifi adapter under Waldorf Crunchbang.  I looked at dmesg and it showed that loading of the ath9k driver failed like this:
[ 8658.903327] usb 2-5: ath9k_htc: Firmware - htc_9271.fw not found
[ 8658.903335] ath9k_htc: probe of 2-5:1.0 failed with error -22
...so I found firmware here:
http://linuxwireless.org/en/users/Drivers/ath9k_htc
...and, as root, copied the firmware file I downloaded into /lib/firmware.  Now it works!  Thought y'all should know.

Offline

Help fund CrunchBang, donate to the project!

#2 2015-01-24 12:13:29

civ
New Member
Registered: 2015-01-24
Posts: 5

Re: fixed my wifi on waldorf- here's how

Hello:

New user, old hardware attempting (yet another) Linux distro install.
Very happy at the moment with #! Waldorf, maybe this time I have a winner.    =-)

After install, I had wireless problems, same ones you had.

From dmesg:
--------------

[    1.988944] usb 2-2: New USB device found, idVendor=0cf3, idProduct=7015
[    1.988949] usb 2-2: New USB device strings: Mfr=16, Product=32, SerialNumber=48
[    1.988953] usb 2-2: Product: USB WLAN
[    1.988956] usb 2-2: Manufacturer: ATHEROS
[    1.988958] usb 2-2: SerialNumber: 12345

--------------

This is my TP-LINK TL-WN821N wireless USB dongle (V3) detected.

But I had no wireless and the cause was listed in dmesg:

--------------

[   23.140421] usb 2-2: firmware: agent aborted loading htc_7010.fw (not found?)
[   23.140896] ath9k_htc: probe of 2-2:1.0 failed with error -22
[   23.140942] usbcore: registered new interface driver ath9k_htc

-------

I looked for the htc_7010.fw driver but it is not present in /lib/firmware, so the (not found?) in dmesg applies.

Another atheros firmware file is present in /lib/firmware: carl9170, but the Waldorf install does not try to load it - instead it attempts to load htc_7010.fw, which (as dmesg indicates) is not there. 

For info on the carl 9170 see here:
https://wiki.debian.org/carl9170

I solved the matter the same way you did, so thanks a bunch.

Cheers,

CIV

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo