SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-01-06 15:14:37

codiddle
New Member
Registered: 2013-01-01
Posts: 5

How I got WNA3100 Netgear Wireless n300 to work...

It's odd, this operating system has been outstanding.  It automatically picked up my MediaLink USB stick, however this Netgear has ALWAYS had issues with Linux.  It's always fun to try and get it working again, though.

This time around, the process took much less time, but something was indeed wrong.
I found the driver by searching bcmw43xx64.inf and bcmw43xx32.inf.  The site I pulled the drivers from was german, or something and the last time I checked it, this morning, the server was 403.  So the files are out there, just can't tell you exactly where.
No problem.

I downloaded the ndiswrapper and ndisgtk from the repos by:

sudo apt-get update
sudo apt-get install ndiswrapper-common
sudo apt-get install ndiswrapper-dkms
sudo apt-get install ndisgtk

Again, no problem.

However, when I loaded the driver into ndisgtk, problems arose.  It recognized the driver in every way imaginable.  It just simply would not connect to the internet.

ndiswrapper -l

showed:

bcmwlhigh5 : driver installed
device(0846:9020) present

What I had to do to get it working:

In the terminal:
(For those reading that aren't using Crunchbang, Geany is simply a text-editor, replace that with your favorite text-editor (i.e. gedit)

sudo geany /etc/modules

Add the line at the bottom:

ndiswrapper

This allows ndiswrapper to run at boot.

I checked to make sure I had b43-fwcutter but reinstalled it anyway:

sudo apt-get install --reinstall b43-fwcutter firmware-b43-lpphy-installer

Then, I had to go and rename some folders.  Sounds odd, I know, but it worked.
(For those reading that aren't using Crunchbang, Thunar is simply the file manager, replace that with your distros file manager)

sudo thunar /var/lib/

Rename NetworkManager.  I recommend if you try this, to just add some digits or something.  So it's easy to find and fix later if needed.

sudo thunar /etc/NetworkManager/

Rename system-connections, again I recommend adding digits to the existing filename.

Finally, open the terminal and type:

sudo geany /etc/network/interfaces

Comment out everything except 'auto lo' and 'iface to inet loopback'.

If the card still doesn't work, try to unplug it, then plug it back in.
If it still doesn't work, reboot.
If that doesn't work, find a different guide.

Last edited by codiddle (2013-01-06 18:51:01)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo