SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#276 2012-11-11 21:18:12

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: Debian Netinstal Sid - Yet Another How To

Run

sudo apt-get update

sudo apt-get dist-upgrade

Offline

Help fund CrunchBang, donate to the project!

#277 2012-11-11 21:20:42

jed
#! CrunchBanger
From: Detachment 7
Registered: 2012-08-28
Posts: 200
Website

Re: Debian Netinstal Sid - Yet Another How To

Ok, done!
Jed

Offline

#278 2012-11-11 21:22:14

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: Debian Netinstal Sid - Yet Another How To

sudo apt-get install spacefm

Offline

#279 2012-11-11 21:23:43

jed
#! CrunchBanger
From: Detachment 7
Registered: 2012-08-28
Posts: 200
Website

Re: Debian Netinstal Sid - Yet Another How To

jedsdesk@jedsdesk:~$ sudo apt-get install spacefm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 spacefm : PreDepends: libgtk2.0-dev (>= 2.18) but it is not going to be installed
           PreDepends: libglib2.0-dev but it is not going to be installed
           PreDepends: libstartup-notification0-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Same result...
Jed

Offline

#280 2012-11-11 21:24:52

jed
#! CrunchBanger
From: Detachment 7
Registered: 2012-08-28
Posts: 200
Website

Re: Debian Netinstal Sid - Yet Another How To

Then I tried this;

jedsdesk@jedsdesk:~$ sudo apt-get install libgtk2.0-dev libglib2.0-dev libstartup-notification0-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libglib2.0-dev : Depends: libglib2.0-0 (= 2.33.12+really2.32.4-3) but 2.34.1-2 is to be installed
                  Depends: libglib2.0-bin (= 2.33.12+really2.32.4-3) but it is not going to be installed
 libstartup-notification0-dev : Depends: libstartup-notification0 (= 0.12-1) but 0.12-2 is to be installed
E: Unable to correct problems, you have held broken packages.

To no avail...
Jed

Offline

#281 2012-11-11 21:30:10

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: Debian Netinstal Sid - Yet Another How To

Here is my sources list

#############################################################
################### OFFICIAL DEBIAN REPOS ###################
#############################################################


###### Debian Main Repos
deb http://ftp.us.debian.org/debian/ sid main contrib non-free
deb-src ftp://ftp.us.debian.org/debian/ sid main contrib non-free


##############################################################
##################### UNOFFICIAL  REPOS ######################
##############################################################


#### Debian Multimedia
deb http://www.deb-multimedia.org sid main non-free
deb http://ftp.us.debian.org/debian/ experimental main contrib non-free
deb http://ignorantguru.github.com/debian/ unstable main
deb http://mozilla.debian.net/ experimental iceweasel-aurora

# Liquorix sources added by smxi
deb http://liquorix.net/debian/ sid main

Save your sources.list

sudo cp /etc/apt/sources.list /etc/apt/sources.old

Now edit your /etc/apt/sources.list and copy in mine

Save it

sudo apt-get update

sudo apt-get dist-upgrade

Let me know if there are errors

If there are not, try this again

sudo apt-get install spacefm

Offline

#282 2012-11-11 21:35:49

jed
#! CrunchBanger
From: Detachment 7
Registered: 2012-08-28
Posts: 200
Website

Re: Debian Netinstal Sid - Yet Another How To

After sudo apt-get update

jedsdesk@jedsdesk:~$ sudo cp /etc/apt/sources.list /etc/apt/sources.old
[1]+  Done                    conky -c ~/conkyJed/.conky/time
jedsdesk@jedsdesk:~$ sudo medit /etc/apt/sources.list
jedsdesk@jedsdesk:~$ sudo apt-get update
Hit http://ignorantguru.github.com unstable InRelease
Hit http://ignorantguru.github.com unstable/main amd64 Packages                                    
Hit http://liquorix.net sid InRelease                                                              
Hit http://www.deb-multimedia.org sid InRelease                                                    
Hit http://liquorix.net sid/main amd64 Packages                                                    
Hit http://ftp.us.debian.org sid InRelease                                                         
Get:1 http://ftp.us.debian.org experimental InRelease [162 kB]                                     
Ign http://mozilla.debian.net experimental InRelease                                               
Hit http://www.deb-multimedia.org sid/main amd64 Packages/DiffIndex                                
Hit http://mozilla.debian.net experimental Release.gpg                                     
Hit http://www.deb-multimedia.org sid/non-free amd64 Packages/DiffIndex                    
Hit ftp://ftp.us.debian.org sid InRelease                                               
Ign http://ignorantguru.github.com unstable/main Translation-en_US                                 
Hit http://mozilla.debian.net experimental Release                                                 
Ign http://ignorantguru.github.com unstable/main Translation-en                                    
Hit ftp://ftp.us.debian.org sid/main Sources/DiffIndex                                             
Hit http://mozilla.debian.net experimental/iceweasel-aurora amd64 Packages                         
Hit http://ftp.us.debian.org sid/main amd64 Packages/DiffIndex                                     
Hit http://ftp.us.debian.org sid/contrib amd64 Packages/DiffIndex                                  
Hit http://ftp.us.debian.org sid/non-free amd64 Packages/DiffIndex            
Get:2 http://ftp.us.debian.org sid/contrib Translation-en [36.9 kB]           
Hit ftp://ftp.us.debian.org sid/contrib Sources/DiffIndex                     
Get:3 http://ftp.us.debian.org sid/main Translation-en [4,070 kB]                                  
Hit ftp://ftp.us.debian.org sid/non-free Sources/DiffIndex                                         
Ign http://liquorix.net sid/main Translation-en_US                                                 
Ign http://liquorix.net sid/main Translation-en                                                    
Ign http://mozilla.debian.net experimental/iceweasel-aurora Translation-en_US        
Ign http://mozilla.debian.net experimental/iceweasel-aurora Translation-en           
Ign http://www.deb-multimedia.org sid/main Translation-en_US    
Ign http://www.deb-multimedia.org sid/main Translation-en       
Ign http://www.deb-multimedia.org sid/non-free Translation-en_US
Ign http://www.deb-multimedia.org sid/non-free Translation-en
Get:4 http://ftp.us.debian.org sid/non-free Translation-en [71.5 kB]                               
Get:5 http://ftp.us.debian.org experimental/main amd64 Packages [916 kB]                           
Get:6 http://ftp.us.debian.org experimental/contrib amd64 Packages [6,931 B]                       
Get:7 http://ftp.us.debian.org experimental/non-free amd64 Packages [15.9 kB]                      
Get:8 http://ftp.us.debian.org experimental/contrib Translation-en [5,707 B]                       
Get:9 http://ftp.us.debian.org experimental/main Translation-en [503 kB]                           
Get:10 http://ftp.us.debian.org experimental/non-free Translation-en [10.6 kB]                     
Fetched 5,798 kB in 9s (635 kB/s)                                                                  
W: Failed to fetch bzip2:/var/lib/apt/lists/partial/ftp.us.debian.org_debian_dists_sid_contrib_i18n_Translation-en  Hash Sum mismatch

W: Failed to fetch bzip2:/var/lib/apt/lists/partial/ftp.us.debian.org_debian_dists_sid_main_i18n_Translation-en  Hash Sum mismatch

W: Failed to fetch bzip2:/var/lib/apt/lists/partial/ftp.us.debian.org_debian_dists_sid_non-free_i18n_Translation-en  Hash Sum mismatch

W: Failed to fetch bzip2:/var/lib/apt/lists/partial/ftp.us.debian.org_debian_dists_experimental_main_i18n_Translation-en  Hash Sum mismatch

W: Failed to fetch bzip2:/var/lib/apt/lists/partial/ftp.us.debian.org_debian_dists_experimental_non-free_i18n_Translation-en  Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.

After sudo apt-get dist-upgrade

jedsdesk@jedsdesk:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

After sudo apt-get install spacefm

jedsdesk@jedsdesk:~$ sudo apt-get install spacefm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 spacefm : PreDepends: libgtk2.0-dev (>= 2.18) but it is not going to be installed
           PreDepends: libglib2.0-dev but it is not going to be installed
           PreDepends: libstartup-notification0-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Things that make you go hmmmmmmm....
Jed

Offline

#283 2012-11-11 21:38:27

jed
#! CrunchBanger
From: Detachment 7
Registered: 2012-08-28
Posts: 200
Website

Re: Debian Netinstal Sid - Yet Another How To

And just for good measure...

jedsdesk@jedsdesk:~$ sudo apt-get install libgtk2.0-dev libglib2.0-dev libstartup-notification0-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libglib2.0-dev : Depends: libglib2.0-0 (= 2.33.12+really2.32.4-3) but 2.34.1-2 is to be installed
                  Depends: libglib2.0-bin (= 2.33.12+really2.32.4-3) but it is not going to be installed
 libstartup-notification0-dev : Depends: libstartup-notification0 (= 0.12-1) but 0.12-2 is to be installed
E: Unable to correct problems, you have held broken packages.

No joy...

Jed

Offline

#284 2012-11-11 21:39:43

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: Debian Netinstal Sid - Yet Another How To

 11 Nov 12 | 18:21:36 ~
         $ apt-cache policy xfce4-screenshooter
xfce4-screenshooter:
  Installed: 1.8.1-1+b1
  Candidate: 1.8.1-1+b1
  Version table:
 *** 1.8.1-1+b1 0
        500 http://ftp.us.debian.org/debian/ sid/main amd64 Packages
        100 /var/lib/dpkg/status

 11 Nov 12 | 18:21:41 ~
         $

Last edited by Sector11 (2012-11-11 21:41:00)

Offline

#285 2012-11-11 21:40:58

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: Debian Netinstal Sid - Yet Another How To

The apt-get update needs to work before apt-get dist-upgrade

keep running until the errors clear

Offline

#286 2012-11-11 21:45:20

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: Debian Netinstal Sid - Yet Another How To

@Sector11 - Xfce4 is at 4.10, some components are still at 4.8 until Wheezy is released.  Then debian will put Xfce 4.10 in testing and Sid

Offline

#287 2012-11-11 21:50:06

jed
#! CrunchBanger
From: Detachment 7
Registered: 2012-08-28
Posts: 200
Website

Re: Debian Netinstal Sid - Yet Another How To

Just ran the apt-get update and dist-upgrade again, this time no errors.  On the install spacefm, same thing happens;

jedsdesk@jedsdesk:~$ sudo apt-get update
Hit http://ignorantguru.github.com unstable InRelease
Hit http://liquorix.net sid InRelease                                                              
Hit http://ignorantguru.github.com unstable/main amd64 Packages                                    
Hit http://ftp.us.debian.org sid InRelease                                                         
Hit http://www.deb-multimedia.org sid InRelease                                                    
Hit http://liquorix.net sid/main amd64 Packages                                                    
Hit http://ftp.us.debian.org experimental InRelease                                                
Hit http://ftp.us.debian.org sid/main amd64 Packages/DiffIndex                                     
Hit http://ftp.us.debian.org sid/contrib amd64 Packages/DiffIndex                                  
Hit http://ftp.us.debian.org sid/non-free amd64 Packages/DiffIndex                
Get:1 http://ftp.us.debian.org sid/contrib Translation-en [37.1 kB]               
Get:2 http://ftp.us.debian.org sid/main Translation-en [4,066 kB]                 
Hit http://www.deb-multimedia.org sid/main amd64 Packages/DiffIndex               
Ign http://mozilla.debian.net experimental InRelease                              
Hit ftp://ftp.us.debian.org sid InRelease                                                          
Hit http://www.deb-multimedia.org sid/non-free amd64 Packages/DiffIndex                            
Hit http://mozilla.debian.net experimental Release.gpg                                             
Hit ftp://ftp.us.debian.org sid/main Sources/DiffIndex                                      
Hit http://mozilla.debian.net experimental Release                                                 
Hit ftp://ftp.us.debian.org sid/contrib Sources/DiffIndex                                          
Hit http://mozilla.debian.net experimental/iceweasel-aurora amd64 Packages                         
Ign http://ignorantguru.github.com unstable/main Translation-en_US                                 
Hit ftp://ftp.us.debian.org sid/non-free Sources/DiffIndex                                         
Ign http://ignorantguru.github.com unstable/main Translation-en                                    
Ign http://liquorix.net sid/main Translation-en_US                                                 
Ign http://liquorix.net sid/main Translation-en                                                    
Ign http://mozilla.debian.net experimental/iceweasel-aurora Translation-en_US           
Ign http://mozilla.debian.net experimental/iceweasel-aurora Translation-en              
Ign http://www.deb-multimedia.org sid/main Translation-en_US      
Ign http://www.deb-multimedia.org sid/main Translation-en         
Ign http://www.deb-multimedia.org sid/non-free Translation-en_US
Get:3 http://ftp.us.debian.org sid/non-free Translation-en [71.3 kB]         
Ign http://www.deb-multimedia.org sid/non-free Translation-en                               
Get:4 http://ftp.us.debian.org experimental/main amd64 Packages/DiffIndex [7,819 B]         
Get:5 http://ftp.us.debian.org experimental/contrib amd64 Packages/DiffIndex [5,749 B]
Get:6 http://ftp.us.debian.org experimental/non-free amd64 Packages/DiffIndex [6,853 B]
Get:7 http://ftp.us.debian.org experimental/contrib Translation-en/DiffIndex [2,161 B]
Get:8 http://ftp.us.debian.org experimental/main Translation-en [497 kB]
Get:9 http://ftp.us.debian.org experimental/non-free Translation-en [10.3 kB]                      
Hit http://ftp.us.debian.org experimental/non-free amd64 Packages                                  
Fetched 4,705 kB in 6s (754 kB/s)                                                                  
Reading package lists... Done
jedsdesk@jedsdesk:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
jedsdesk@jedsdesk:~$ sudo apt-get install spacefm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 spacefm : PreDepends: libgtk2.0-dev (>= 2.18) but it is not going to be installed
           PreDepends: libglib2.0-dev but it is not going to be installed
           PreDepends: libstartup-notification0-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
jedsdesk@jedsdesk:~$ sudo apt-get install libgtk2.0-dev libglib2.0-dev libstartup-notification0-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libglib2.0-dev : Depends: libglib2.0-0 (= 2.33.12+really2.32.4-3) but 2.34.1-2 is to be installed
                  Depends: libglib2.0-bin (= 2.33.12+really2.32.4-3) but it is not going to be installed
 libstartup-notification0-dev : Depends: libstartup-notification0 (= 0.12-1) but 0.12-2 is to be installed
E: Unable to correct problems, you have held broken packages.

Hey Sector11.  Welcome to my nightmare!  devil  Been going at this in some form or fashion for the last 19 hours!  monkey   Since around 9:00p.m. ET last night! Joy Joy...

Jed

Offline

#288 2012-11-11 21:52:21

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: Debian Netinstal Sid - Yet Another How To

* I am at a loss.. Same sources same setup same everything and it all works fine for me.

Offline

#289 2012-11-11 21:55:34

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: Debian Netinstal Sid - Yet Another How To

my /etc/apt/apt.conf

# APT::Default-Release sid;

My /etc/apt/preferences

# Package: *
# Pin: release n=sid
# Pin-Priority: 500

Package: *
Pin: release n=experimental
Pin-Priority: 100

Offline

#290 2012-11-11 22:07:19

jed
#! CrunchBanger
From: Detachment 7
Registered: 2012-08-28
Posts: 200
Website

Re: Debian Netinstal Sid - Yet Another How To

I was dreading that!  Not sure where to go from here...  You ever heard that expression;  "You can't get there from here!"

VastOne your a scholar and a gentleman!  Thanks for your patience and generosity.  It's things like this that keep making the Linux community grow.  Those of us without the 'skills' that some of you have, stick around because we'd never get this kind of help with any other OS.  (IMO)

I think I mentioned that I used your script to do the 'complete' install, after the netinst part.  I thought I was breezing through just fine when I so easily got the wireless up and running!  That's called "counting your beans before their roasted"!  Towards the end of the script running, there were some errors, but they were gone before you could even get a look.

Also, I'm on pretty new hardware here.  (Dell XPS 15z bought in Feb.)  The bumblebee part went fairly smoothly once I found where to get it from.  (ominous Optimus!  Yes, it sucks!  thanks for nothing nVidia!)  After that, things started deteriorating quickly!  I'm really stubborn and hate starting over ops

Again, lots of thank-you's VastOne.  If you think of anything just holler.  I'll keep watching the thread for a while to see if there's an update...

My /etc/apt/preferences and /etc/apt/apt.conf is identical to yours!

Jed

Last edited by jed (2012-11-11 22:10:40)

Offline

#291 2012-11-11 22:19:18

jed
#! CrunchBanger
From: Detachment 7
Registered: 2012-08-28
Posts: 200
Website

Re: Debian Netinstal Sid - Yet Another How To

By the way, I'm probably most upset that conkyforecast wont install or work! hehe

Jed

Offline

#292 2012-11-11 22:37:35

Sector11
#!'er to BL'er
From: SR11 Cockpit
Registered: 2010-05-05
Posts: 15,667
Website

Re: Debian Netinstal Sid - Yet Another How To

Offline

#293 2012-11-11 22:38:36

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: Debian Netinstal Sid - Yet Another How To

Offline

#294 2012-11-11 22:39:47

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: Debian Netinstal Sid - Yet Another How To

One more try at this Jed

sudo apt-get install autotools-dev bash build-essential dbus desktop-file-utils libc6 libcairo2 libdbus-1-3 libglib2.0-0 libgtk2.0-0 libgtk2.0-bin libpango1.0-0 libx11-6 shared-mime-info intltool pkg-config libgtk2.0-dev libglib2.0-dev fakeroot libdbus-1-dev libudev0 libudev-dev

Report the results...

Offline

#295 2012-11-11 22:49:01

jed
#! CrunchBanger
From: Detachment 7
Registered: 2012-08-28
Posts: 200
Website

Re: Debian Netinstal Sid - Yet Another How To

Thanks for the effort!  Here's the results;

jedsdesk@jedsdesk:~$ sudo apt-get install autotools-dev bash build-essential dbus desktop-file-utils libc6 libcairo2 libdbus-1-3 libglib2.0-0 libgtk2.0-0 libgtk2.0-bin libpango1.0-0 libx11-6 shared-mime-info intltool pkg-config libgtk2.0-dev libglib2.0-dev fakeroot libdbus-1-dev libudev0 libudev-dev
[sudo] password for jedsdesk: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
bash is already the newest version.
libcairo2 is already the newest version.
libcairo2 set to manually installed.
dbus is already the newest version.
dbus set to manually installed.
libdbus-1-3 is already the newest version.
desktop-file-utils is already the newest version.
desktop-file-utils set to manually installed.
libc6 is already the newest version.
fakeroot is already the newest version.
fakeroot set to manually installed.
libgtk2.0-0 is already the newest version.
libgtk2.0-0 set to manually installed.
libgtk2.0-bin is already the newest version.
libgtk2.0-bin set to manually installed.
libx11-6 is already the newest version.
libx11-6 set to manually installed.
libpango1.0-0 is already the newest version.
libpango1.0-0 set to manually installed.
pkg-config is already the newest version.
pkg-config set to manually installed.
shared-mime-info is already the newest version.
shared-mime-info set to manually installed.
libudev0 is already the newest version.
libglib2.0-0 is already the newest version.
libglib2.0-0 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libglib2.0-dev : Depends: libglib2.0-0 (= 2.33.12+really2.32.4-3) but 2.34.1-2 is to be installed
                  Depends: libglib2.0-bin (= 2.33.12+really2.32.4-3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Still no love!  Very weird...

Grabbing the iso now...

Jed

Last edited by jed (2012-11-11 22:52:50)

Offline

#296 2012-11-12 03:46:20

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,432

Re: Debian Netinstal Sid - Yet Another How To

Now, how about removing two repos more that are third party repos?

deb http://ignorantguru.github.com/debian/ unstable main
deb http://suwako.nomanga.net/debian sid main contrib

Maybe they make problems? Also, you had quite a mix in your sources list, not a good starting point but VastOne fixed already some of the things.

Edit: But I now see you need Ignorant Guru's repo for SpaceFM, then just ignore this but something got borked in the process, seems like dependency hell to me.

Last edited by ivanovnegro (2012-11-12 03:50:01)

Offline

#297 2012-11-12 06:28:16

buri
Member
Registered: 2012-05-30
Posts: 23

Re: Debian Netinstal Sid - Yet Another How To

deb http://ftp.spline.de/pub/siduction/xfcenext unstable main

Archbang x86
Very very poor english

Offline

#298 2012-11-12 06:56:34

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: Debian Netinstal Sid - Yet Another How To

^ Aye, we are all aware of that one..  This was an exercise in seeing what was borked on one system and not another...

Thanks

Offline

#299 2012-11-12 11:07:52

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: Debian Netinstal Sid - Yet Another How To

@Jed

Try debugging 'apt-get dist-upgrade', by
(1) Creating the file /etc/apt/apt.config.d/03debug as root, with your favorite editor
(2) Put these 2 lines into that file:

APT::Debug::pkgProblemResolver "true";
APT::Debug::pkgProblemResolver::ShowScore "true";

(3) run dist-upgrade as follows:

sudo apt-get dist-upgrade 2>&1 | tee dist-upgrade.debug

(4) Post the content of file dist-upgrade.debug in the forum

Offline

Be excellent to each other!

#300 2012-11-12 22:46:03

jed
#! CrunchBanger
From: Detachment 7
Registered: 2012-08-28
Posts: 200
Website

Re: Debian Netinstal Sid - Yet Another How To

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: bleh

Debian Logo