SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2012-02-14 21:02:25

saneks
#! Die Hard
Registered: 2009-10-01
Posts: 1,020

help, dual boot install messed up win7. nothing boots

february 2012 backports 64 bit version - I thought it was easy as always but the cruchbang installer told me something like "the disk is not clean, continue installing?" - formatted the spare partition to ext4 before with geparted. cleaned it anyway again and told the installer to format it, strange, never had that before:

installer, both graphical or text will dump me into the menu with the install steps (some items say "false") and wont finish the installation. naturally, no grub is installed (or LILO - actually the menue does not mention grub but also lilo would not install.

couldnt get nowhere there, so I restarted the system and nothing boots. no crunchbang and no windows7. I restarted with a mint cd to rescue the data, before I try anything.

right now doing a backup of the user data, which is still there. luckily. but what is broken? it only tells me "insert boot device" - I wonder if installing linux and thus having grub migh help finding windows again? but how whe the istaller does not work?  - I searched the forum for MBR issues,  but found only old threads with vista or xp involved and this more recent one: http://crunchbanglinux.org/forums/topic … r-problem/

but before I start messing around: i am confused: is grub or lillo used in the latest release?

Last edited by saneks (2012-02-14 21:04:36)


eee701 user & other lap/desktops

Offline

Help fund CrunchBang, donate to the project!

#2 2012-02-14 21:27:32

tmillic
#! CrunchBanger
From: Fayetteville - Tucson
Registered: 2011-04-25
Posts: 217

Re: help, dual boot install messed up win7. nothing boots

Have you tried checking the boot flags on partitions using gparted on a live disk?
You can update the MBR for Windows 7 the same way you do for XP. I'm pretty sure I've done it using an XP disk even as a last-ditch attempt - and it worked (for the windows 7 install at least).

Offline

#3 2012-02-14 21:37:56

Matt
Member
Registered: 2012-01-19
Posts: 11

Re: help, dual boot install messed up win7. nothing boots

I had a similar sort of thing when I first installed #!, where the installation said the disk had data on it (though I had only just created the partition).

I think my disk was corrupted. I re-downloaded the image on another computer and burnt a new disc and the install went fine.

The boot flag had been removed from the windows partition, but that was simple to replace with gparted. That would be easy to do from the mint cd if you need to get to it.. Also, the boot for windows had gone screwy (something about winload.exe being corrupted) so I had to boot into my vista recovery disk and repair it

I then updated grub (can't remember the exact command now, something like update-grub), and now it seems to be fixed. I still got some errors from gparted whenever I ran it about not being able to mount partitions, but they seem to have disappeared recently (no idea why, may have been an upgrade I did).

There was a lot of other things I tried as well, but I think those were the ones that worked for me. I never actually lost anything.

Last edited by Matt (2012-02-14 21:38:36)

Offline

#4 2012-02-14 21:48:23

thevdude
#! Junkie
From: Pittsburgh, PA
Registered: 2011-09-01
Posts: 469

Re: help, dual boot install messed up win7. nothing boots

first thing to do is repair the win7 MBR, then focus on trying to get grub and linux on there.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo