SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2011-10-30 13:56:54

dubois
The Old Codger
From: Missoula, Montana
Registered: 2010-09-03
Posts: 2,238

HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

If you want to use notify-osd add this DEB file  https://launchpad.net/~leolik/+archive/ … 3_i386.deb  which works without issues in Debian Squeeze.  I prefer right-clicking the DEB and letting gdebi do the rest.  This  https://launchpad.net/~leolik/+archive/ … _amd64.deb  should work for AMD64 systems. 

Run this in terminal

gconftool-2 -s /apps/notify-osd/gravity --type=int [number]

where [number] is
1 - top-right corner
2 - middle-right
3 - bottom-right corner
4 - bottom-left corner
5 - middle-left
6 - top-left corner

Run this in terminal to verify

notify-send test

If you choose you can edit your /home/username/.notify-osd file which is a #! default, especially such items as
bubble-expire-timeout -- shortens or lengthens on-screen timeout to suit your needs
bubble-background-color -- change to match or contrast your current theme
bubble-background-opacity -- make it more translucent, or not

Leave this as is
slot-allocaction = fixed
as it will keep your notify-osd from sitting on the bottom of the screen, instead it leaves a bit of space to the right and just below itself

And this can be added
bubble-prevent-fade = 0
which allows it to fade away, whereas changing it to = 1 causes it to blink off at end of time previously set in bubble-expire-timeout

EDIT [MODIFIED] ON 20120326 -- If this how to doesn't work as expected, please delete notification-deamon in Gnome.  That seemed to keep the bubble locked in the upper-right corner preventing it from being moved by first code command, above and it keeps the new notify-osd from utilizing its own notification bubble which better suits crunchbang's statler interface.

If you're using this How To in CrunchBang 10 or a full-blown Debian install then libnotify1 and libnotify-bin are no doubt already installed, however if you're building up from a netinst like I was, you'll most likely need to add these libraries.  smile

LIST OF SOURCES
https://launchpad.net/~leolik/+archive/leolik
http://www.webupd8.org/2010/05/finally- … otify.html
http://www.webupd8.org/2010/07/patched- … on-to.html

NOTE TO USERS
I don't use Ubuntu as an OS.  If I ever did in the past I certainly don't remember it.  I know the risks of mixing codes from different operating systems but this DEB is self-contained and doesn't pull in any dependencies.   I've tested this on my ASUS 1015PEM 2GB running Debian Squeeze Xfce netinst, both 32bit and 64bit, where it works real fine.  wink

Last edited by dubois (2012-03-26 21:56:26)

Offline

Help fund CrunchBang, donate to the project!

#2 2011-10-30 14:11:17

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

jean@xaos52:~/downloads$ sudo dpkg -i notify-osd_0.9.32-0ubuntu3-leolik~ppa1_i386.deb
Selecting previously deselected package notify-osd.
(Reading database ... 138154 files and directories currently installed.)
Unpacking notify-osd (from notify-osd_0.9.32-0ubuntu3-leolik~ppa1_i386.deb) ...
dpkg: dependency problems prevent configuration of notify-osd:
notify-osd depends on libcairo2 (>= 1.10.0); however:
  Version of libcairo2 on system is 1.8.10-6.
notify-osd depends on libgdk-pixbuf2.0-0 (>= 2.22.0); however:
  Package libgdk-pixbuf2.0-0 is not installed.
notify-osd depends on libglib2.0-0 (>= 2.26.0); however:
  Version of libglib2.0-0 on system is 2.24.2-1.
notify-osd depends on libgtk-3-0 (>= 3.1.6); however:
  Package libgtk-3-0 is not installed.
notify-osd depends on libwnck-3-0 (>= 2.91.6); however:
  Package libwnck-3-0 is not installed.
notify-osd depends on dconf-gsettings-backend | gsettings-backend; however:
  Package dconf-gsettings-backend is not installed.
  Package gsettings-backend is not installed.
dpkg: error processing notify-osd (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
notify-osd
j

... is what I get on a #! OB-system upgraded to backports.

Edit

jean@xaos52:~/downloads$ sudo gdebi notify-osd_0.9.32-0ubuntu3-leolik~ppa1_i386.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Building data structures... Done
Building data structures... Done
This package is uninstallable
Dependency is not satisfiable: libcairo2 (>= 1.10.0)

... is what gdebi says.

Last edited by xaos52 (2011-10-30 14:15:44)

Offline

#3 2011-10-30 14:17:22

dubois
The Old Codger
From: Missoula, Montana
Registered: 2010-09-03
Posts: 2,238

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

^ I don't use nor know about using backports or helping those who do, however perhaps someone else does...  The link works fine in Debian Squeeze as advertised in title.  smile


EDIT  -- I see your edit.  Can you force the application in either terminal or synaptic?

Last edited by dubois (2011-10-30 14:19:37)

Offline

#4 2011-10-30 14:21:33

dubois
The Old Codger
From: Missoula, Montana
Registered: 2010-09-03
Posts: 2,238

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

You're correct.  The link I posted is invalid for stable.  Please allow me to fix it...

Last edited by dubois (2011-10-30 20:49:13)

Offline

#5 2011-10-30 14:22:23

HMW
#! CrunchBanger
From: Sweden
Registered: 2011-10-09
Posts: 199

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

Thanks dubois! I have been annoyed at the long time the ”bubbles” appear, I don't need ten seconds to read ”You are connected to network so-and-so”. I changed the value to three seconds, which is quite long enough in my opinion.

Again, thanks for the information.

HMW

Offline

#6 2011-10-30 14:29:37

dubois
The Old Codger
From: Missoula, Montana
Registered: 2010-09-03
Posts: 2,238

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

dubois wrote:

You're correct.  The link I posted is invalid for stable.  Please allow me to fix it...

<doh>  I believe that the links are correct for Debian Squeeze [stable] for both i386 and AMD64 systems.  Apologies for any confusion.  hmm


EDIT -- The link never was broken but it was invalid for the stable release.

Last edited by dubois (2011-10-30 20:56:20)

Offline

#7 2011-10-30 14:33:52

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

Nice How To dubois...  Well done


VSIDO | Words That Build Or Destroy

I dev VSIDO

Offline

#8 2011-10-30 14:39:20

dubois
The Old Codger
From: Missoula, Montana
Registered: 2010-09-03
Posts: 2,238

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

VastOne wrote:

Nice How To dubois...  Well done

Thanks.  From you that's a compliment.  smile

HMW, you're right.  I mean, how long do you need or not need to be notified of something that you know inside out like your personal OS.

Offline

#9 2011-10-30 15:17:02

rhowaldt
#!*$%:)
Registered: 2011-03-09
Posts: 4,396

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

nice how-to dubois. for an alternative to notify-osd, check out twmn, as discussed here: http://crunchbanglinux.org/forums/topic/15684/twmn/

Offline

#10 2011-10-30 16:08:36

dubois
The Old Codger
From: Missoula, Montana
Registered: 2010-09-03
Posts: 2,238

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

^Thanks.  I saw that earlier this morning.  wink

Offline

#11 2011-11-04 23:55:56

dubois
The Old Codger
From: Missoula, Montana
Registered: 2010-09-03
Posts: 2,238

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

Belated Edit

I noticed today after installing Debian Squeeze netinst 64bit on my 1015PEM [again] that the link I'd posted for 64bit systems didn't work as expected. It installed but didn't work.  After a bit of research I realized that Gnome's notification-daemon had to be removed via terminal or synaptic in order to get the desired results.  That seemed to keep the bubble locked in the upper-right corner preventing it from being moved by first code command.

My apologies for failing to mention this in my original post, which I've edited.  sad

Last edited by dubois (2011-11-05 00:03:38)

Offline

#12 2011-11-05 00:00:08

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

dubois wrote:

Belated Edit

I noticed today after installing Debian Squeeze netinst 64bit on my 1015PEM [again] that the link I'd posted for 64bit systems didn't work as expected. It installed but didn't work.  After a bit of research I realized that Gnome's notification-daemon had to be removed via terminal or synaptic in order to get the desired results.

My apologies for failing to mention this in my original post, which I've edited.  sad


Nice catch... It's always good when YOU find it first...


VSIDO | Words That Build Or Destroy

I dev VSIDO

Offline

#13 2011-11-20 22:54:54

PurpleApple
New Member
Registered: 2011-05-19
Posts: 3

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

Hello People,

I have a question, namely I'd like to set it up so that it dose not disappear on hover, but that it stays and instead, when I click on it, it disappears ot after the set period of time.

Is that possible?

PurpleApple aka Kai

Offline

#14 2011-11-21 01:22:16

dubois
The Old Codger
From: Missoula, Montana
Registered: 2010-09-03
Posts: 2,238

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

Hello, PurpleApple.  That's a good question.  I've just spent several minutes changing some of the settings in .notify-osd but couldn't find anything to help you -- the way this is set up on my system it doesn't have a means to click it off.  Does your notification bubble have an x to click it off, or not, or is this a feature you'd like to have?  I'll certainly invite anyone else to weigh in with a solution.

Offline

#15 2011-12-06 15:14:08

dubois
The Old Codger
From: Missoula, Montana
Registered: 2010-09-03
Posts: 2,238

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

dubois wrote:

Hello, PurpleApple.  That's a good question.  I've just spent several minutes changing some of the settings in .notify-osd but couldn't find anything to help you -- the way this is set up on my system it doesn't have a means to click it off.  Does your notification bubble have an x to click it off, or not, or is this a feature you'd like to have?  I'll certainly invite anyone else to weigh in with a solution.

The newest release from Ubuntu, Oneiric, has this as a feature, so you may want to check the PPA in my original post and select that option.

I'm now running Debian Sid without notify-osd so can't check whether this works, or not.  Best of luck to you.  smile


EDIT -- I'm going to edit this post rather than bumping the thread but in answer to the question put to me recently another option would be

bubble-close-on-click = 1

SEE LIST OF SOURCES, first entry, scroll down to near bottom of page -- it's been there all along.  smile

NOTE -- apparently this HOW TO doesn't work as written in Debian sid, having just tested it with the newest DEB from leolik's PPA.  I'm leaving it as is for squeeze as it's still got a decent life in front of it.  Bye!

Last edited by dubois (2011-12-11 18:52:46)

Offline

#16 2012-01-20 03:26:26

kri5
#! Die Hard
From: L.G.C. UK
Registered: 2011-11-10
Posts: 568

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

dubois:

If you want to use notify-osd add this DEB file  https://launchpad.net/~leolik/+archive/ … 3_i386.deb  which works without issues in Debian Squeeze.  I prefer right-clicking the DEB and letting gdebi do the rest.  This  https://launchpad.net/~leolik/+archive/ … _amd64.deb  should work for AMD64 systems.

The 'Notify-OSD' in the link is already installed on #! (I'm running #! Statler 32bit, November 2011 ISO)

dubois:

Run this in terminal to verify

notify-send test

This just results in:

kris@kris-inspiron-1720:~$ notify-send test
bash: notify-send: command not found
kris@kris-inspiron-1720:~$ 

dubois:

If you choose you can edit your /home/username/.notify-osd file which is a #! default,

There doesn't appear to be such a file or at least if i enter the command in terminal to edit the file it just opens up a blank/empty text file, presumably because it just created it.

However saying all that after running the command:

gconftool-2 -s /apps/notify-osd/gravity --type=int 3

I initially thought it didn't work but after a re-boot I noticed that it had indeed changed to the bottom right corner, so job done:D

Last edited by kri5 (2012-01-20 22:56:32)


#! Waldorf - 64bit - Xfce

Offline

#17 2012-01-20 16:35:59

dubois
The Old Codger
From: Missoula, Montana
Registered: 2010-09-03
Posts: 2,238

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

Oh.  It works?  I mean, um, it works!  wink

Offline

#18 2012-01-20 17:29:17

dubois
The Old Codger
From: Missoula, Montana
Registered: 2010-09-03
Posts: 2,238

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

kri5 could you, would you please indicate which version of #! you're using as it'd be a real help for someone with a similar setup looking for help?  Thanks.  smile

Offline

#19 2012-01-20 19:27:56

kri5
#! Die Hard
From: L.G.C. UK
Registered: 2011-11-10
Posts: 568

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

dubois wrote:

kri5 could you, would you please indicate which version of #! you're using as it'd be a real help for someone with a similar setup looking for help?  Thanks.  smile

I'm sure there's a command for the terminal that will give me the precise version I have installed, unfortunately I'm not sure what it is.  I'm running CrunchBang Statler,the November 2011 ISO.

Hope that helps, I have edited my previous post to reflect this also.

Last edited by kri5 (2012-01-20 19:30:36)


#! Waldorf - 64bit - Xfce

Offline

#20 2012-01-20 22:14:07

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 13,970

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

^ 32- or 64-bit?

Offline

#21 2012-01-20 22:55:47

kri5
#! Die Hard
From: L.G.C. UK
Registered: 2011-11-10
Posts: 568

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

^ Sorry, 32bit.

(starting to see a trend here, oh well another edit:lol:)


#! Waldorf - 64bit - Xfce

Offline

#22 2012-01-20 23:07:38

dubois
The Old Codger
From: Missoula, Montana
Registered: 2010-09-03
Posts: 2,238

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

nm.  I was reading posts out of order.  My Bad.  roll

Last edited by dubois (2012-01-21 00:00:38)

Offline

#23 2012-03-25 20:40:29

Erasmus
Member
From: Inside the Network
Registered: 2012-03-25
Posts: 20
Website

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

Hey there @Dubois!

Wanted to let you know your little tutorial on d/l 'ing the PPA version of  "notify-osd"
and the configuration tips for position worked Great!!! I didn't like having my beautiful
Conky display covered up by notifications, as cool as some of them are! I do like cb-fortunes
a lot, but not on top of Conky, please! Now I can put the notifications off to the side!

Thanks again Dubois!  ;^)

Erasmus


"This  project  will   require  drinking  a  great  deal  of  tea!"

Offline

#24 2012-03-25 20:58:40

dubois
The Old Codger
From: Missoula, Montana
Registered: 2010-09-03
Posts: 2,238

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

^
You're welcome.  Now scoot over to Introductions and let everyone know all about you.  wink

Offline

Be excellent to each other!

#25 2012-03-25 21:07:35

Erasmus
Member
From: Inside the Network
Registered: 2012-03-25
Posts: 20
Website

Re: HOW TO Set Up Notify-OSD in Debian Squeeze [Stable]

Okay, will do that Soon, I was registered under another account at one time, so I Am a real  #!'er !!!


"This  project  will   require  drinking  a  great  deal  of  tea!"

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo