SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2011-09-28 18:46:54

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

SOLVED - mpd client can't connect (timeout)

I've been trying to get mpd to work properly for two days now. Followed the #! HowTo, consulted the Arch wiki, changed a gazillion options, but I just can't get past the last hurdle. I can get mpd to start, but the clients don't want to connect. They give me "timeout while connecting" - mpc, ncmpc and ncmpcpp.

My mpdconf is

music_directory                 "/home/elkoraco/music"
playlist_directory              "/home/elkoraco/.mpd/playlists"
db_file                         "/home/elkoraco/.mpd/db"
log_file                        "/home/elkoraco/.mpd/mpd.log"
pid_file                        "/home/elkoraco/.mpd/pid"
state_file                     "/home/elkoraco/.mpd/state"

#port "6600"

audio_output {
        type                    "alsa"
        name                    "My ALSA Device"
        device                  "hw:0,0"     # optional
}
#auto_update "yes"

There are some super weird errors. Like, the db file can't be named tag_cache, because mpd won't start in that case. Also, it doesn't want to start when I leave the auto update option uncommented. So, nvm, it starts, I run mpd --create-db, all is well, the db is created, but mpc, ncmpc, ncmpcpp don't wanna connect to it.

I stopped it from starting in /etc/default, and in the rc scripts. Still a no-go. Is this a Debian thing, or am I missing something? All the guides say this should be easy.

Last edited by el_koraco (2011-10-04 17:09:46)

Offline

Be excellent to each other!

#2 2011-09-28 23:37:25

psyco430404
#! Die Hard
From: Las Vegas, Nevada
Registered: 2011-07-04
Posts: 804

Re: SOLVED - mpd client can't connect (timeout)

http://linuxowns.wordpress.com/2008/07/ … d-locally/

I followed this tutorial to the T and its working perfectly for me.


"'If fighting is to result in victory, then you must fight'...Sun Tzu said that and id say he knows a little more about fighting then you do pal."

- TF2 Soldier

Offline

#3 2011-09-29 01:25:03

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: SOLVED - mpd client can't connect (timeout)

I used the same How To psyco430404 used and after a few MPD restarts, it did work properly...


VSIDO | Words That Build Or Destroy

I dev VSIDO

Offline

#4 2011-09-29 07:48:17

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: SOLVED - mpd client can't connect (timeout)

Perhaps because this is missing?

#
# This setting sets the address for the daemon to listen on. Careful attention
# should be paid if this is assigned to anything other then the default, any.
# This setting can deny access to control of the daemon.
#
# For network
bind_to_address        "localhost"

Offline

#5 2011-09-29 11:24:34

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: SOLVED - mpd client can't connect (timeout)

Thanks guys, but I've given up, sorry to have wasted everyone's time.

Offline

#6 2011-09-29 12:37:09

ivanovnegro
Ivan #000000
From: unstable madness
Registered: 2011-06-02
Posts: 5,432

Re: SOLVED - mpd client can't connect (timeout)

^ I know this feeling, once I wanted to set up MPD on Ubuntu to no avail. And interestingly I figured it out on Debian some weeks ago but later I changed something and could never get it running again, I even broke MPD totally. It was a mess. Anyway I tried almost all clients and was neither satisfied with them except for ncm..., you know the CLI thingy but it is just not for me.

Offline

#7 2011-09-29 12:40:35

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: SOLVED - mpd client can't connect (timeout)

ivanovnegro wrote:

^ I know this feeling, once I wanted to set up MPD on Ubuntu to no avail. And interestingly I figured it out on Debian some weeks ago but later I changed something and could never get it running again, I even broke MPD totally. It was a mess. Anyway I tried almost all clients and was neither satisfied with them except for ncm..., you know the CLI thingy but it is just not for me.

It really is too bad that both of you have had this issue.. MPD is a powerful tool with  excellent term and gui apps

on the gui side, I really like Ario and Gnome Music Player Client (GMPC) both very minimal and with GMPC, just about every tool that any other music manager has

Last edited by VastOne (2011-09-29 12:41:03)


VSIDO | Words That Build Or Destroy

I dev VSIDO

Offline

#8 2011-09-29 12:46:42

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: SOLVED - mpd client can't connect (timeout)

... could not find 'given up' in the linux dictionary smile

Offline

#9 2011-09-29 12:52:07

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: SOLVED - mpd client can't connect (timeout)

xaos52 wrote:

... could not find 'given up' in the linux dictionary smile

Well, at some point, enough is enough. I tried all the permutations of the local and global config file, symlinked, made and deleted directories and files, fiddled around with the client configs, and couldn't get anything to connect. At some point I decided to stop wasting time getting it to work, since MOC does its job like a work-horse.

Last edited by el_koraco (2011-09-29 12:52:59)

Offline

#10 2011-09-29 12:52:43

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: SOLVED - mpd client can't connect (timeout)

You must disable 'mpd' system service if you want mpd to run for your user only (e.g. start mpd from autostart.sh)

sudo update-rc.d mpd disable

Otherwise, the system service starts up and the mpd you launch from autostart.sh stops, because the mpd daemon is running already.
hth

Offline

#11 2011-09-29 12:53:52

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: SOLVED - mpd client can't connect (timeout)

xaos52 wrote:

Otherwise, the system service starts up and the mpd you launch from autostart.sh stops, because the mpd daemon is running already.
hth

That was the first thing I did.

Offline

#12 2011-09-29 12:55:52

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: SOLVED - mpd client can't connect (timeout)

xaos52 wrote:

... could not find 'given up' in the linux dictionary smile

# 1 zillion...  Well said..


VSIDO | Words That Build Or Destroy

I dev VSIDO

Offline

#13 2011-09-29 12:57:29

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: SOLVED - mpd client can't connect (timeout)

Can you start mpd now?
If yes, try strace -o trace.output <your client name>
publish trace.output

Offline

#14 2011-09-29 13:04:03

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: SOLVED - mpd client can't connect (timeout)

execve("/usr/bin/ncmpcpp", ["ncmpcpp"], [/* 34 vars */]) = 0
brk(0)                                  = 0x9d28000
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
mmap2(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb782e000
open("/usr/lib/scrotwm/libswmhack.so.0.0", O_RDONLY) = 5
read(5, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0P\7\0\0004\0\0\0"..., 512) = 512
fstat64(5, {st_mode=S_IFREG|0644, st_size=6532, ...}) = 0
mmap2(NULL, 9492, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 5, 0) = 0xb782b000
mmap2(0xb782d000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 5, 0x1) = 0xb782d000
close(5)                                = 0
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 5
fstat64(5, {st_mode=S_IFREG|0644, st_size=70852, ...}) = 0
mmap2(NULL, 70852, PROT_READ, MAP_PRIVATE, 5, 0) = 0xb7819000
close(5)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/usr/lib/libmpdclient.so.2", O_RDONLY) = 5
read(5, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\20N\0\0004\0\0\0"..., 512) = 512
fstat64(5, {st_mode=S_IFREG|0644, st_size=57612, ...}) = 0
mmap2(NULL, 60332, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 5, 0) = 0xb780a000
mmap2(0xb7818000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 5, 0xd) = 0xb7818000
close(5)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/lib/libncursesw.so.5", O_RDONLY) = 5
read(5, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\0\276\0\0004\0\0\0"..., 512) = 512
fstat64(5, {st_mode=S_IFREG|0644, st_size=282648, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7809000
mmap2(NULL, 286480, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 5, 0) = 0xb77c3000
mmap2(0xb7806000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 5, 0x42) = 0xb7806000
close(5)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/usr/lib/libfftw3.so.3", O_RDONLY) = 5
read(5, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\20\21\1\0004\0\0\0"..., 512) = 512
fstat64(5, {st_mode=S_IFREG|0644, st_size=1328896, ...}) = 0
mmap2(NULL, 1328380, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 5, 0) = 0xb767e000
mmap2(0xb77ba000, 36864, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 5, 0x13c) = 0xb77ba000
close(5)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/lib/i686/cmov/libpthread.so.0", O_RDONLY) = 5
read(5, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\20J\0\0004\0\0\0"..., 512) = 512
fstat64(5, {st_mode=S_IFREG|0755, st_size=117367, ...}) = 0
mmap2(NULL, 98784, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 5, 0) = 0xb7665000
mmap2(0xb767a000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 5, 0x14) = 0xb767a000
mmap2(0xb767c000, 4576, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0xb767c000
close(5)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/usr/lib/libcurl-gnutls.so.4", O_RDONLY) = 5
read(5, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\300\237\0\0004\0\0\0"..., 512) = 512
fstat64(5, {st_mode=S_IFREG|0644, st_size=319672, ...}) = 0
mmap2(NULL, 322876, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 5, 0) = 0xb7616000
mmap2(0xb7663000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 5, 0x4c) = 0xb7663000
close(5)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/usr/lib/libtag.so.1", O_RDONLY)  = 5
read(5, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0PN\2\0004\0\0\0"..., 512) = 512
fstat64(5, {st_mode=S_IFREG|0644, st_size=609236, ...}) = 0
mmap2(NULL, 613624, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 5, 0) = 0xb7580000
mmap2(0xb7613000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 5, 0x92) = 0xb7613000
close(5)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/usr/lib/libstdc++.so.6", O_RDONLY) = 5
read(5, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0`q\4\0004\0\0\0"..., 512) = 512
fstat64(5, {st_mode=S_IFREG|0644, st_size=975012, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb757f000
mmap2(NULL, 1000332, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 5, 0) = 0xb748a000
mmap2(0xb7573000, 20480, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 5, 0xe9) = 0xb7573000
mmap2(0xb7578000, 25484, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0xb7578000

Offline

#15 2011-09-29 13:07:06

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: SOLVED - mpd client can't connect (timeout)

And for mpc

execve("/usr/bin/mpc", ["mpc"], [/* 34 vars */]) = 0
brk(0)                                  = 0x88d2000
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
mmap2(NULL, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7731000
open("/usr/lib/scrotwm/libswmhack.so.0.0", O_RDONLY) = 5
read(5, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0P\7\0\0004\0\0\0"..., 512) = 512
fstat64(5, {st_mode=S_IFREG|0644, st_size=6532, ...}) = 0
mmap2(NULL, 9492, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 5, 0) = 0xb772e000
mmap2(0xb7730000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 5, 0x1) = 0xb7730000
close(5)                                = 0
access("/etc/ld.so.preload", R_OK)      = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 5
fstat64(5, {st_mode=S_IFREG|0644, st_size=70852, ...}) = 0
mmap2(NULL, 70852, PROT_READ, MAP_PRIVATE, 5, 0) = 0xb771c000
close(5)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/lib/i686/cmov/libnsl.so.1", O_RDONLY) = 5
read(5, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\2201\0\0004\0\0\0"..., 512) = 512
fstat64(5, {st_mode=S_IFREG|0644, st_size=79676, ...}) = 0
mmap2(NULL, 92136, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 5, 0) = 0xb7705000
mmap2(0xb7718000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 5, 0x12) = 0xb7718000
mmap2(0xb771a000, 6120, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0xb771a000
close(5)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/usr/lib/libmpdclient.so.2", O_RDONLY) = 5
read(5, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\20N\0\0004\0\0\0"..., 512) = 512
fstat64(5, {st_mode=S_IFREG|0644, st_size=57612, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7704000
mmap2(NULL, 60332, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 5, 0) = 0xb76f5000
mmap2(0xb7703000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 5, 0xd) = 0xb7703000
close(5)                                = 0
access("/etc/ld.so.nohwcap", F_OK)      = -1 ENOENT (No such file or directory)
open("/lib/i686/cmov/libc.so.6", O_RDONLY) = 5
read(5, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\320m\1\0004\0\0\0"..., 512) = 512
fstat64(5, {st_mode=S_IFREG|0755, st_size=1323460, ...}) = 0
mmap2(NULL, 1333608, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 5, 0) = 0xb75af000
mmap2(0xb76ef000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 5, 0x13f) = 0xb76ef000
mmap2(0xb76f2000, 10600, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0xb76f2000
close(5)                                = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb75ae000
set_thread_area({entry_number:-1 -> 6, base_addr:0xb75ae6c0, limit:1048575, seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0, useable:1}) = 0
mprotect(0xb76ef000, 8192, PROT_READ)   = 0
mprotect(0xb7718000, 4096, PROT_READ)   = 0
mprotect(0xb774f000, 4096, PROT_READ)   = 0
munmap(0xb771c000, 70852)               = 0
brk(0)                                  = 0x88d2000
brk(0x88f3000)                          = 0x88f3000
ioctl(1, SNDCTL_TMR_TIMEBASE or TCGETS, {B38400 opost isig icanon echo ...}) = 0
ioctl(0, SNDCTL_TMR_TIMEBASE or TCGETS, {B38400 opost isig icanon echo ...}) = 0
open("/usr/lib/locale/locale-archive", O_RDONLY|O_LARGEFILE) = 5
fstat64(5, {st_mode=S_IFREG|0644, st_size=1527584, ...}) = 0
mmap2(NULL, 1527584, PROT_READ, MAP_PRIVATE, 5, 0) = 0xb7439000
close(5)                                = 0
socket(PF_FILE, SOCK_STREAM|SOCK_CLOEXEC|SOCK_NONBLOCK, 0) = 5
connect(5, {sa_family=AF_FILE, path="/var/run/mpd/socket"}, 110) = -1 ENOENT (No such file or directory)
close(5)                                = 0
socket(PF_NETLINK, SOCK_RAW, 0)         = 5
bind(5, {sa_family=AF_NETLINK, pid=0, groups=00000000}, 12) = 0
getsockname(5, {sa_family=AF_NETLINK, pid=8290, groups=00000000}, [12]) = 0
time(NULL)                              = 1317301517
sendto(5, "\24\0\0\0\26\0\1\3\rm\204N\0\0\0\0\0\0\0\0", 20, 0, {sa_family=AF_NETLINK, pid=0, groups=00000000}, 12) = 20
recvmsg(5, {msg_name(12)={sa_family=AF_NETLINK, pid=0, groups=00000000}, msg_iov(1)=[{"<\0\0\0\24\0\2\0\rm\204Nb \0\0\2\30\200\0\3\0\0\0\10\0\1\0\300\250\1\2"..., 4096}], msg_controllen=0, msg_flags=0}, 0) = 60
recvmsg(5, {msg_name(12)={sa_family=AF_NETLINK, pid=0, groups=00000000}, msg_iov(1)=[{"@\0\0\0\24\0\2\0\rm\204Nb \0\0\n@\200\375\3\0\0\0\24\0\1\0\376\200\0\0"..., 4096}], msg_controllen=0, msg_flags=0}, 0) = 64

Offline

#16 2011-09-29 13:08:44

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: SOLVED - mpd client can't connect (timeout)

this is with the conf from the OP.

Offline

#17 2011-09-29 13:11:06

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: SOLVED - mpd client can't connect (timeout)

Can you start mpd with strace, then start mpc, then sptop mpd and post strace for mpd?

Offline

#18 2011-09-29 13:15:38

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,165
Website

Re: SOLVED - mpd client can't connect (timeout)

el_koraco wrote:

this is with the conf from the OP.


Are all the files from the conf actually there?

music_directory                 "/home/elkoraco/music"
playlist_directory              "/home/elkoraco/.mpd/playlists"
db_file                         "/home/elkoraco/.mpd/db"
log_file                        "/home/elkoraco/.mpd/mpd.log"
pid_file                        "/home/elkoraco/.mpd/pid"
state_file                     "/home/elkoraco/.mpd/state"

I know I had to create them first...

Just making sure...

Also, as I understand it,  MPD no longer uses mpd.db... and if it did this line:

db_file                         "/home/elkoraco/.mpd/db"

should be this:

db_file                         "/home/elkoraco/.mpd/mpd.db"

VSIDO | Words That Build Or Destroy

I dev VSIDO

Offline

#19 2011-09-29 13:16:36

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: SOLVED - mpd client can't connect (timeout)

Offline

#20 2011-09-29 13:18:14

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: SOLVED - mpd client can't connect (timeout)

@VastOne
Yup, all the files are there. I can remove the db file later, it shouldn't be a problem.

Offline

#21 2011-09-29 13:28:47

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: SOLVED - mpd client can't connect (timeout)

Seems ok so far.
Can you add:

user   "<your username>"

to your config file and try again

Last edited by xaos52 (2011-09-29 13:29:25)

Offline

#22 2011-09-29 13:33:52

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,602

Re: SOLVED - mpd client can't connect (timeout)

Also, can you add

## Change this (set to non-zero) to enable/disable debugging
MPD_DEBUG=true

to your /etc/default/mpd

And: forget what I said about disabling mpd daemon.

sudo update-rc.d mpd enable

Last edited by xaos52 (2011-09-29 13:34:30)

Offline

#23 2011-09-29 13:37:52

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: SOLVED - mpd client can't connect (timeout)

one more

no luck. I am running e4rat-preload as init add-on, could that have something to do with what we're seeing?

Offline

#24 2011-09-29 13:43:21

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: SOLVED - mpd client can't connect (timeout)

xaos52 wrote:

Also, can you add

## Change this (set to non-zero) to enable/disable debugging
MPD_DEBUG=true

to your /etc/default/mpd

And: forget what I said about disabling mpd daemon.

sudo update-rc.d mpd enable

ok, did that. it does't start as a service, due to config file inconsistecies. Do you want the debug line?

Offline

Be excellent to each other!

#25 2011-09-29 13:44:26

el_koraco
#!/loony/bun
From: inside Ed
Registered: 2011-07-25
Posts: 4,749

Re: SOLVED - mpd client can't connect (timeout)

## Defaults for the MPD init script, sourced by /etc/init.d/mpd on Debian
## systems.  Uncomment (remove the leading '#') and change values as needed.

## Change this to prevent MPD from being started as a system service (for
## example, if you want to run it from a regular user account)
START_MPD=true

## The configuration file location for mpd:
# MPDCONF=/etc/mpd.conf
MPD_DEBUG=true

This is my etc/default/mpd

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo