SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2011-01-17 19:00:40

SmashedGlass
#! CrunchBanger
From: Colorado Springs, Colorado USA
Registered: 2009-05-20
Posts: 238

[SOLVED]Workspace switching via keyboard question [XFCE]

I thought I had a problem though think I figured it out, but I'll go ahead and ask a question related anyhow.

On my Mint 9 Xfce install, I had noticed today that I was unable to switch spaces using CTL+ALT+pg left/right.
Was still able to from the panel and using CTL+F1/F2 etc, just not the "normal" method for me. Configs in the Window Manager->Keyboard still had CTL+ALT+pg set correctly but still no good.

Here's the thing I think I found: my panel is set vertically on the right side of the desktop; if I use CTL+ALT+up/down, I can switch. So am I correct in assuming the keyboard workspace switching is tied to how you have your panel setup? I'm used to switching workspaces Left to Right, not Upper to Lower, and this is the first time I've really used a 'vertical' panel in the three years I've used Linux.

Input/answers/sneers welcome.

Last edited by SmashedGlass (2011-01-17 22:23:37)

Offline

Help fund CrunchBang, donate to the project!

#2 2011-01-17 19:43:18

Unia
#! Octo-portal-pussy
From: The Netherlands
Registered: 2010-07-17
Posts: 4,634
Website

Re: [SOLVED]Workspace switching via keyboard question [XFCE]

Do you have a "switch workspace"-plugin on your panel? AFAIK, if the desktop are on top of each other there, they are on top of each other. If they're next to each other on the plugin, they're next to eachother.

Do you get what I'm trying to say here? (english isn't my first language so I can't get any further than that)

Offline

#3 2011-01-17 21:26:48

mynis01
#! Die Hard
From: 127.0.0.1
Registered: 2010-07-02
Posts: 2,005

Re: [SOLVED]Workspace switching via keyboard question [XFCE]

Try using grandr to adjust the positions of the monitors. Sometimes I have better luck using xrandr via command line. If that doesn't work you could always just change the hotkeys in the keyboard settings with the xfce pannel. For example, set ctrl+alt+<-- to desktop up, and ctrl+alt+--> to desktop down. That is a very unique problem you're having, it seems for whatever reason your installation set the desktops to span vertically instead of horizontally.

Offline

#4 2011-01-17 22:23:11

SmashedGlass
#! CrunchBanger
From: Colorado Springs, Colorado USA
Registered: 2009-05-20
Posts: 238

Re: [SOLVED]Workspace switching via keyboard question [XFCE]

Unia hit it on the head. I switched the columns under the panel switcher properties to '2 columns' and was able to change to CTL+ALT+pg L/R. But I didn't like the way it looked in the panel lol, so switched back to a single column. Just had to figure it out is all. Really need to start spending more time tinkering with the laptop again.

Offline

#5 2011-01-17 22:54:32

Unia
#! Octo-portal-pussy
From: The Netherlands
Registered: 2010-07-17
Posts: 4,634
Website

Re: [SOLVED]Workspace switching via keyboard question [XFCE]

Glad I could be of help! smile

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.
Server: acrobat

Debian Logo