SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-10-31 09:42:18

daz4126
#! Member
From: Manchester
Registered: 2013-04-23
Posts: 52
Website

Compositing Needs Restart on Boot

Hi,

I've just installed #! on a new laptop and everything is fine except for one slight annoyance:

When it boots up, the icons in the tint2 menu at the top are 'smudgy'. If I restart compositing then this fixes the problem straight away.

Does anybody know why this might be happening (and how to stop it) or how I could automate the 'restart compositing' on boot up?

Thanks,

DAZ

Offline

Help fund CrunchBang, donate to the project!

#2 2013-10-31 12:39:45

brontosaurusrex
#! Red Menace
Registered: 2012-06-15
Posts: 1,237

Re: Compositing Needs Restart on Boot

you could probably try increasing that "sleep 2s" in openbox autostart;

## Group start:
## 1. nitrogen - restores wallpaper
## 2. compositor - start
## 3. sleep - give compositor time to start
## 4. tint2 panel
(\
nitrogen --restore && \
cb-compositor --start && \
sleep 2s && \
tint2 \
) &

or adding

cb-compositor --restart

later on.

Last edited by brontosaurusrex (2013-10-31 12:42:01)

Offline

#3 2013-10-31 14:25:19

daz4126
#! Member
From: Manchester
Registered: 2013-04-23
Posts: 52
Website

Re: Compositing Needs Restart on Boot

Thanks Brontosaurusrex!

I added this line:

(sleep 3s && cb-compositor --restart) &

There's a very slight delay, but that's fine. Would be nice to now why it needs doing, but I can live with it!

Cheers,

DAZ

Offline

#4 2014-11-23 07:46:36

gurflob
New Member
Registered: 2014-11-23
Posts: 6

Re: Compositing Needs Restart on Boot

Same thing for me. My icons had a white background (instead of transparent) until I restart the compositor. DAZ's fix worked perfectly!

Offline

#5 2014-11-25 18:08:16

daz4126
#! Member
From: Manchester
Registered: 2013-04-23
Posts: 52
Website

Re: Compositing Needs Restart on Boot

Glad the fix worked gurflob! Wish I knew what caused it, but it doesn't cause any issues really.

DAZ

Offline

#6 2014-11-25 23:17:12

common-sense
#! CrunchBanger
Registered: 2014-09-08
Posts: 114

Re: Compositing Needs Restart on Boot

This issue is quite simple. If Tint2 is started when the compositor already is running, you can get this issue. At least with Intel hdgraphics. Your workaround, or just simply delaying the initial compositor start so that it starts after Tint2, will be fine.

But just to test. If you try to restart tint2 (settings/tint2/Restart Tint2) then the problem should reappear. You can choose to live with this, but you can solve it permanently so that you can use the default Crunchbang autostart file. Solve it like this :

As root, create a file called "20-intel.conf" in "/etc/X11/xorg.conf.d" . If the xorg.conf.d folder doesn't exist, then create it.
The content in the file should be like this:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
EndSection

Save the file and reboot. Should work with the default autostart. no need to delay or restart anything.

Offline

#7 2014-11-26 07:16:17

Head_on_a_Stick
#! Cat
From: A world of pure imagination
Registered: 2014-01-21
Posts: 2,781

Re: Compositing Needs Restart on Boot

^ If you're going to do this, I would advise also compiling the latest compton version from source as the SNA driver tears badly.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo