SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2014-05-17 12:29:36

saturdaywasokay
New Member
Registered: 2014-05-17
Posts: 2

[SOLVED] Issue with running GNU icecat 24 (GLIBC not found)

Hi there! I've been trying to get GNU icecat 24 to work and I just can't get it to.
I downloaded both icecat-24.0.tar.gz & icecat-24.0-64bit.tar.gz from http://ftp.gnu.org/gnu/gnuzilla/24/.
When exucuting

$ ./run-icecat.sh

I get

./icecat-bin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by ./icecat-bin)
./icecat-bin: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.17' not found (required by ./icecat-bin)

I tried version 17 and that works fine but i'd like to use the most recent version.

NOTE: I also tried running ./icecat & ./icecat-bin and I get the exact same error.
NOTE: I also tried running as root just to see if that would work but it didn't.

I have no idea what to do. Any help would be much appreciated!

Last edited by saturdaywasokay (2014-05-18 01:56:43)

Offline

Help fund CrunchBang, donate to the project!

#2 2014-05-17 12:37:44

Alad
#! Little Rocket Man
From: bugs.debian.org
Registered: 2014-02-20
Posts: 860
Website

Re: [SOLVED] Issue with running GNU icecat 24 (GLIBC not found)

Why Icecat? Iceweasel has the same sauce of philosophical debate, security updates (Icecat was last updated 7 months ago) and FWIW, Debian-specific patches.

But if you must use it - normally I'd say LD_LIBRARY_PATH (see signature) but with intertwined software like browsers that's hard. What's left is recompiling from source, trying the 32bit variant, or dist-upgrade to testing/sid.

Last edited by Alad (2014-05-17 12:40:04)

Offline

#3 2014-05-17 15:58:18

twoion
Emerald Caffeine
From: 星界
Registered: 2012-05-11
Posts: 551

Re: [SOLVED] Issue with running GNU icecat 24 (GLIBC not found)

IMHO using the 32bit version via multiarch would do nothing to solve the problem

Apart from Alad's suggestion to use LD_LIBRARY_PATH, which is by no means a sane way to run a program of that size, compiling Icecat might be impossible for you – it's essentially a flavour of Firefox, and Firefox needs >= 4GB of RAM to compile (think 6-12GB) (otherwise it might not compile correctly!) and a reasonably fast processor (think at least i5/i7 class) if you don't want to wait too long. It definitely takes ~30 minutes to an hour on a powerful system (definitely longer than building the kernel).

Upgrading to testing/unstable is the easiest way. Alternatively, you could create a VM using qemu-kvm or virtualbox in which you run Debian Unstable + Icecat.


Magic is real, unless declared integer.
SidLiquorixInfinalityXonoticVimSuckless

Offline

#4 2014-05-18 01:54:47

saturdaywasokay
New Member
Registered: 2014-05-17
Posts: 2

Re: [SOLVED] Issue with running GNU icecat 24 (GLIBC not found)

Thanks for the suggestions you two! I just ended up compiling it and it worked out all fine. Thank you!

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo