SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-12-13 04:09:04

JoeS
Member
Registered: 2013-10-03
Posts: 41

Trouble installing programs

I've tried to install 3 programs, but get error messages with aptitude. Can anyone sort this out?
Why doesn't Crunchbang want to install these programs?

Thanks

root@crunchbang:~# aptitude install gxine
                                
[  0%] Initializing package states       
The following NEW packages will be installed:
  gxine libfame-0.9-1{a} libmozjs185-1.0{a} libvdpau1{a} libxine2{a} libxine2-bin{a} libxine2-ffmpeg{a} libxine2-gnome{a} 
  libxine2-misc-plugins{ab} libxine2-plugins{a} libxine2-x{a} 
0 packages upgraded, 11 newly installed, 0 to remove and 4 not upgraded.
Need to get 5,235 kB of archives. After unpacking 12.2 MB will be used.
The following packages have unmet dependencies:
 libxine2-misc-plugins : Depends: libcdio10 which is a virtual package.
                         Depends: libiso9660-7 which is a virtual package.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     gxine [Not Installed]                              
2)     libxine2 [Not Installed]                           
3)     libxine2-misc-plugins [Not Installed]              
4)     libxine2-plugins [Not Installed]                   



Accept this solution? [Y/n/q/?]
root@crunchbang:~# aptitude install mplayer
The following NEW packages will be installed:
  libfaac0{a} mplayer{b} 
0 packages upgraded, 2 newly installed, 0 to remove and 4 not upgraded.
Need to get 6,667 kB of archives. After unpacking 14.8 MB will be used.
The following packages have unmet dependencies:
 mplayer : Depends: libggi2 (>= 1:2.2.2) which is a virtual package.
           Depends: libggiwmh0 (>= 0.3.2) which is a virtual package.
           Depends: libsvga1 but it is not going to be installed. or
                    svgalib-dummyg1 which is a virtual package.
           Depends: libvdpau1 (>= 0.2) but it is not going to be installed.
           Depends: libx264-122 (>= 3:0.122.2184+git5c85e0a) but it is not going to be installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     mplayer [Not Installed]                            



Accept this solution? [Y/n/q/?]
root@crunchbang:~# aptitude install dvdrip
The following NEW packages will be installed:
  dvdrip dvdrip-doc{a} fping{a} gawk{a} gocr{a} gtk2-ex-formfactory-perl{a} libanyevent-perl{a} libevent-execflow-perl{a} libevent-perl{a} 
  libevent-rpc-perl{a} libfame-0.9-1{a} libintl-perl{a} libmjpegtools-2.0-0{a} libquicktime2{a} libsigsegv2{a} libsox-fmt-alsa{a} 
  libsox-fmt-base{a} libsox2{a} libvdpau1{a} libxine2{a} libxine2-bin{a} libxine2-ffmpeg{a} libxine2-misc-plugins{ab} libxine2-plugins{a} 
  libxine2-x{a} lsdvd{a} mjpegtools{a} sox{a} subtitleripper{a} transcode{a} transcode-doc{a} transcode-utils{a} transfig{a} twolame{a} 
  xine-ui{a} 
0 packages upgraded, 35 newly installed, 0 to remove and 4 not upgraded.
Need to get 15.2 MB of archives. After unpacking 37.9 MB will be used.
The following packages have unmet dependencies:
 libxine2-misc-plugins : Depends: libcdio10 which is a virtual package.
                         Depends: libiso9660-7 which is a virtual package.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libxine2 [Not Installed]                           
2)     libxine2-misc-plugins [Not Installed]              
3)     libxine2-plugins [Not Installed]                   
4)     xine-ui [Not Installed]                            

     Leave the following dependencies unresolved:         
5)     dvdrip recommends xine-ui                          


Accept this solution? [Y/n/q/?]

Offline

Help fund CrunchBang, donate to the project!

#2 2013-12-14 09:31:48

ohnonot
#! Petunia
Registered: 2012-05-22
Posts: 1,360
Website

Re: Trouble installing programs

nothing fancy here.
there is not (yet) any error message.

each of the three ouputs you provided asks you to make a choice (press a number 1-5, or y or n, then enter).
please try all this, use common sense, and is you still don't succeed, post relevant output.

also, in your situation, i'd use

sudo apt-get install <package>

instead of aptitude.

Last edited by ohnonot (2013-12-14 09:32:19)

Offline

#3 2013-12-14 09:57:12

KrunchTime
#! Die Hard
From: Not Where I Belong
Registered: 2012-03-02
Posts: 2,019

Re: Trouble installing programs

ohnonot wrote:

also, in your situation, i'd use

sudo apt-get install <package>

instead of aptitude.

Why this suggestion?

Offline

#4 2013-12-14 10:21:07

KrunchTime
#! Die Hard
From: Not Where I Belong
Registered: 2012-03-02
Posts: 2,019

Re: Trouble installing programs

@OP...why are you trying to install mplayer?  It already comes by default with CrunchBang.  Sounds like maybe you've hosed your setup with some other package installs.

I just went through the preliminaries of installing gxine under CrunchBang 11 and I didn't get the error messages you got.  I'm beginning to think you've done something to your system.

Offline

#5 2013-12-14 10:25:24

pvsage
Internal Affairs
From: North Carolina
Registered: 2009-10-18
Posts: 12,535

Re: Trouble installing programs

Before trying anything else, I would suggest

sudo apt-get update

and watch for error messages, specifically any messages regarding trouble connecting to a repo.


I'm a moderator here.  How are we doing?  Feedback is encouraged.

Offline

#6 2013-12-15 01:17:47

ew
#! Die Hard
Registered: 2012-09-27
Posts: 1,975

Re: Trouble installing programs

KrunchTime wrote:

@OP...why are you trying to install mplayer?  It already comes by default with CrunchBang.  Sounds like maybe you've hosed your setup with some other package installs.

I just went through the preliminaries of installing gxine under CrunchBang 11 and I didn't get the error messages you got.  I'm beginning to think you've done something to your system.

Nope, VLC comes with Crunchbang. Corenominal reintroduced it in his updated iso`s, by popular demand. So I guess someone whined about it, and got their will. No MPlayer in the latest iso`s.


- apt-mark hold account

Offline

#7 2013-12-15 01:43:25

ew
#! Die Hard
Registered: 2012-09-27
Posts: 1,975

Re: Trouble installing programs

What do you have in your sources.list? Let`s take you gxine issue, just to test if this will help you.

I assume that you are on Wheezy(stable), as you are posting in the stable-section.

Download one of these packages, depending on your architecture:
gxine wheezy 64-bit         gxine wheezy 32-bit

When downloaded, open it with GDEBI and install the package.

The same with these:
mplayer wheezy 64-bit      mplaayer wheezy 32-bit


dvdrip squeeze multimedia 64-bit      dvdrip squeeze multimedia 32-bit

Last edited by ew (2013-12-15 02:04:29)


- apt-mark hold account

Offline

#8 2013-12-15 06:22:31

KrunchTime
#! Die Hard
From: Not Where I Belong
Registered: 2012-03-02
Posts: 2,019

Re: Trouble installing programs

ew wrote:
KrunchTime wrote:

@OP...why are you trying to install mplayer?  It already comes by default with CrunchBang.  Sounds like maybe you've hosed your setup with some other package installs.

I just went through the preliminaries of installing gxine under CrunchBang 11 and I didn't get the error messages you got.  I'm beginning to think you've done something to your system.

Nope, VLC comes with Crunchbang. Corenominal reintroduced it in his updated iso`s, by popular demand. So I guess someone whined about it, and got their will. No MPlayer in the latest iso`s.

You may be right.  Now that I think about it, mplayer may have been pulled in by my installation of another player.

Offline

#9 2013-12-18 05:04:24

JoeS
Member
Registered: 2013-10-03
Posts: 41

Re: Trouble installing programs

ew wrote:

What do you have in your sources.list?

root@crunchbang:~# cat /etc/apt/sources.list
## CRUNCHBANG
## Compatible with Debian Wheezy, but use at your own risk.
deb http://packages.crunchbang.org/waldorf waldorf main
#deb-src http://packages.crunchbang.org/waldorf waldorf main

## DEBIAN
deb http://ftp.ca.debian.org/debian wheezy main contrib non-free
#deb-src http://ftp.ca.debian.org/debian wheezy main contrib non-free

## DEBIAN SECURITY
deb http://security.debian.org/ wheezy/updates main
#deb-src http://security.debian.org/ wheezy/updates main

## Third Parties Repos
# Debian Multimedia
deb http://www.las.ic.unicamp.br/pub/debian-multimedia/ wheezy main non-free

I installed the above packages which seemed to install OK, but couldn't install gxine:

root@crunchbang:~# gdebi /home/joe/downloads/packages/gxine_0.5.907-2+deb7u1_amd64.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Building data structures... Done
Building data structures... Done
This package is uninstallable
Cannot install 'libxine2'

dvdrip complained when I checked the settings:

STDIN player command: xine not found : NOT Ok
rar command (for vobsub compression): rar-2.80 not found : NOT Ok

Why couldn't aptitude install the other packages. Can I fix this?

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo