SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-03-06 16:27:55

Uchimata
Member
Registered: 2013-03-04
Posts: 20

Conky at startup?

Hello,

I am not usinc #!, but I was told this community would be willing to help out regardless! smile

I am using Mint 14 xfce and am having a bit of trouble with Conky. I'm trying to get Conky to open at startup, but can't figure out how. I used a Conky Lua script and originally ran the command: "conky -c ./.conky/conkyrc" to run it. I put that command in the startup app list, but it didn't start.

Also, if I just put in "Conky" in the terminal, the default Conky starts instead of the one I downloaded. Any help?

Offline

Be excellent to each other!

#2 2013-03-06 17:15:05

sevensage
#! CrunchBanger
Registered: 2012-11-10
Posts: 134

Re: Conky at startup?

conky -c ./.conky/conkyrc or conky -c ~/.conky/conkyrc


dig +short txt crunchbang.wp.dg.cx

Offline

#3 2013-03-06 17:54:56

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,163
Website

Re: Conky at startup?

conky -c ~/.conky/conkyrc would be correct IF the file conkyrc is in the directory /home/username/.conky directory

Perhaps the best thing to do is have conkyrc (or .conkyrc) or whatever the file name is in ~/ (this is a shortcut of /home/username) have it in startup as

conky -c ~/conkyrc

(or whatever the file name is)

This is mine .. my conky file name is .conkyrc and it is in my home ~/

(sleep 3s && conky -c ~/.conkyrc) &

VSIDO | Words That Build Or Destroy

We do not run from challenges, they become new innovations within VSIDO!

Offline

#4 2013-03-08 07:21:03

Uchimata
Member
Registered: 2013-03-04
Posts: 20

Re: Conky at startup?

I tried everything, and it will still not start up on login.

I put the conkyrc into ~/, I tried all the commands here, and I still can't get it to open on start up. What's going on!?

Offline

#5 2013-03-08 12:53:20

iMBeCil
WAAAT?
From: Edrychwch o'ch cwmpas
Registered: 2012-03-22
Posts: 763
Website

Re: Conky at startup?

Uchimata, go to your home dir

$ cd $HOME

and post output of

$ pwd

and

$ ls -al | grep conky

Just to be sure we are talking about same files ...

Last edited by iMBeCil (2013-03-08 12:54:48)


Postpone all your duties; if you die, you won't have to do them ..

Offline

#6 2013-03-08 15:45:03

Uchimata
Member
Registered: 2013-03-04
Posts: 20

Re: Conky at startup?

For $ pwd: /home/nhkim
For $ grep: .conkyrc
                  .start-conky

Offline

#7 2013-03-08 15:47:35

VastOne
#! Ranger
From: V-Ger
Registered: 2011-04-26
Posts: 10,163
Website

Re: Conky at startup?

run this from terminal

conky -c .start-conky

If your conky starts, put this in your autostart

(sleep 3s && conky -c ~/.start-conky) &

VSIDO | Words That Build Or Destroy

We do not run from challenges, they become new innovations within VSIDO!

Offline

#8 2013-03-08 19:35:03

iMBeCil
WAAAT?
From: Edrychwch o'ch cwmpas
Registered: 2012-03-22
Posts: 763
Website

Re: Conky at startup?

@Uchimata:

To expand on VastOne's answer: you have two possible conky-related config: '.conkyrc' and '.start-conky'.

VastOne recommends one possibility.

Based on your first post, perhaps you might want to run:

$ conky -c .conkyrc

(beware of dots in file names)!
Anyway, this will show which one of the configs are one you want.

Where to put it in Mint, I have no idea ... sorry.

Last edited by iMBeCil (2013-03-08 19:35:37)


Postpone all your duties; if you die, you won't have to do them ..

Offline

#9 2013-03-09 00:27:51

ew
#! Die Hard
Registered: 2012-09-27
Posts: 1,975

Re: Conky at startup?

Do I understand it correctly? Your initial command still works from terminal, but it doesn`t work when you put this command in your startup-app list?  If that is the case, then I have some ideas. You are not using the same autostart mechanism as we do. We use openbox, and start Conky with the openbox autostart-file. This file probably doesn`t exist with you. But I don`t take it any further now, in case I have got it all wrong, and your initial command doesn`t work anymore...

If you could post your startup-app list and tell us the exact location of your .conkyrc, it would be helpful.... For example, in a lxde-distro I use, I start conky with "@conky-start", because I`ve made a shell-script with that name, and putted it in my "bin". But the list that I put "@conky-start" in, wouldn`t have worked with the usual "conky -c /home/user(/.conky)/.conkyrc" command.... Therfore, show us the list:)


- apt-mark hold account

Offline

#10 2013-03-09 07:33:00

Uchimata
Member
Registered: 2013-03-04
Posts: 20

Re: Conky at startup?

Hey.

So... yes. I am able to start conky with the lua script from terminal. Just typing "conky" brings up the default look.
In xfce, you can just go to settings > Session and Startup > Application Autostart (tab). There I have the typical things like pidgin (which just uses the command "pidgin"), Synapse, xfce stuff.

On that list, I added a command for conky. In the "Name" slot, I put "Conky." In the "Command" slot, I tried a bunch of different commands. I tried putting the conkyrc in ~/.conky/conkyrc  and in ~/.conkyrc. I made sure the file name was correct, tried putting in and taking out the "." Still nothing. Finally, I downloaded a start up file. In it, it has this:
#!/bin/sh
sleep 20
conky -d -c ~/.conkyrc
exit

... still nothing.

Offline

#11 2013-03-09 11:31:02

erghiez
Member
Registered: 2009-01-08
Posts: 25

Re: Conky at startup?

I actually downloaded mint14 xfce and run it in virtualbox to see whether I can replicate the problem. Funny thing is I managed to make it autorun in first try. What I did was

1. install conky using "apt-get install conky-all" Typing "conky" in terminal at this stage will run the default conky
2. there was no ~/.conkyrc in mint14 by default, so I copied my #! conky rc to mint14 ~/.conkyrc.
3. tried running conky in terminal by typing "conky", and I managed to run my #! conkyrc in mint14
4. add new item to Session and Startup, with "conky" as command, and I managed to make the conky autorun after rebooting.

Having said that, my conkyrc is just a simple script, showing cpu, ram, network status.

Can you share what your conky script? See whether I can autorun it in virtualbox?

Offline

#12 2013-03-09 14:19:26

iMBeCil
WAAAT?
From: Edrychwch o'ch cwmpas
Registered: 2012-03-22
Posts: 763
Website

Re: Conky at startup?

Uchimata wrote:

Finally, I downloaded a start up file. In it, it has this:
#!/bin/sh
sleep 20
conky -d -c ~/.conkyrc
exit

... still nothing.

Did you make above file executable with:

$ chmod u+x filename

In retrospective, I think that your 'conky' related command is not really executed during boot, for some reason.
Here is a possible (simple) way of checking if some command is executed during boot and when: in your startup file (whatever and wherever it is) comment out line with 'conky' with '#', and below put the command:

echo `date` > ~/delete-this-file

Now after each system boots, you should have file named 'delete-this-file' in your home dir, with the date and time when it has been created:

- if there is no such file, then this command hasn't been run at all, meaning that the appropriate startup file is not executed
- if file exists (you can open it and check when it is created), it means that something is probably wrong with your conky config file

(Of course, simple '$ ll ~/delete-this-file' will give same information ...)

Last edited by iMBeCil (2013-03-09 14:20:33)


Postpone all your duties; if you die, you won't have to do them ..

Offline

#13 2013-03-09 16:47:45

ew
#! Die Hard
Registered: 2012-09-27
Posts: 1,975

Re: Conky at startup?

Uchimata wrote:

Hey.

So... yes. I am able to start conky with the lua script from terminal. Just typing "conky" brings up the default look.
In xfce, you can just go to settings > Session and Startup > Application Autostart (tab). There I have the typical things like pidgin (which just uses the command "pidgin"), Synapse, xfce stuff.

On that list, I added a command for conky. In the "Name" slot, I put "Conky." In the "Command" slot, I tried a bunch of different commands. I tried putting the conkyrc in ~/.conky/conkyrc  and in ~/.conkyrc. I made sure the file name was correct, tried putting in and taking out the "." Still nothing. Finally, I downloaded a start up file. In it, it has this:
#!/bin/sh
sleep 20
conky -d -c ~/.conkyrc
exit

... still nothing.

Ok. You downloaded a startup-file, which looks ok provided your .conkyrc is directly in "/home/user/, but you can delete the "-d", and add a "&". Make it look like this:

conky -c ~/.conkyrc &

Now, where did you put the startup file and what did you call it? If you putted it in your private bin, then there is a chance that your bin is not working. Try to put the startup-file in "/usr/bin", make it executable, and name it with the command you want to start conky with. If you name it "conkystart", then use "conkystart" in the command slot in your application autostart. If you name the file conkystart.sh, then you also need to use the .sh in your command. Therefore, name the file with the command you want to use, without the file-extension. Test in terminal if your command works, if it does, then you should be ok. If your command works, but you still doesn`t get to autostart it, then do a little workaround like this: Create a text-file like this.

sudo geany /etc/xdg/autostart/conkystart.desktop

Copy the following text and paste it into the blank text-file that opens.

[Desktop Entry]
Name=conkystart
Exec=conkystart
Terminal=false
Type=Application

Provided your command works in terminal, then this will work. In the Exec-field, replace conkystart with whatever command that works for you in terminal. It can also be your initial command, but remember the "&" at the end if you use some form of this command: "conky -c ~/.conkyrc &". It`s extremely important.

Last edited by ew (2013-03-09 16:48:40)


- apt-mark hold account

Offline

#14 2013-03-17 07:52:30

Uchimata
Member
Registered: 2013-03-04
Posts: 20

Re: Conky at startup?

iMBeCil wrote:
Uchimata wrote:

Finally, I downloaded a start up file. In it, it has this:
#!/bin/sh
sleep 20
conky -d -c ~/.conkyrc
exit

... still nothing.

Did you make above file executable with:

$ chmod u+x filename

In retrospective, I think that your 'conky' related command is not really executed during boot, for some reason.
Here is a possible (simple) way of checking if some command is executed during boot and when: in your startup file (whatever and wherever it is) comment out line with 'conky' with '#', and below put the command:

echo `date` > ~/delete-this-file

Now after each system boots, you should have file named 'delete-this-file' in your home dir, with the date and time when it has been created:

- if there is no such file, then this command hasn't been run at all, meaning that the appropriate startup file is not executed
- if file exists (you can open it and check when it is created), it means that something is probably wrong with your conky config file

(Of course, simple '$ ll ~/delete-this-file' will give same information ...)

This worked. Thank you!

Offline

#15 2013-03-17 09:34:56

iMBeCil
WAAAT?
From: Edrychwch o'ch cwmpas
Registered: 2012-03-22
Posts: 763
Website

Re: Conky at startup?

No problem, thanks.

Just two small things:
- what exactly worked? 'chmod' thing or other one?
- could you please add word '[Solved]' to the topic title?
(those will possibly help other people with similar problems)


Postpone all your duties; if you die, you won't have to do them ..

Offline

#16 2013-10-01 19:22:33

wmatthews
New Member
Registered: 2013-10-01
Posts: 1

Re: Conky at startup?

I was having this same problem with XFCE4 on Gentoo. For some odd reason when you start conky when you log in, it will run but is hidden. I never thought of making it wait for 20 seconds before it actually started.

Great shit.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo