SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-03-08 00:05:06

xkyuz
New Member
Registered: 2013-03-07
Posts: 6

PowerMizer Issues

Hey there Cruchbangers,

I've been lurking the forums for many weeks, I really like the community. I don't really like posting, only when it's really necessary. So here it goes.

I have been having issues with my notebook's video card running crunchbang. It is a Thinkpad T510i with a Nvidia 3100m. The main issue is it is running hot because of the driver always putting the Nvidia PowerMizer settings the highest. The PowerMizer settings has 3 settings:

--- Graphics Clock --- Mem. Clock ----- Processor Clock
0 : 135 MHz -----------135 MHz -------- 270 MHz
1 : 405 MHz -----------405 MHz -------- 810 MHz
2 : 606 MHz -----------790 MHz -------- 1468 MHz

The interesting thing is, you should think if I am just browsing the web and reading news it should stay at option number 0 or at least at number 1. But no! If I even as switch the desktop in Openbox it goes up to option 2, so Processor 1468 MHz!! If you run that a long time your notebook begins to run very hot under your palms.

I have tried to put settings in xorg.conf as it says in this link. But unfortunate it still stays at the same settings as before and doesn't even behave a litte defferent. Just keeps turning the maximum settings for something as simple as desktop switching in Openbox.

I understand that if I am playing video games this higher clock is usefull, but not when I am browsing the web or writing code! It is absulutely not necessary to get the laptop this how when I am just browsing.

Can anybody please help me configre this mad notebook video card. Because surely it will break soon if it keeps up getting this hot every time I 'use' the notebook.

Thank you very much in advance!! cool

ps: I can not find the exact temperture of the video card, but I can feel it under my palm as I am typing this post. This is a Thinkpad and it should not do this normally. It is not supposed to get this hot under normal circumstances.

Offline

Be excellent to each other!

#2 2013-03-10 11:12:41

zubcho81
#! CrunchBanger
From: Sofia, Bulgaria
Registered: 2012-08-12
Posts: 184

Re: PowerMizer Issues

Try to remove compositing from autostart, or just comment it with # in the start of the line.

alt+F2 and type nvidia-settings and in the powermizer settings put the Preferred mode to adaptive.

In Iceweasel  click on Icewesel button then Preferences >> Advanced and remove the thick before "Use hardware acceleration when available"

Last edited by zubcho81 (2013-03-10 11:24:24)

Offline

#3 2013-03-10 16:24:27

xkyuz
New Member
Registered: 2013-03-07
Posts: 6

Re: PowerMizer Issues

zubcho81 wrote:

Try to remove compositing from autostart, or just comment it with # in the start of the line.

alt+F2 and type nvidia-settings and in the powermizer settings put the Preferred mode to adaptive.

In Iceweasel  click on Icewesel button then Preferences >> Advanced and remove the thick before "Use hardware acceleration when available"

I just did turn off the cb-compositor and not a lot has changed. Also I have put powermizer configs in the xorg.conf file so it should be effictive. But it still isn't. Because if I switch my desktop quickly it rises immedeatly to full power. In windows I never get any problems with this, only if I play any games the video card gets hot.

Now I am again writing this reply with a warmed up left palm.

Offline

#4 2013-03-11 02:17:19

ausmuso
Member
From: Blue Mountains, Australia
Registered: 2013-03-08
Posts: 32

Re: PowerMizer Issues

Hi xkyuz,
Have a look at this thread:
http://crunchbang.org/forums/viewtopic.php?id=23445
Good luck!
Cheers!


The trouble with having an open mind . . . .
  . . . . . . is people come and put things in it.

Offline

#5 2013-03-11 09:13:18

zubcho81
#! CrunchBanger
From: Sofia, Bulgaria
Registered: 2012-08-12
Posts: 184

Re: PowerMizer Issues

Do your laptop have a second video card? I mean intel video? If the answer is yes, you have to see this https://wiki.debian.org/Bumblebee#Installation

Offline

#6 2013-03-11 09:34:55

xkyuz
New Member
Registered: 2013-03-07
Posts: 6

Re: PowerMizer Issues

zubcho81 wrote:

Do your laptop have a second video card? I mean intel video? If the answer is yes, you have to see this https://wiki.debian.org/Bumblebee#Installation

No I don't have Nvidia Optimus so that is not the issue.

ausmuso wrote:

Hi xkyuz,
Have a look at this thread:
http://crunchbang.org/forums/viewtopic.php?id=23445
Good luck!
Cheers!

I just tried and implemented the powersaving in the grub file, but no results.

I think I am stuck, or I can underclock my nvidia card for the highest setting. neutral

Offline

#7 2013-03-11 10:38:55

xaos52
The Good Doctor
From: Planet of the @s
Registered: 2011-06-24
Posts: 4,595

Offline

#8 2013-03-11 21:05:39

xkyuz
New Member
Registered: 2013-03-07
Posts: 6

Re: PowerMizer Issues

I have set that option in xorg.conf under the Device settings. I haven't seen much changes today after I have changed it again. But hopefully this will change with an update of Nvidia drivers - currently running 304.64.

Thanks guys for the help. I shall try and find a solution for myself. If I do, I will post my solution in the comments.

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo