SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#26 2013-02-19 17:29:29

RobyIndie
New Member
Registered: 2013-02-19
Posts: 3

Re: Steam on #! Waldorf

I installed it, but I can't understand why I have to run steam in a root terminal, or it says command not found... that's annoying and I don't usually run applications as root user, is there a way to edit the script and make steam work for a normal user? I've seen zachr asking that but I don't see the answer.. could you explain me how you made it work for every user? big_smile

Offline

Help fund CrunchBang, donate to the project!

#27 2013-02-19 21:45:38

lobo86
New Member
Registered: 2013-02-09
Posts: 9

Re: Steam on #! Waldorf

RobyIndie wrote:

I installed it, but I can't understand why I have to run steam in a root terminal, or it says command not found... that's annoying and I don't usually run applications as root user, is there a way to edit the script and make steam work for a normal user? I've seen zachr asking that but I don't see the answer.. could you explain me how you made it work for every user? big_smile

Yeah, Don't run the script with sudo.

Offline

#28 2013-02-20 08:34:08

RobyIndie
New Member
Registered: 2013-02-19
Posts: 3

Re: Steam on #! Waldorf

lobo86 wrote:
RobyIndie wrote:

I installed it, but I can't understand why I have to run steam in a root terminal, or it says command not found... that's annoying and I don't usually run applications as root user, is there a way to edit the script and make steam work for a normal user? I've seen zachr asking that but I don't see the answer.. could you explain me how you made it work for every user? big_smile

Yeah, Don't run the script with sudo.

I don't think I did actually.... Oh well, I will test again! But how can I remove the existing steam root installation?

EDIT: Solved by removing everything that sounded steam-ish from /root/.local/Share/ (the steam folder and Steam in the applications folder). Then I reinstalled steam with the script wihout using sudo and I created a link in /usr/bin that points to /home/USERNAME/.local/Share/applitcations/Steam

Thanks for the script and enjoy playing! big_smile

Last edited by RobyIndie (2013-02-20 14:40:52)

Offline

#29 2013-02-22 18:42:12

Tim
#! CrunchBanger
From: SWeden
Registered: 2012-07-09
Posts: 149

Re: Steam on #! Waldorf

Steam works great and i really want to thank you for this thread smile its pure awesome!
But i just ran in to a "problem".
When iam in terminal "/home/tim/downloads/gist4231563-45bbf171953630f9b11acec71b8cc6fa70f0abe0/tree/usr/share/doc/steam#
" and entering 'steam' , steam starts and runs just fine.
But i cant enter steam anywhare in my terminal, and in that folder i cant find anything called steam or so, but it works. Its makes me confused. How do i add a shortcut to my 'rightclick menu'?


Crunchy feeling #!

Offline

#30 2013-02-22 22:46:32

incogn1to
#! CrunchBanger
From: Riga, Latvia
Registered: 2010-07-20
Posts: 125
Website

Re: Steam on #! Waldorf

Tim wrote:

Steam works great and i really want to thank you for this thread smile its pure awesome!
But i just ran in to a "problem".
When iam in terminal "/home/tim/downloads/gist4231563-45bbf171953630f9b11acec71b8cc6fa70f0abe0/tree/usr/share/doc/steam#
" and entering 'steam' , steam starts and runs just fine.
But i cant enter steam anywhare in my terminal, and in that folder i cant find anything called steam or so, but it works. Its makes me confused. How do i add a shortcut to my 'rightclick menu'?

You can add it to menu as

~/.steam/steam/steam_on_debian.sh

because shell file that launches steam is actually located in your home directory.

PS You are welcome smile


Don't let anyone ever make you feel like you don't deserve what you want
Samsung 535U3C

Offline

#31 2013-02-23 09:12:16

Tim
#! CrunchBanger
From: SWeden
Registered: 2012-07-09
Posts: 149

Re: Steam on #! Waldorf

In my home folder, /home/tim/.steam/steam_on_debian.sh ,
its just a emty folder.
And when iam trying to add that line or ~/.steam/steam/steam_on_debian.sh im getting this message:
translating from swedish:
cannot find childproccess, , /home/tim/.steam/steam_on_debian.sh, catalog or file do not exist.

I dont get it, what am i missing?  Sorry for my bad English  monkey


Edit

The only way around i can get this to work is:
1361611603-sk--rmbild---2013-02-23---10-32-03-png.png
When iam in that directory, rightclicking 'open in terminal', enter steam. And steam starts.

Last edited by Tim (2013-02-23 09:34:23)


Crunchy feeling #!

Offline

#32 2013-02-23 13:01:28

incogn1to
#! CrunchBanger
From: Riga, Latvia
Registered: 2010-07-20
Posts: 125
Website

Re: Steam on #! Waldorf

Tim wrote:

In my home folder, /home/tim/.steam/steam_on_debian.sh ,
its just a emty folder.
And when iam trying to add that line or ~/.steam/steam/steam_on_debian.sh im getting this message:
translating from swedish:
cannot find childproccess, , /home/tim/.steam/steam_on_debian.sh, catalog or file do not exist.

I dont get it, what am i missing?  Sorry for my bad English  monkey


Edit

The only way around i can get this to work is:
http://imup.info/u/data/2013/2/23/13616 … 03-png.png
When iam in that directory, rightclicking 'open in terminal', enter steam. And steam starts.

try

/home/tim/.steam/steam/steam_on_debian.sh

or let us see, what do you have in your .steam folder

ls ~/.steam

Last edited by incogn1to (2013-02-23 13:03:27)


Don't let anyone ever make you feel like you don't deserve what you want
Samsung 535U3C

Offline

#33 2013-02-23 15:21:26

Tim
#! CrunchBanger
From: SWeden
Registered: 2012-07-09
Posts: 149

Re: Steam on #! Waldorf

Well in .steam there is nothing at all.

tim@crang:~$ ls ~/.steam
tim@crang:~$ 

Thats the strange part i guess, as i can se in the script it should be installing in that directory, but it does not.
If i use catfish for searching 'steam' i get this.
1361632453-sk--rmbild---2013-02-23---16-20-18-png.png
There you have everything steamish the cat can find. smile
Thanks for your time


Crunchy feeling #!

Offline

#34 2013-02-23 22:56:01

incogn1to
#! CrunchBanger
From: Riga, Latvia
Registered: 2010-07-20
Posts: 125
Website

Re: Steam on #! Waldorf

Is it possible, that you installed steam as root? It may be located in /root.


Don't let anyone ever make you feel like you don't deserve what you want
Samsung 535U3C

Offline

#35 2013-02-24 08:25:58

Tim
#! CrunchBanger
From: SWeden
Registered: 2012-07-09
Posts: 149

Re: Steam on #! Waldorf

i really dont have a clue, my /root folder is almoast emtyp. The only think located there is somthing called destop.
When in desktop this is what i see:
root@crang:~/Desktop# pwd
/root/Desktop
root@crang:~/Desktop# ls
Counter-Strike.desktop


Crunchy feeling #!

Offline

#36 2013-02-24 09:18:20

incogn1to
#! CrunchBanger
From: Riga, Latvia
Registered: 2010-07-20
Posts: 125
Website

Re: Steam on #! Waldorf

is there a /root/.stream folder?
try

ls -a /root/.steam

Don't let anyone ever make you feel like you don't deserve what you want
Samsung 535U3C

Offline

#37 2013-02-24 12:49:00

Tim
#! CrunchBanger
From: SWeden
Registered: 2012-07-09
Posts: 149

Re: Steam on #! Waldorf

tim@crang:~$ ls -a /root/.steam


.   bin    bin64     root    sdk64  steam_install_agreement.txt  steam.pipe
..  bin32  registry.vdf  sdk32    steam  steam.pid

edit:

if i:

root@crang:/home/tim# cd ~/.steam
root@crang:~/.steam# steam
Running Steam on debian 7.0 32-bit
STEAM_RUNTIME is enabled automatically
....
....
....
....

Steam starts if im in ~/.steam#
as root i guess

edit2:
If im in  ~/.steam as root i can open steam. Otherwise i can not.
what i can see, the folder is also empty?
Confused a bit  roll

Last edited by Tim (2013-02-24 12:57:30)


Crunchy feeling #!

Offline

#38 2013-02-24 21:07:55

incogn1to
#! CrunchBanger
From: Riga, Latvia
Registered: 2010-07-20
Posts: 125
Website

Re: Steam on #! Waldorf

Tim wrote:

tim@crang:~$ ls -a /root/.steam


.   bin    bin64     root    sdk64  steam_install_agreement.txt  steam.pipe
..  bin32  registry.vdf  sdk32    steam  steam.pid

edit:

if i:

root@crang:/home/tim# cd ~/.steam
root@crang:~/.steam# steam
Running Steam on debian 7.0 32-bit
STEAM_RUNTIME is enabled automatically
....
....
....
....

Steam starts if im in ~/.steam#
as root i guess

edit2:
If im in  ~/.steam as root i can open steam. Otherwise i can not.
what i can see, the folder is also empty?
Confused a bit  roll

You've installed your steam in your root folder.
So right shortcut in your case will be /root/.steam/steam/steam_on_debian.sh
But I would suggest you to reinstall steam as normal user.


Don't let anyone ever make you feel like you don't deserve what you want
Samsung 535U3C

Offline

#39 2013-04-05 20:32:55

sillysocks
New Member
From: Chicago
Registered: 2013-04-05
Posts: 2
Website

Re: Steam on #! Waldorf

Thank you for this script and guide, incogn1to!  I have steam running on my Eee PC now. big_smile

I only needed to do steps 1, 2, 3, 4, and 7 since I am running 32-bit. Also, just a note: When I typed steam in Terminal, it started to update but then stopped with "fatal error." I closed it down. Then I just typed steam in Terminal again (definition of insanity? haha) and it worked this time!

Only a fraction of the games in my library are available to play on Linux, but hopefully more will be ported over someday.

Offline

#40 2013-04-06 03:39:37

Orcgo
New Member
Registered: 2013-04-05
Posts: 1

Re: Steam on #! Waldorf

When I try to install the dependencies I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libgl1-mesa-glx
E: Unable to locate package libgl1-mesa-dri
E: Unable to locate package libcurl3-gnutls
E: Unable to locate package libogg0
E: Unable to locate package libpixman-1-0
E: Unable to locate package libsdl1.2debian
E: Couldn't find any package by regex 'libsdl1.2debian'
E: Unable to locate package libtheora0
E: Unable to locate package libvorbis0a
E: Unable to locate package libvorbisenc2
E: Unable to locate package libvorbisfile3
E: Unable to locate package libasound2
E: Unable to locate package libc6
E: Unable to locate package libcairo2
E: Unable to locate package libcups2
E: Unable to locate package libdbus-1-3
E: Unable to locate package libfontconfig1
E: Unable to locate package libfreetype6
E: Unable to locate package libgcc1
E: Unable to locate package libgcrypt11
E: Unable to locate package libgdk-pixbuf2.0-0
E: Couldn't find any package by regex 'libgdk-pixbuf2.0-0'
E: Unable to locate package libglib2.0-0
E: Couldn't find any package by regex 'libglib2.0-0'
E: Unable to locate package libgtk2.0-0
E: Couldn't find any package by regex 'libgtk2.0-0'
E: Unable to locate package libnspr4
E: Unable to locate package libnss3
E: Unable to locate package libopenal1
E: Unable to locate package libpango1.0-0
E: Couldn't find any package by regex 'libpango1.0-0'
E: Unable to locate package libpng12-0
E: Unable to locate package libpulse0
E: Unable to locate package libstdc++6
E: Couldn't find any package by regex 'libstdc++6'
E: Unable to locate package libx11-6
E: Unable to locate package libxext6
E: Unable to locate package libxfixes3
E: Unable to locate package libxi6
E: Unable to locate package libxrandr2
E: Unable to locate package libxrender1
E: Unable to locate package zlib1g


Am I missing a repo? Still new to linux.

Also, when I tried to run steam w/o all those dependencies, it told me I only needed libc.so.6. Do I need all of them?

Last edited by Orcgo (2013-04-06 03:43:05)

Offline

#41 2013-04-06 03:58:55

eliezer40
New Member
Registered: 2013-03-28
Posts: 5

Re: Steam on #! Waldorf

Very nice. Thank you.

Offline

#42 2013-04-09 22:05:42

Xxiled
New Member
Registered: 2013-04-06
Posts: 3

Re: Steam on #! Waldorf

Amazing! Thanks for this!

Offline

#43 2013-04-14 21:46:25

stolid
#! CrunchBanger
Registered: 2012-09-06
Posts: 206

Re: Steam on #! Waldorf

I think we may soon be able to apt-get install steam from experimental. big_smile
http://packages.qa.debian.org/s/steam.html

Last edited by stolid (2013-04-14 21:46:48)


Registered Linux User #555399
crunchbox:     Phenom II X6 1055T | 8GB RAM | OCZ Vertex 4 128GB | Radeon 7870XT | Win7 / #! 11 (i3 WM)
lambdacore:     4x Opteron 8431 | 16GB RAM | 2x1TB mirrored (ZFSoL) | Debian 7 (headless)
crunchtop:     Acer Aspire 1410 11.6" | 2GB RAM | Crucial M4 128GB | #! 11 (i3 WM)

Offline

#44 2013-05-17 19:42:29

incogn1to
#! CrunchBanger
From: Riga, Latvia
Registered: 2010-07-20
Posts: 125
Website

Re: Steam on #! Waldorf

If you encountered problems launching steam after latest updates just edit

~/.local/share/Steam/debian_bin/steam

and change it to:

#!/bin/sh
exec "~/.steam/steam/steam.sh" ""

Last edited by incogn1to (2013-05-18 20:49:29)


Don't let anyone ever make you feel like you don't deserve what you want
Samsung 535U3C

Offline

#45 2013-08-01 12:19:12

ohyran
#! Member
From: Sweden
Registered: 2013-05-31
Posts: 77
Website

Re: Steam on #! Waldorf

Ok so this may be bumping an ancient thread but I'm planning on installing steam for my #! 64bit installation which is set to Sid instead of Wheezy aaaand I'm kinda wondering if anyone knows if this might work at all or if I'll end up with everything borked beyond belief (the BBB)?


>>>I draw pretty pictures for a living!<<<
>>>>>>>>>>>>#! Animal<<<<<<<<<<<<

Offline

#46 2013-08-04 09:41:53

ohyran
#! Member
From: Sweden
Registered: 2013-05-31
Posts: 77
Website

Re: Steam on #! Waldorf

Ok I tried installing (even managed not to mess up the download of the script even though I too ran into that "root" thing and now I have to go dig out the folders and delete them) but ran into a little hitch when rebooting and writing in "steam".

In a normal terminal window I get...

Running Steam on debian  64-bit
STEAM_RUNTIME is enabled automatically
/home/jens/.local/share/Steam/steam.sh: rad 704:  2761 Segmenteringsfel        $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Error: Couldn't start bootstrap and couldn't reinstall from /usr/lib/steam/bootstraplinux_ubuntu12_32.tar.xz.  Please contact technical support.
/home/jens/.local/share/Steam/steam.sh: rad 42:  2773 Segmenteringsfel        zenity "$style" --text="$*" 2> /dev/null

and then in that steam-pop-up terminal I get this... (the latter part from the "normal terminal"

Couldn't start bootstrap and couldn't reinstall from /usr/lib/steam/bootstraplinux_ubuntu12_32.tar.gz. Please contact technincal support.

Should I be doing something between reboot and "steam"? Is there a step I'm missing out on


>>>I draw pretty pictures for a living!<<<
>>>>>>>>>>>>#! Animal<<<<<<<<<<<<

Offline

#47 2013-08-10 07:24:36

woof
Member
Registered: 2012-06-11
Posts: 45

Re: Steam on #! Waldorf

Thanks to this guide steam is now installed on my acer aspire one with waldorf 32bit. i have played hl1 already and it works. smile

1st attempt i used this guide.. http://steamcommunity.com/sharedfiles/f … =144277542 failed to install the libc v2.15 and lib-bin so gave up..

2nd attempt... http://crunchbang.org/forums/viewtopic.php?id=24711 that also stumped me  roll

Now im a happy linux gamer thanks incogn1to

Offline

#48 2013-08-12 07:17:18

stolid
#! CrunchBanger
Registered: 2012-09-06
Posts: 206

Re: Steam on #! Waldorf

If you're running testing (jessie) or sid, just install it from the repository (apt-get install steam) for a pain-free experience. It worked for me...

If you're running 64-bit, make sure you've enabled multiarch. Also, I found out I had to install a 32-bit libgl package for Steam to load with my graphics.


Registered Linux User #555399
crunchbox:     Phenom II X6 1055T | 8GB RAM | OCZ Vertex 4 128GB | Radeon 7870XT | Win7 / #! 11 (i3 WM)
lambdacore:     4x Opteron 8431 | 16GB RAM | 2x1TB mirrored (ZFSoL) | Debian 7 (headless)
crunchtop:     Acer Aspire 1410 11.6" | 2GB RAM | Crucial M4 128GB | #! 11 (i3 WM)

Offline

#49 2013-09-28 02:56:09

trollhammer
New Member
Registered: 2013-09-28
Posts: 1

Re: Steam on #! Waldorf

For the 64bit install do I need to have an AMD chip or will it also work with Intel???

Offline

Help fund CrunchBang, donate to the project!

#50 2013-12-02 01:06:21

BrightEyesDavid
New Member
Registered: 2013-12-02
Posts: 2

Re: Steam on #! Waldorf

I'm running Waldorf 64-bit. The link to the Ubuntu Glibc in that install script seems to be out of date and no longer available, so I commented out the relevant lines and used this version instead, from here. I extracted the deb archive and copied all the files in the 'lib/i386-linux-gnu' directory into '~/.local/share/Steam/ubuntu12_32', and now I'm able to run steam. (Thinking about it, maybe I should have simply changed the link!)

Running Steam with 'steam' at the terminal does give a warning about the 32-bit 'libc.so.6' being missing, saying "Steam may not run" and "Press enter to continue", but it does run. If anyone has any guidance on how to avoid the warning, please let me know.

To do things more cleanly, I think I could have done this instead.

However, next time I'm going to try using GhostSquad57's re-write of Valve's deb package for Wheezy, found via this thread, as that looks nice and easy. smile

stolid wrote:

I think we may soon be able to apt-get install steam from experimental. big_smile
http://packages.qa.debian.org/s/steam.html

I'm not at all experienced with using apt-get in anything other than simple ways, and using experimental, etc. Is doing this an option yet?

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo