SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2013-01-13 14:06:41

gebeer
Member
Registered: 2013-01-11
Posts: 12

Slow write speed - Thunar script to dd to USB

Hello,

I'm on a fresh install of #!Waldorf, have done a dist-upgrade and experience very slow write speeds to USB, especially with large files. I know this problem from my Ubuntu install. There it has been solved by the devs already.

Now this seems to be a common problem with the 3.2.0-3-amd64 kernel from what I read on Debian Bug Tracker: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=684630
And it seems to still exist after dist-upgrade to 3.2.0-4-amd64

There are suggested solutions from https://bbs.archlinux.org/viewtopic.php … 6#p1033186 that don't seem to help with #!

Another suggestion I found at http://forums.debian.net/viewtopic.php? … =0#p450178 involves the dd command like:

dd if=myfile of=/media/usb0/myfile oflag=direct obs=64k

I tried it with a 1.5G file and it worked like a charm.

Now I'm looking into making a custom action for Thunar. Something like:

dd if=%f of=/media/NAME_OF_MOUNTPOINT/%N oflag=direct obs=64k

And here's where the trouble starts.

I need to have a bash script that detects the inserted USB flash drive and it's mount point so I can replace NAME_OF_MOUNTPOINT with the proper mount point.

After a search I found some potential solutions at http://www.unix.com/shell-programming-s … rives.html. But they seem to be quite complicated. The one's I tried, didn't work on my system.

Anyways, in the Thunar right click menu there is an entry 'Send to' which nicely lists all mounted USB drives. So why not use that code, I thought.

But I can't find the relevant code. It is neither in ~/.local/share/Thunar/sendto nor in /usr/share/Thunar/sendto/

Can anybody help putting together that custom action or, even better, provide a general fix for the slow write speed in wheezy?

Cheers
gerhard

Last edited by gebeer (2013-01-13 15:01:58)

Offline

Help fund CrunchBang, donate to the project!

#2 2013-01-17 14:57:08

jotapesse
#! Junkie
From: Algarve, Portugal
Registered: 2009-02-07
Posts: 377

Re: Slow write speed - Thunar script to dd to USB

You may obtain the mountpoint with the following:

mount | grep -o "/media/usb[0-9]"/%N

Regarding slow usb speeds, try to adjust tlhe block option on dd, this works fine for me:

dd bs=1M if=%f of=`mount | grep -o "/media/usb[0-9]"`/%N

Last edited by jotapesse (2013-01-17 14:59:12)


On an ASRock VisionX 321B, Asus EeeBoxPC 1501P and EeePC 1000H with Debian Sid/Experimental Xfce 4.10 Linux
Outdated How to: Install Xfce 4.10 with upgraded Apps and Plugins

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo