SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2011-09-22 20:23:24

burton247
#! CrunchBanger
Registered: 2011-01-08
Posts: 114
Website

Stop f10 bringing up the menu bar?

I can't find out where this behaviour is configured. I have searched online and looking in the openbox config file but cannot work it out. If I press f10 the menu bar of the window becomes active but I would like to bind f10 to something in code::blocks but it keeps jumping me to the menu.

Does anyone know where this is configured?

Thanks


My person website, Michael Burton

Offline

Help fund CrunchBang, donate to the project!

#2 2011-09-22 20:37:07

CBizgreat!
#! Die Hard
Registered: 2011-07-27
Posts: 1,476

Re: Stop f10 bringing up the menu bar?

Don't quote me on this. But more than likely, look for it under.

Right click/main menu>Settings>Openbox Config>Edit rc.xml

Should be able to change it there. After you're done, save the file of course, to save your changes. Then click on Reconfigure in the Openbox Config menu.

Last edited by CBizgreat! (2011-09-22 20:39:03)


Some common cbiz abbreviations. This will save me time and yet @ same time tell folks what the babble is supposed to mean.

Vll ! = ( Viva la gnu/Linux !)    Vl#!! = ( Viva la #! !)    Last but not least, UD ... OD ! = ( Use Debian ... or die !) tongue

Offline

#3 2011-09-22 20:47:16

burton247
#! CrunchBanger
Registered: 2011-01-08
Posts: 114
Website

Re: Stop f10 bringing up the menu bar?

That was the first place I looked! I can't find any references to f10 in there sad


My person website, Michael Burton

Offline

#4 2011-09-22 22:24:00

CBizgreat!
#! Die Hard
Registered: 2011-07-27
Posts: 1,476

Re: Stop f10 bringing up the menu bar?

Hmmm sorry, that's what the don't quote me was about. Should be a file search option for gedit or whatever text editor you're using. Guess couldn't hurt to search for F10 and etc in the rc.xml file. I've changed so many things in this #! install, wouldn't begin to be able to know which did what and when. My F10 key doesn't pop up that annoying menu anymore though. So somewhere along the way I must've discovered where to disable it.

Keep checking around and you're sure to find it.

Last edited by CBizgreat! (2011-09-22 22:26:04)


Some common cbiz abbreviations. This will save me time and yet @ same time tell folks what the babble is supposed to mean.

Vll ! = ( Viva la gnu/Linux !)    Vl#!! = ( Viva la #! !)    Last but not least, UD ... OD ! = ( Use Debian ... or die !) tongue

Offline

#5 2013-01-13 21:07:33

criba
New Member
Registered: 2013-01-06
Posts: 3

Re: Stop f10 bringing up the menu bar?

I don't know if I should start a new topic (since this one it's pretty old)...
Here is the solution I found to stop the F10 keybind work in terminal windows:
In ~/.gtkrk-2.0.mine I added

binding "NoKeyboardNavigation" {
        unbind "<shift>F10"
        unbind "F10"
}

class "*" binding "NoKeyboardNavigation"

Now I can exit mc without the annoying menu smile

CB

Last edited by criba (2013-01-13 21:08:12)

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo