SEARCH

Enter your search query in the box above ^, or use the forum search tool.

You are not logged in.

#1 2010-10-09 05:28:21

tshann
#! Member
Registered: 2009-09-07
Posts: 96

How I solved Hibernate in Statler

I've used this method with only two Statler installs - so of course - ymmv. I've tried it on my HP Pavilion DV5 Lappie (4 gigs, 2 ghz core 2 duo) and my Dell Optiplex 210L (3 ghz HT 1.5 gigs Ram). Both installs are Statler A2 Xfce x64. It works on them both equally well. Here's what I did (googled around and found various parts from the mint forum and others):

Run

blkid | grep swap

in terminal - gives uuid for swap, retain this information
Confirm uuid is same in /etc/fstab - if not,  make it so

Create a file (as root) called resume in the /etc/initramfs-tools/conf.d directory
( on my rig, there was no resume file here)

insert the following line in that file:

RESUME=UUID=Your Swap's UUID

Save
Run @ terminal:

[sudo] update-initramfs -u

open the /etc/default/grub file (as root)
Insert the following line:

GRUB_CMDLINE_LINUX="RESUME=UUID=your swap uuid"

(you do need the quotes around this phrase as far as I know)

Run

[sudo] update-grub

On both of my rigs, this gave me the ability to restore from hibernate - which was the problem I was having. So you should be able to use standard hibernate OR run the hibernate script (need to install from synaptic). On my rig, both work after doing the above.

If you've installed the hibernate script, just run [sudo] hibernate to activate it. I've not seen an appreciable difference between running the hibernate script or just hitting hibernate after clicking the logout on the menu. So might just as well use hibernate on the log out menu for simplicity's sake.

Would be nice to add this as a fix option in the cb-welcome script. Something that says "fix hibernate?" or something like that.

Hope this helps others.


   Peace

Offline

Be excellent to each other!

#2 2010-10-09 09:42:12

Tunafish
#! Die Hard
From: the Netherlands
Registered: 2010-03-07
Posts: 1,204

Re: How I solved Hibernate in Statler

Thanks a lot!
I have hibernate working on my laptop now...
don't know if'll ever use it, i just couldn't accept it was not working smile


sed 's/stress/relaxation/g'
Privacy & Security on #!

Offline

#3 2010-10-09 17:51:10

johnraff
#!Drunkard
From: Nagoya, Japan
Registered: 2009-01-07
Posts: 2,870
Website

Re: How I solved Hibernate in Statler

Tshann thank you! It worked perfectly on this Sony Vaio laptop cool

btw if you want a command to go into hibernate (or suspend) without having to use sudo, these work for me:

 dbus-send --session --type=method_call --print-reply --dest="org.freedesktop.PowerManagement" --reply-timeout=2000 /org/freedesktop/PowerManagement org.freedesktop.PowerManagement.Hibernate

and

 dbus-send --session --type=method_call --print-reply --dest="org.freedesktop.PowerManagement" --reply-timeout=2000 /org/freedesktop/PowerManagement org.freedesktop.PowerManagement.Suspend

(The "reply-timeout" option might be, er, optional.)


John
--------------------
( a boring Japan blog , idle twitterings  and GitStuff )
#! forum moderator

Offline

#4 2010-10-09 20:18:25

SuperOscar
Member
From: Joensuu, Finland
Registered: 2010-09-30
Posts: 29
Website

Re: How I solved Hibernate in Statler

Yay! It works on Samsung’s N140 netbook as well. Now the only problem I had with Statler has gone away.

Thank you so much!


My armada: Arch (desktop, test machine), Debian GNU/Linux 6.0 (laptop, netbook, server), Mythbuntu 11.04 (HTPC), Windows 7 Ultimate (test machine)

Offline

#5 2010-10-12 13:14:16

Tunafish
#! Die Hard
From: the Netherlands
Registered: 2010-03-07
Posts: 1,204

Re: How I solved Hibernate in Statler

I use the xfce power manager to hibernate... works without password as well.

Another option is to disable the password for pm-suspend and pm-hibernate in the sudoers file:
http://wiki.archlinux.org/index.php/Pm- … gular_user

Tuna.


sed 's/stress/relaxation/g'
Privacy & Security on #!

Offline

#6 2010-11-23 16:16:27

paulorccanuto
New Member
From: Presidente Médici, Rondônia-BR
Registered: 2010-11-10
Posts: 3

Re: How I solved Hibernate in Statler

Works very well for me. Thank you!


####    UPDATE  -  HELP!    ####

I do a fresh install on my notebook using the last crunchbang alpha release, so, i can't use this method anymore.
There are no uuid data on fstab:

# UNCONFIGURED FSTAB FOR BASE SYSTEM
proc    /proc   proc    nodev,noexec,nosuid     0       0
/dev/sda4       /opt    ext4    rw,errors=remount-ro    0       0
/dev/sda5       /home   ext4    rw,errors=remount-ro    0       0
/dev/sda1       /boot   ext2    rw,errors=remount-ro    0       0
/dev/sda2       swap    swap    defaults        0       0
/dev/sda3       /       ext4    rw,errors=remount-ro    0       0

How can i proceed to get hibernation using the method presented in this topic?


Sorry for my english cool

Last edited by paulorccanuto (2011-01-28 00:03:38)


If you wish to make an apple pie from scratch, you must first invent the universe.
— Carl Sagan

Offline

Board footer

Powered by FluxBB

Copyright © 2012 CrunchBang Linux.
Proudly powered by Debian. Hosted by Linode.
Debian is a registered trademark of Software in the Public Interest, Inc.

Debian Logo